ID CVE-2017-0889
Summary Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.
References
Vulnerable Configurations
  • Thoughtbot Paperclip for Ruby 4.2.1
    cpe:2.3:a:thoughtbot:paperclip:4.2.1:-:-:-:-:ruby
CVSS
Base: 7.5
Impact:
Exploitability:
CWE CWE-918
CAPEC
refmap via4
confirm https://github.com/thoughtbot/paperclip/pull/2435
misc
Last major update 13-11-2017 - 12:29
Published 13-11-2017 - 12:29
Last modified 29-11-2017 - 12:27
Back to Top