ID CVE-2016-8526
Summary Aruba Airwave all versions up to, but not including, 8.2.3.1 is vulnerable to an XML external entities (XXE). XXEs are a way to permit XML parsers to access storage that exist on external systems. If an unprivileged user is permitted to control the contents of XML files, XXE can be used as an attack vector. Because the XML parser has access to the local filesystem and runs with the permissions of the web server, it can access any file that is readable by the web server and copy it to an external system of the attacker's choosing. This could include files that contain passwords, which could then lead to privilege escalation.
References
Vulnerable Configurations
  • cpe:2.3:a:hp:airwave:8.0.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.6.3:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.6.3:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.7.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.7.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.7.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.8.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.9.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.9.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.9.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.9.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.9.2:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.9.2:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.0.11.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.0.11.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:hp:airwave:8.2.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:hp:airwave:8.2.3.0:*:*:*:*:*:*:*
CVSS
Base: 4.0 (as of 16-10-2018 - 20:26)
Impact:
Exploitability:
CWE CWE-611
CAPEC
  • XML External Entities Blowup
    This attack takes advantage of the entity replacement property of XML where the value of the replacement is a URI. A well-crafted XML document could have the entity refer to a URI that consumes a large amount of resources to create a denial of service condition. This can cause the system to either freeze, crash, or execute arbitrary code depending on the URI.
Access
VectorComplexityAuthentication
NETWORK LOW SINGLE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
cvss-vector via4 AV:N/AC:L/Au:S/C:P/I:N/A:N
refmap via4
bid 96495
confirm http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-001.txt
exploit-db 41482
Last major update 16-10-2018 - 20:26
Published 06-08-2018 - 20:29
Back to Top