ID CVE-2016-8515
Summary A remote malicious file upload vulnerability in HPE Version Control Repository Manager (VCRM) was found. The problem impacts all versions prior to 7.6.
References
Vulnerable Configurations
  • HP Version Control Repository Manager
    cpe:2.3:a:hp:version_control_repository_manager
  • HP Version Control Repository Manager 1.0.1288.1
    cpe:2.3:a:hp:version_control_repository_manager:1.0.1288.1
  • HP Version Control Repository Manager 1.0.2241.0
    cpe:2.3:a:hp:version_control_repository_manager:1.0.2241.0
  • HP Version Control Repository Manager 1.0.2289.0
    cpe:2.3:a:hp:version_control_repository_manager:1.0.2289.0
  • HP Version Control Repository Manager 1.0.2345.0
    cpe:2.3:a:hp:version_control_repository_manager:1.0.2345.0
  • HP Version Control Repository Manager 1.0.3085.0
    cpe:2.3:a:hp:version_control_repository_manager:1.0.3085.0
  • HP Version Control Repository Manager 1.0.3086.0
    cpe:2.3:a:hp:version_control_repository_manager:1.0.3086.0
  • HP Version Control Repository Manager 2.0.0.50
    cpe:2.3:a:hp:version_control_repository_manager:2.0.0.50
  • HP Version Control Repository Manager 2.0.1.30
    cpe:2.3:a:hp:version_control_repository_manager:2.0.1.30
  • HP Version Control Repository Manager 2.1.1.7.10
    cpe:2.3:a:hp:version_control_repository_manager:2.1.1.710
  • HP Version Control Repository Manager 2.1.1.720
    cpe:2.3:a:hp:version_control_repository_manager:2.1.1.720
  • HP Version Control Repository Manager 6.3.0.870
    cpe:2.3:a:hp:version_control_repository_manager:6.3.0.870
  • HP Version Control Repository Manager 7.4.0
    cpe:2.3:a:hp:version_control_repository_manager:7.4.0
CVSS
Base: 6.5
Impact:
Exploitability:
CWE CWE-434
CAPEC
  • Accessing Functionality Not Properly Constrained by ACLs
    In applications, particularly web applications, access to functionality is mitigated by the authorization framework, whose job it is to map ACLs to elements of the application's functionality; particularly URL's for web apps. In the case that the administrator failed to specify an ACL for a particular element, an attacker may be able to access it with impunity. An attacker with the ability to access functionality not properly constrained by ACLs can obtain sensitive information and possibly compromise the entire application. Such an attacker can access resources that must be available only to users at a higher privilege level, can access management sections of the application or can run queries for data that he is otherwise not supposed to.
  • Privilege Abuse
    An adversary is able to exploit features of the target that should be reserved for privileged users or administrators but are exposed to use by lower or non-privileged accounts. Access to sensitive information and functionality must be controlled to ensure that only authorized users are able to access these resources. If access control mechanisms are absent or misconfigured, a user may be able to access resources that are intended only for higher level users. An adversary may be able to exploit this to utilize a less trusted account to gain information and perform activities reserved for more trusted accounts. This attack differs from privilege escalation and other privilege stealing attacks in that the adversary never actually escalates their privileges but instead is able to use a lesser degree of privilege to access resources that should be (but are not) reserved for higher privilege accounts. Likewise, the adversary does not exploit trust or subvert systems - all control functionality is working as configured but the configuration does not adequately protect sensitive resources at an appropriate level.
nessus via4
  • NASL family Misc.
    NASL id HP_VERSION_CONTROL_REPO_MANAGER_7_6_0_NIX.NASL
    description According to its self-reported version, the HP Version Control Repository Manager (VCRM) application installed on the remote Linux host is prior to 7.6.0. It is, therefore, affected by multiple vulnerabilities : - A cross-site request forgery (XSRF) vulnerability exists in VCRM due to HTTP requests not requiring multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit this, by convincing a user into following a specially crafted link, to perform unspecified actions. (CVE-2016-8513) - An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to disclose potentially sensitive information. (CVE-2016-8514) - An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to upload arbitrary files. (CVE-2016-8515) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 96722
    published 2017-01-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=96722
    title HP Version Control Repository Manager for Linux < 7.6.0 Multiple Vulnerabilities
  • NASL family Windows
    NASL id HP_VERSION_CONTROL_REPO_MANAGER_7_6_0_0.NASL
    description According to its self-reported version, the HP Version Control Repository Manager (VCRM) application installed on the remote Windows host is prior to 7.6.0. It is, therefore, affected by multiple vulnerabilities : - A denial of service vulnerability exists in OpenSSL in x509_vfy.c due to improper handling of certificate revocation lists (CRLs). An unauthenticated, remote attacker can exploit this, via a specially crafted CRL, to cause a NULL pointer dereference, resulting in a crash of the service. (CVE-2016-7052) - A cross-site request forgery (XSRF) vulnerability exists in VCRM due to HTTP requests not requiring multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. An unauthenticated, remote attacker can exploit this, by convincing a user into following a specially crafted link, to perform unspecified actions. (CVE-2016-8513) - An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to disclose potentially sensitive information. (CVE-2016-8514) - An unspecified flaw exists in VCRM that allows an authenticated, remote attacker to upload arbitrary files. (CVE-2016-8515) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 96721
    published 2017-01-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=96721
    title HP Version Control Repository Manager < 7.6.0 Multiple Vulnerabilities
refmap via4
bid 94949
confirm
sectrack 1037485
Last major update 15-02-2018 - 17:29
Published 15-02-2018 - 17:29
Last modified 06-03-2018 - 10:11
Back to Top