ID CVE-2016-7643
Summary An issue was discovered in certain Apple products. iOS before 10.2 is affected. macOS before 10.12.2 is affected. watchOS before 3.1.3 is affected. The issue involves the "ImageIO" component. It allows remote attackers to obtain sensitive information from process memory or cause a denial of service (out-of-bounds read and application crash) via a crafted web site.
References
Vulnerable Configurations
  • Apple iPhone OS 10.1.1
    cpe:2.3:o:apple:iphone_os:10.1.1
  • Apple Mac OS X 10.12.1
    cpe:2.3:o:apple:mac_os_x:10.12.1
  • Apple WatchOS 2.2.2
    cpe:2.3:o:apple:watchos:2.2.2
CVSS
Base: 5.8 (as of 21-02-2017 - 17:33)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE PARTIAL
nessus via4
NASL family MacOS X Local Security Checks
NASL id MACOS_10_12_2.NASL
description The remote host is running a version of macOS that is 10.12.x prior to 10.12.2. It is, therefore, affected by multiple vulnerabilities in the following components : - apache_mod_php - AppleGraphicsPowerManagement - Assets - Audio - Bluetooth - CoreCapture - CoreFoundation - CoreGraphics - CoreMedia External Displays - CoreMedia Playback - CoreStorage - CoreText - curl - Directory Services - Disk Images - FontParser - Foundation - Grapher - ICU - ImageIO - Intel Graphics Driver - IOFireWireFamily - IOAcceleratorFamily - IOHIDFamily - IOKit - IOSurface - Kernel - kext tools - libarchive - LibreSSL - OpenLDAP - OpenPAM - OpenSSL - Power Management - Security - syslog - WiFi - xar Note that successful exploitation of the most serious issues can result in arbitrary code execution. Furthermore, CVE-2016-6304, CVE-2016-7596, and CVE-2016-7604 also affect Mac OS X versions 10.10.5 and 10.11.6. However, this plugin does not check those versions.
last seen 2019-02-21
modified 2018-07-14
plugin id 95917
published 2016-12-16
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=95917
title macOS 10.12.x < 10.12.2 Multiple Vulnerabilities
refmap via4
bid 94905
confirm
sectrack 1037469
Last major update 22-02-2017 - 08:54
Published 20-02-2017 - 03:59
Last modified 30-10-2018 - 12:27
Back to Top