ID CVE-2016-6905
Summary The read_image_tga function in gd_tga.c in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA image.
References
Vulnerable Configurations
  • cpe:2.3:a:libgd:libgd:1.3.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.3.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.6.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.6.2:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.6.2:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.6.3:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.6.3:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.7.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.7.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.7.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.7.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.7.2:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.7.2:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.7.3:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.7.3:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.8.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.8.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.8.3:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.8.3:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:1.8.4:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:1.8.4:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.3:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.3:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.4:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.4:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.5:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.5:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.6:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.6:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.7:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.7:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.8:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.8:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.9:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.9:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.10:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.10:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.11:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.11:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.12:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.12:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.13:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.13:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.14:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.14:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.15:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.15:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.17:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.17:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.18:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.18:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.19:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.19:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.20:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.20:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.21:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.21:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.22:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.22:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.23:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.23:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.24:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.24:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.25:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.25:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.26:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.26:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.27:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.27:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.28:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.28:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.29:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.29:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.30:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.30:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.31:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.31:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.32:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.32:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.33:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.33:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.0.34:rc1:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.0.34:rc1:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.0:-:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.0:-:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.0:alpha1:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.0:alpha1:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.0:rc1:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.0:rc1:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.0:rc2:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.0:rc2:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.2.0:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:libgd:libgd:2.2.2:*:*:*:*:*:*:*
    cpe:2.3:a:libgd:libgd:2.2.2:*:*:*:*:*:*:*
  • cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 30-10-2018 - 16:27)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Infiltration of Hardware Development Environment
    An attacker, leveraging the ability to manipulate components of primary support systems and tools within the development and production environments, inserts malicious software within the hardware and/or firmware development environment. The infiltration purpose is to alter developed hardware components in a system destined for deployment at the victim's organization, for the purpose of disruption or further compromise.
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
refmap via4
bid 91743
confirm
mlist [oss-security] 20160822 Re: CVE Request: libgd: Out-Of-Bounds Read in function read_image_tga of gd_tga.c
suse
  • openSUSE-SU-2016:2203
  • openSUSE-SU-2016:2363
Last major update 30-10-2018 - 16:27
Published 03-10-2016 - 21:59
Back to Top