ID CVE-2016-5697
Summary Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.
References
Vulnerable Configurations
  • cpe:2.3:a:onelogin:ruby-saml:1.2.0
    cpe:2.3:a:onelogin:ruby-saml:1.2.0
CVSS
Base: 5.0 (as of 25-01-2017 - 09:15)
Impact:
Exploitability:
CWE CWE-91
CAPEC
  • XML Injection
    An attacker utilizes crafted XML user-controllable input to probe, attack, and inject data into the XML database, using techniques similar to SQL injection. The user-controllable input can allow for unauthorized viewing of data, bypassing authentication or the front-end application for direct XML database access, and possibly altering database information.
  • XPath Injection
    An attacker can craft special user-controllable input consisting of XPath expressions to inject the XML database and bypass authentication or glean information that he normally would not be able to. XPath Injection enables an attacker to talk directly to the XML database, thus bypassing the application completely. XPath Injection results from the failure of an application to properly sanitize input used as part of dynamic XPath expressions used to query an XML database. In order to successfully inject XML and retrieve information from a database, an attacker:
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL NONE
nessus via4
NASL family FreeBSD Local Security Checks
NASL id FREEBSD_PKG_3FCD52B2451011E6A15F00248C0C745D.NASL
description RubySec reports : ruby-saml prior to version 1.3.0 is vulnerable to an XML signature wrapping attack in the specific scenario where there was a signature that referenced at the same time 2 elements (but past the scheme validator process since 1 of the element was inside the encrypted assertion). ruby-saml users must update to 1.3.0, which implements 3 extra validations to mitigate this kind of attack.
last seen 2019-02-21
modified 2018-11-21
plugin id 92006
published 2016-07-12
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=92006
title FreeBSD : ruby-saml -- XML signature wrapping attack (3fcd52b2-4510-11e6-a15f-00248c0c745d)
refmap via4
mlist [oss-security] 20160624 [CVE-2016-5697] signature wrapping attack vulnerability in ruby-saml prior to version 1.3.0 http://www.openwall.com/lists/oss-security/2016/06/24/3 MLIST:[oss-security] 06/24/2016 Re: [CVE-2016-5697] signature wrapping attack vulnerability in ruby-saml prior to version 1.3.0
Last major update 25-01-2017 - 09:20
Published 23-01-2017 - 16:59
Back to Top