ID CVE-2016-2041
Summary libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.
References
Vulnerable Configurations
  • Fedora 22
    cpe:2.3:o:fedoraproject:fedora:22
  • Fedora Project Fedora 23
    cpe:2.3:o:fedoraproject:fedora:23
  • phpMYAdmin 4.0.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0
  • phpMYAdmin 4.0.0 release candidate 2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0:rc2
  • phpMYAdmin 4.0.0 release candidate 3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0:rc3
  • phpMYAdmin 4.0.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.1
  • phpMYAdmin 4.0.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10
  • phpMyAdmin 4.0.10.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.1
  • phpMYAdmin 4.0.10.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.2
  • phpMyAdmin 4.0.10.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.3
  • phpMyAdmin 4.0.10.4
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.4
  • phpMYAdmin 4.0.10.5
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.5
  • phpMyAdmin 4.0.10.6
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.6
  • phpMyAdmin 4.0.10.7
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.7
  • phpMyAdmin 4.0.10.8
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.8
  • phpMyAdmin 4.0.10.9
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.9
  • phpMyAdmin 4.0.10.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.10
  • phpMyAdmin 4.0.10.11
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.11
  • phpMyAdmin 4.0.10.12
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.12
  • phpMyAdmin 4.4.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.0
  • phpMyAdmin 4.4.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.1
  • phpMyAdmin 4.4.1.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.1.1
  • phpMYAdmin 4.4.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.2
  • phpMyAdmin 4.4.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.3
  • phpMyAdmin 4.4.4
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.4
  • phpMyAdmin 4.4.5
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.5
  • phpMyAdmin 4.4.6
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.6
  • phpMyAdmin 4.4.6.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.6.1
  • phpMyAdmin 4.4.7
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.7
  • phpMyAdmin 4.4.8
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.8
  • phpMyAdmin 4.4.9
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.9
  • phpMyAdmin 4.4.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.10
  • phpMyAdmin 4.4.11
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.11
  • phpMyAdmin 4.4.12
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.12
  • phpMyAdmin 4.4.13
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.13
  • phpMyAdmin 4.4.13.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.13.1
  • phpMYAdmin 4.4.14.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.14.1
  • phpMYAdmin 4.4.15
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15
  • phpMyAdmin 4.4.15.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.1
  • phpMyAdmin 4.4.15.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.2
  • phpMyAdmin 4.4.15.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.3
  • phpMYAdmin 4.5.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0
  • phpMYAdmin 4.5.0.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1
  • phpMYAdmin 4.5.0.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2
  • phpMyAdmin 4.5.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1
  • phpMyAdmin 4.5.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2
  • phpMyAdmin 4.5.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3
  • openSUSE Leap 42.1
    cpe:2.3:o:opensuse:leap:42.1
  • OpenSUSE 13.1
    cpe:2.3:o:opensuse:opensuse:13.1
  • OpenSUSE 13.2
    cpe:2.3:o:opensuse:opensuse:13.2
CVSS
Base: 5.0 (as of 17-08-2016 - 14:30)
Impact:
Exploitability:
CWE CWE-254
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE PARTIAL NONE
nessus via4
  • NASL family CGI abuses
    NASL id PHPMYADMIN_PMASA_2016_5.NASL
    description According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.13, 4.4.x prior to 4.4.15.3, or 4.5.x prior to 4.5.4. It is, therefore, affected by the following vulnerabilities : - A security bypass vulnerability exists due to the use of the Math.random() JavaScript function which does not provide cryptographically secure random numbers. A remote attacker can exploit this to guess passwords via a brute-force attack. (CVE-2016-1927) - An information disclosure vulnerability exists in multiple scripts that allows a remote attacker, via a specially crafted request, to disclose the software's installation path. (CVE-2016-2038) - A security bypass vulnerability exists due to generating XSRF tokens with cryptographically insecure values. A remote attacker can exploit this to bypass intended access restrictions by predicting a value. (CVE-2016-2039) - Multiple cross-site scripting vulnerabilities exist due to improper validation of user-supplied input to the home, database search, and zoom search pages. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-2040) - A security bypass vulnerability exists due to a failure to use a constant-time algorithm for comparing XSRF tokens. A remote attacker can exploit this, via a timing attack, to bypass intended access restrictions. (CVE-2016-2041) Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 88985
    published 2016-02-26
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88985
    title phpMyAdmin 4.0.x < 4.0.10.13 / 4.4.x < 4.4.15.3 / 4.5.x < 4.5.4 Multiple Vulnerabilities (PMASA-2016-1 - PMASA-2016-5)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2016-E1FE01E96E.NASL
    description phpMyAdmin 4.5.4 (2016-01-28) ============================= - live data edit of big sets is not working - Table list not saved in db QBE bookmarked search - While 'changing a column', query fails with a syntax error after the 'CHARSET=' keyword - Avoid syntax error in JavaScript messages on invalid PHP setting for max_input_vars - Properly handle errors in upacking zip archive - Set PHP's internal encoding to UTF-8 - Fixed Kanji encoding in some specific cases - Check whether iconv works before using it - Avoid conversion of MySQL error messages - Undefined index: parameters - Undefined index: field_name_orig - Undefined index: host - 'Add to central columns' (per column button) does nothing - SQL duplicate entry error trying to INSERT in designer_settings table - Fix handling of databases with dot in a name - Fix hiding of page content behind menu - FROM clause not generated after loading search bookmark - Fix creating/editing VIEW with DEFINER containing special chars - Do not invoke FLUSH PRIVILEGES when server in --skip-grant-tables - Misleading message for configuration storage - Table pagination does nothing when session expired - Index comments not working properly - Better handle local storage errors - Improve detection of privileges for privilege adjusting - Undefined property: stdClass::$releases at version check when disabled in config - SQL comment and variable stripped from bookmark on save - Gracefully handle errors in regex based JavaScript search - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-1 - [Security] Unsafe generation of CSRF token, see PMASA-2016-2 - [Security] Multiple XSS vulnerabilities, see PMASA-2016-3 - [Security] Insecure password generation in JavaScript, see PMASA-2016-4 - [Security] Unsafe comparison of CSRF token, see PMASA-2016-5 - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-6 - [Security] XSS vulnerability in normalization page, see PMASA-2016-7 - [Security] Full path disclosure vulnerability in SQL parser, see PMASA-2016-8 - [Security] XSS vulnerability in SQL editor, see PMASA-2016-9 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-10-18
    plugin id 89625
    published 2016-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89625
    title Fedora 22 : phpMyAdmin-4.5.4-1.fc22 (2016-e1fe01e96e)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DLA-406.NASL
    description Several flaws were discovered in the CSRF authentication code of phpMyAdmin. CVE-2016-2039 The XSRF/CSRF token is generated with a weak algorithm using functions that do not return cryptographically secure values. CVE-2016-2041 The comparison of the XSRF/CSRF token parameter with the value saved in the session is vulnerable to timing attacks. Moreover, the comparison could be bypassed if the XSRF/CSRF token matches a particular pattern. NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-06
    plugin id 88492
    published 2016-02-01
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88492
    title Debian DLA-406-1 : phpmyadmin security update
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-168.NASL
    description Security update to phpMyAdmin 4.4.15.4 The followinng vulnerabilities were fixed: (boo#964024) - CVE-2016-2038: Multiple full path disclosure vulnerabilities - CVE-2016-2039: Unsafe generation of XSRF/CSRF token - CVE-2016-2040: Multiple XSS vulnerabilities - CVE-2016-1927: Insecure password generation in JavaScript - CVE-2016-2041: Unsafe comparison of XSRF/CSRF token - CVE-2016-2042: Multiple full path disclosure vulnerabilities - CVE-2016-2043: XSS vulnerability in normalization page
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 88632
    published 2016-02-09
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88632
    title openSUSE Security Update : phpMyAdmin (openSUSE-2016-168)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-3627.NASL
    description Several vulnerabilities have been fixed in phpMyAdmin, the web-based MySQL administration interface. - CVE-2016-1927 The suggestPassword function relied on a non-secure random number generator which makes it easier for remote attackers to guess generated passwords via a brute-force approach. - CVE-2016-2039 CSRF token values were generated by a non-secure random number generator, which allows remote attackers to bypass intended access restrictions by predicting a value. - CVE-2016-2040 Multiple cross-site scripting (XSS) vulnerabilities allow remote authenticated users to inject arbitrary web script or HTML. - CVE-2016-2041 phpMyAdmin does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences. - CVE-2016-2560 Multiple cross-site scripting (XSS) vulnerabilities allow remote attackers to inject arbitrary web script or HTML. - CVE-2016-2561 Multiple cross-site scripting (XSS) vulnerabilities allow remote attackers to inject arbitrary web script or HTML. - CVE-2016-5099 Multiple cross-site scripting (XSS) vulnerabilities allow remote attackers to inject arbitrary web script or HTML. - CVE-2016-5701 For installations running on plain HTTP, phpMyAdmin allows remote attackers to conduct BBCode injection attacks against HTTP sessions via a crafted URI. - CVE-2016-5705 Multiple cross-site scripting (XSS) vulnerabilities allow remote attackers to inject arbitrary web script or HTML. - CVE-2016-5706 phpMyAdmin allows remote attackers to cause a denial of service (resource consumption) via a large array in the scripts parameter. - CVE-2016-5731 A cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML. - CVE-2016-5733 Multiple cross-site scripting (XSS) vulnerabilities allow remote attackers to inject arbitrary web script or HTML. - CVE-2016-5739 A specially crafted Transformation could leak information which a remote attacker could use to perform cross site request forgeries.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 92527
    published 2016-07-25
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=92527
    title Debian DSA-3627-1 : phpmyadmin - security update
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DLA-481.NASL
    description The previous security upload broke the search pages in phpMyAdmin. This was caused by a broken patch applied to fix CVE-2016-2040. For Debian 7 'Wheezy', these problems have been fixed in version 4:3.4.11.1-2+deb7u4. NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-06
    plugin id 91243
    published 2016-05-19
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91243
    title Debian DLA-481-2 : phpmyadmin regression update
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-151.NASL
    description This update to phpMyAdmin 4.4.15.4 fixes the following issues (boo#964024) - CVE-2016-2038: Multiple full path disclosure vulnerabilities - CVE-2016-2039: Unsafe generation of XSRF/CSRF token - CVE-2016-2040: Multiple XSS vulnerabilities - CVE-2016-1927: Insecure password generation in JavaScript - CVE-2016-2041: Unsafe comparison of XSRF/CSRF token - CVE-2016-2042: Multiple full path disclosure vulnerabilities - CVE-2016-2043: XSS vulnerability in normalization page
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 88607
    published 2016-02-08
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88607
    title openSUSE Security Update : phpMyAdmin (openSUSE-2016-151)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2016-E55278763E.NASL
    description phpMyAdmin 4.5.4.1 (2016-01-28) =============================== - Error with PMA 4.4.15.3 - Remove hard dependency on phpseclib phpMyAdmin 4.5.4 (2016-01-28) ============================= - live data edit of big sets is not working - Table list not saved in db QBE bookmarked search - While 'changing a column', query fails with a syntax error after the 'CHARSET=' keyword - Avoid syntax error in JavaScript messages on invalid PHP setting for max_input_vars - Properly handle errors in upacking zip archive - Set PHP's internal encoding to UTF-8 - Fixed Kanji encoding in some specific cases - Check whether iconv works before using it - Avoid conversion of MySQL error messages - Undefined index: parameters - Undefined index: field_name_orig - Undefined index: host - 'Add to central columns' (per column button) does nothing - SQL duplicate entry error trying to INSERT in designer_settings table - Fix handling of databases with dot in a name - Fix hiding of page content behind menu - FROM clause not generated after loading search bookmark - Fix creating/editing VIEW with DEFINER containing special chars - Do not invoke FLUSH PRIVILEGES when server in --skip- grant-tables - Misleading message for configuration storage - Table pagination does nothing when session expired - Index comments not working properly - Better handle local storage errors - Improve detection of privileges for privilege adjusting - Undefined property: stdClass::$releases at version check when disabled in config - SQL comment and variable stripped from bookmark on save - Gracefully handle errors in regex based JavaScript search - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-1 - [Security] Unsafe generation of CSRF token, see PMASA-2016-2 - [Security] Multiple XSS vulnerabilities, see PMASA-2016-3 - [Security] Insecure password generation in JavaScript, see PMASA-2016-4 - [Security] Unsafe comparison of CSRF token, see PMASA-2016-5 - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-6 - [Security] XSS vulnerability in normalization page, see PMASA-2016-7 - [Security] Full path disclosure vulnerability in SQL parser, see PMASA-2016-8 - [Security] XSS vulnerability in SQL editor, see PMASA-2016-9 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-10-18
    plugin id 89630
    published 2016-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89630
    title Fedora 23 : phpMyAdmin-4.5.4.1-1.fc23 (2016-e55278763e)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_71B24D99C60B11E5BF366805CA0B3D42.NASL
    description The phpMyAdmin development team reports : The comparison of the XSRF/CSRF token parameter with the value saved in the session is vulnerable to timing attacks. Moreover, the comparison could be bypassed if the XSRF/CSRF token matches a particular pattern. We consider this vulnerability to be serious.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 88471
    published 2016-01-29
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88471
    title FreeBSD : phpmyadmin -- Unsafe comparison of XSRF/CSRF token (71b24d99-c60b-11e5-bf36-6805ca0b3d42)
refmap via4
confirm
debian DSA-3627
fedora
  • FEDORA-2016-e1fe01e96e
  • FEDORA-2016-e55278763e
suse
  • openSUSE-SU-2016:0357
  • openSUSE-SU-2016:0378
Last major update 28-11-2016 - 15:02
Published 19-02-2016 - 20:59
Last modified 30-10-2018 - 12:27
Back to Top