ID CVE-2016-2038
Summary phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allows remote attackers to obtain sensitive information via a crafted request, which reveals the full path in an error message.
References
Vulnerable Configurations
  • phpMYAdmin 4.0.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0
  • phpMYAdmin 4.0.0 release candidate 2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0:rc2
  • phpMYAdmin 4.0.0 release candidate 3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.0:rc3
  • phpMYAdmin 4.0.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.1
  • phpMYAdmin 4.0.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10
  • phpMyAdmin 4.0.10.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.1
  • phpMYAdmin 4.0.10.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.2
  • phpMyAdmin 4.0.10.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.3
  • phpMyAdmin 4.0.10.4
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.4
  • phpMYAdmin 4.0.10.5
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.5
  • phpMyAdmin 4.0.10.6
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.6
  • phpMyAdmin 4.0.10.7
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.7
  • phpMyAdmin 4.0.10.8
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.8
  • phpMyAdmin 4.0.10.9
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.9
  • phpMyAdmin 4.0.10.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.10
  • phpMyAdmin 4.0.10.11
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.11
  • phpMyAdmin 4.0.10.12
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.0.10.12
  • phpMyAdmin 4.4.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.0
  • phpMyAdmin 4.4.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.1
  • phpMyAdmin 4.4.1.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.1.1
  • phpMYAdmin 4.4.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.2
  • phpMyAdmin 4.4.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.3
  • phpMyAdmin 4.4.4
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.4
  • phpMyAdmin 4.4.5
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.5
  • phpMyAdmin 4.4.6
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.6
  • phpMyAdmin 4.4.6.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.6.1
  • phpMyAdmin 4.4.7
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.7
  • phpMyAdmin 4.4.8
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.8
  • phpMyAdmin 4.4.9
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.9
  • phpMyAdmin 4.4.10
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.10
  • phpMyAdmin 4.4.11
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.11
  • phpMyAdmin 4.4.12
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.12
  • phpMyAdmin 4.4.13
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.13
  • phpMyAdmin 4.4.13.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.13.1
  • phpMYAdmin 4.4.14.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.14.1
  • phpMYAdmin 4.4.15
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15
  • phpMyAdmin 4.4.15.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.1
  • phpMyAdmin 4.4.15.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.2
  • phpMyAdmin 4.4.15.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.4.15.3
  • phpMYAdmin 4.5.0
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0
  • phpMYAdmin 4.5.0.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1
  • phpMYAdmin 4.5.0.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2
  • phpMyAdmin 4.5.1
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1
  • phpMyAdmin 4.5.2
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2
  • phpMyAdmin 4.5.3
    cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3
  • Fedora 22
    cpe:2.3:o:fedoraproject:fedora:22
  • Fedora Project Fedora 23
    cpe:2.3:o:fedoraproject:fedora:23
  • openSUSE Leap 42.1
    cpe:2.3:o:opensuse:leap:42.1
  • OpenSUSE 13.1
    cpe:2.3:o:opensuse:opensuse:13.1
  • OpenSUSE 13.2
    cpe:2.3:o:opensuse:opensuse:13.2
CVSS
Base: 5.0 (as of 17-08-2016 - 14:27)
Impact:
Exploitability:
CWE CWE-200
CAPEC
  • Subverting Environment Variable Values
    The attacker directly or indirectly modifies environment variables used by or controlling the target software. The attacker's goal is to cause the target software to deviate from its expected operation in a manner that benefits the attacker.
  • Footprinting
    An attacker engages in probing and exploration activity to identify constituents and properties of the target. Footprinting is a general term to describe a variety of information gathering techniques, often used by attackers in preparation for some attack. It consists of using tools to learn as much as possible about the composition, configuration, and security mechanisms of the targeted application, system or network. Information that might be collected during a footprinting effort could include open ports, applications and their versions, network topology, and similar information. While footprinting is not intended to be damaging (although certain activities, such as network scans, can sometimes cause disruptions to vulnerable applications inadvertently) it may often pave the way for more damaging attacks.
  • Exploiting Trust in Client (aka Make the Client Invisible)
    An attack of this type exploits a programs' vulnerabilities in client/server communication channel authentication and data integrity. It leverages the implicit trust a server places in the client, or more importantly, that which the server believes is the client. An attacker executes this type of attack by placing themselves in the communication channel between client and server such that communication directly to the server is possible where the server believes it is communicating only with a valid client. There are numerous variations of this type of attack.
  • Browser Fingerprinting
    An attacker carefully crafts small snippets of Java Script to efficiently detect the type of browser the potential victim is using. Many web-based attacks need prior knowledge of the web browser including the version of browser to ensure successful exploitation of a vulnerability. Having this knowledge allows an attacker to target the victim with attacks that specifically exploit known or zero day weaknesses in the type and version of the browser used by the victim. Automating this process via Java Script as a part of the same delivery system used to exploit the browser is considered more efficient as the attacker can supply a browser fingerprinting method and integrate it with exploit code, all contained in Java Script and in response to the same web page request by the browser.
  • Session Credential Falsification through Prediction
    This attack targets predictable session ID in order to gain privileges. The attacker can predict the session ID used during a transaction to perform spoofing and session hijacking.
  • Reusing Session IDs (aka Session Replay)
    This attack targets the reuse of valid session ID to spoof the target system in order to gain privileges. The attacker tries to reuse a stolen session ID used previously during a transaction to perform spoofing and session hijacking. Another name for this type of attack is Session Replay.
  • Using Slashes in Alternate Encoding
    This attack targets the encoding of the Slash characters. An attacker would try to exploit common filtering problems related to the use of the slashes characters to gain access to resources on the target host. Directory-driven systems, such as file systems and databases, typically use the slash character to indicate traversal between directories or other container components. For murky historical reasons, PCs (and, as a result, Microsoft OSs) choose to use a backslash, whereas the UNIX world typically makes use of the forward slash. The schizophrenic result is that many MS-based systems are required to understand both forms of the slash. This gives the attacker many opportunities to discover and abuse a number of common filtering problems. The goal of this pattern is to discover server software that only applies filters to one version, but not the other.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
nessus via4
  • NASL family CGI abuses
    NASL id PHPMYADMIN_PMASA_2016_5.NASL
    description According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.13, 4.4.x prior to 4.4.15.3, or 4.5.x prior to 4.5.4. It is, therefore, affected by the following vulnerabilities : - A security bypass vulnerability exists due to the use of the Math.random() JavaScript function which does not provide cryptographically secure random numbers. A remote attacker can exploit this to guess passwords via a brute-force attack. (CVE-2016-1927) - An information disclosure vulnerability exists in multiple scripts that allows a remote attacker, via a specially crafted request, to disclose the software's installation path. (CVE-2016-2038) - A security bypass vulnerability exists due to generating XSRF tokens with cryptographically insecure values. A remote attacker can exploit this to bypass intended access restrictions by predicting a value. (CVE-2016-2039) - Multiple cross-site scripting vulnerabilities exist due to improper validation of user-supplied input to the home, database search, and zoom search pages. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2016-2040) - A security bypass vulnerability exists due to a failure to use a constant-time algorithm for comparing XSRF tokens. A remote attacker can exploit this, via a timing attack, to bypass intended access restrictions. (CVE-2016-2041) Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 88985
    published 2016-02-26
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88985
    title phpMyAdmin 4.0.x < 4.0.10.13 / 4.4.x < 4.4.15.3 / 4.5.x < 4.5.4 Multiple Vulnerabilities (PMASA-2016-1 - PMASA-2016-5)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_5D6A204FC60B11E5BF366805CA0B3D42.NASL
    description The phpMyAdmin development team reports : By calling some scripts that are part of phpMyAdmin in an unexpected way, it is possible to trigger phpMyAdmin to display a PHP error message which contains the full path of the directory where phpMyAdmin is installed. We consider these vulnerabilities to be non-critical. This path disclosure is possible on servers where the recommended setting of the PHP configuration directive display_errors is set to on, which is against the recommendations given in the PHP manual for a production server.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 88467
    published 2016-01-29
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88467
    title FreeBSD : phpmyadmin -- Multiple full path disclosure vulnerabilities (5d6a204f-c60b-11e5-bf36-6805ca0b3d42)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2016-E1FE01E96E.NASL
    description phpMyAdmin 4.5.4 (2016-01-28) ============================= - live data edit of big sets is not working - Table list not saved in db QBE bookmarked search - While 'changing a column', query fails with a syntax error after the 'CHARSET=' keyword - Avoid syntax error in JavaScript messages on invalid PHP setting for max_input_vars - Properly handle errors in upacking zip archive - Set PHP's internal encoding to UTF-8 - Fixed Kanji encoding in some specific cases - Check whether iconv works before using it - Avoid conversion of MySQL error messages - Undefined index: parameters - Undefined index: field_name_orig - Undefined index: host - 'Add to central columns' (per column button) does nothing - SQL duplicate entry error trying to INSERT in designer_settings table - Fix handling of databases with dot in a name - Fix hiding of page content behind menu - FROM clause not generated after loading search bookmark - Fix creating/editing VIEW with DEFINER containing special chars - Do not invoke FLUSH PRIVILEGES when server in --skip-grant-tables - Misleading message for configuration storage - Table pagination does nothing when session expired - Index comments not working properly - Better handle local storage errors - Improve detection of privileges for privilege adjusting - Undefined property: stdClass::$releases at version check when disabled in config - SQL comment and variable stripped from bookmark on save - Gracefully handle errors in regex based JavaScript search - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-1 - [Security] Unsafe generation of CSRF token, see PMASA-2016-2 - [Security] Multiple XSS vulnerabilities, see PMASA-2016-3 - [Security] Insecure password generation in JavaScript, see PMASA-2016-4 - [Security] Unsafe comparison of CSRF token, see PMASA-2016-5 - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-6 - [Security] XSS vulnerability in normalization page, see PMASA-2016-7 - [Security] Full path disclosure vulnerability in SQL parser, see PMASA-2016-8 - [Security] XSS vulnerability in SQL editor, see PMASA-2016-9 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-10-18
    plugin id 89625
    published 2016-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89625
    title Fedora 22 : phpMyAdmin-4.5.4-1.fc22 (2016-e1fe01e96e)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-168.NASL
    description Security update to phpMyAdmin 4.4.15.4 The followinng vulnerabilities were fixed: (boo#964024) - CVE-2016-2038: Multiple full path disclosure vulnerabilities - CVE-2016-2039: Unsafe generation of XSRF/CSRF token - CVE-2016-2040: Multiple XSS vulnerabilities - CVE-2016-1927: Insecure password generation in JavaScript - CVE-2016-2041: Unsafe comparison of XSRF/CSRF token - CVE-2016-2042: Multiple full path disclosure vulnerabilities - CVE-2016-2043: XSS vulnerability in normalization page
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 88632
    published 2016-02-09
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88632
    title openSUSE Security Update : phpMyAdmin (openSUSE-2016-168)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-151.NASL
    description This update to phpMyAdmin 4.4.15.4 fixes the following issues (boo#964024) - CVE-2016-2038: Multiple full path disclosure vulnerabilities - CVE-2016-2039: Unsafe generation of XSRF/CSRF token - CVE-2016-2040: Multiple XSS vulnerabilities - CVE-2016-1927: Insecure password generation in JavaScript - CVE-2016-2041: Unsafe comparison of XSRF/CSRF token - CVE-2016-2042: Multiple full path disclosure vulnerabilities - CVE-2016-2043: XSS vulnerability in normalization page
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 88607
    published 2016-02-08
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=88607
    title openSUSE Security Update : phpMyAdmin (openSUSE-2016-151)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2016-E55278763E.NASL
    description phpMyAdmin 4.5.4.1 (2016-01-28) =============================== - Error with PMA 4.4.15.3 - Remove hard dependency on phpseclib phpMyAdmin 4.5.4 (2016-01-28) ============================= - live data edit of big sets is not working - Table list not saved in db QBE bookmarked search - While 'changing a column', query fails with a syntax error after the 'CHARSET=' keyword - Avoid syntax error in JavaScript messages on invalid PHP setting for max_input_vars - Properly handle errors in upacking zip archive - Set PHP's internal encoding to UTF-8 - Fixed Kanji encoding in some specific cases - Check whether iconv works before using it - Avoid conversion of MySQL error messages - Undefined index: parameters - Undefined index: field_name_orig - Undefined index: host - 'Add to central columns' (per column button) does nothing - SQL duplicate entry error trying to INSERT in designer_settings table - Fix handling of databases with dot in a name - Fix hiding of page content behind menu - FROM clause not generated after loading search bookmark - Fix creating/editing VIEW with DEFINER containing special chars - Do not invoke FLUSH PRIVILEGES when server in --skip- grant-tables - Misleading message for configuration storage - Table pagination does nothing when session expired - Index comments not working properly - Better handle local storage errors - Improve detection of privileges for privilege adjusting - Undefined property: stdClass::$releases at version check when disabled in config - SQL comment and variable stripped from bookmark on save - Gracefully handle errors in regex based JavaScript search - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-1 - [Security] Unsafe generation of CSRF token, see PMASA-2016-2 - [Security] Multiple XSS vulnerabilities, see PMASA-2016-3 - [Security] Insecure password generation in JavaScript, see PMASA-2016-4 - [Security] Unsafe comparison of CSRF token, see PMASA-2016-5 - [Security] Multiple full path disclosure vulnerabilities, see PMASA-2016-6 - [Security] XSS vulnerability in normalization page, see PMASA-2016-7 - [Security] Full path disclosure vulnerability in SQL parser, see PMASA-2016-8 - [Security] XSS vulnerability in SQL editor, see PMASA-2016-9 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-10-18
    plugin id 89630
    published 2016-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89630
    title Fedora 23 : phpMyAdmin-4.5.4.1-1.fc23 (2016-e55278763e)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DLA-481.NASL
    description The previous security upload broke the search pages in phpMyAdmin. This was caused by a broken patch applied to fix CVE-2016-2040. For Debian 7 'Wheezy', these problems have been fixed in version 4:3.4.11.1-2+deb7u4. NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-06
    plugin id 91243
    published 2016-05-19
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91243
    title Debian DLA-481-2 : phpmyadmin regression update
  • NASL family CGI abuses
    NASL id PHPMYADMIN_PMASA_2016_PATH_DISCLOSURE.NASL
    description The phpMyAdmin application hosted on the remote web server is affected by multiple path disclosure vulnerabilities in multiple scripts. An unauthenticated, remote attacker can exploit these vulnerabilities, via a specially crafted request, to disclose the full path of the directory where phpMyAdmin is installed. Note that phpMyAdmin is also reportedly affected by multiple cross-site scripting and cross-site request forgery vulnerabilities; however, Nessus has not tested for these.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 90428
    published 2016-04-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90428
    title phpMyAdmin Multiple Path Disclosure Vulnerabilities (PMASA-2016-1, PMASA-2016-6, PMASA-2016-8)
refmap via4
confirm
fedora
  • FEDORA-2016-e1fe01e96e
  • FEDORA-2016-e55278763e
suse
  • openSUSE-SU-2016:0357
  • openSUSE-SU-2016:0378
Last major update 17-08-2016 - 14:56
Published 19-02-2016 - 20:59
Last modified 30-10-2018 - 12:27
Back to Top