ID CVE-2016-1704
Summary Multiple unspecified vulnerabilities in Google Chrome before 51.0.2704.103 allow attackers to cause a denial of service or possibly have other impact via unknown vectors.
References
Vulnerable Configurations
  • Google Chrome 51.0.2704.84
    cpe:2.3:a:google:chrome:51.0.2704.84
  • Canonical Ubuntu Linux 14.04 LTS (Long-Term Support)
    cpe:2.3:o:canonical:ubuntu_linux:14.04:-:-:-:lts
  • Canonical Ubuntu Linux 15.10
    cpe:2.3:o:canonical:ubuntu_linux:15.10
  • Canonical Ubuntu Linux 16.04 LTS (Long-Term Support)
    cpe:2.3:o:canonical:ubuntu_linux:16.04:-:-:-:lts
  • Red Hat Enterprise Linux Desktop 6.0
    cpe:2.3:o:redhat:enterprise_linux_desktop:6.0
  • Red Hat Enterprise Linux Server 6.0
    cpe:2.3:o:redhat:enterprise_linux_server:6.0
  • Red Hat Enterprise Linux Workstation 6.0
    cpe:2.3:o:redhat:enterprise_linux_workstation:6.0
  • Novell SUSE Package Hub For SUSE Linux Enterprise 12
    cpe:2.3:a:novell:suse_package_hub_for_suse_linux_enterprise:12
  • openSUSE Leap 42.1
    cpe:2.3:o:opensuse:leap:42.1
  • OpenSUSE 13.1
    cpe:2.3:o:opensuse:opensuse:13.1
  • OpenSUSE 13.2
    cpe:2.3:o:opensuse:opensuse:13.2
CVSS
Base: 6.8 (as of 17-11-2016 - 12:04)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
nessus via4
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-744.NASL
    description Chromium was updated to 51.0.2704.103 to fix three vulnerabilities : - CVE-2016-1704: Various fixes from internal audits, fuzzing and other initiatives (shared identifier) (boo#985397)
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 91709
    published 2016-06-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91709
    title openSUSE Security Update : Chromium (openSUSE-2016-744)
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-3015-1.NASL
    description Multiple security issues were discovered in Chromium. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to read uninitialized memory, cause a denial of service via application crash, or execute arbitrary code. (CVE-2016-1704). Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-12-01
    plugin id 91914
    published 2016-07-01
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91914
    title Ubuntu 14.04 LTS / 15.10 / 16.04 LTS : oxide-qt vulnerabilities (USN-3015-1)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_GOOGLE_CHROME_51_0_2704_103.NASL
    description The version of Google Chrome installed on the remote Mac OS X host is prior to 51.0.2704.103. It is, therefore, affected by multiple vulnerabilities : - A flaw exists in the individualCharacterRanges() function in CachingWordShaper.cpp that is triggered when handling invalid glyph shaping results. A remote attacker can exploit this issue to corrupt memory, resulting in the execution of code. - A use-after-free error exists in the OnChannelMessage() function in node_channel.cc that allows a remote attacker to dereference already freed memory, resulting in the execution of arbitrary code. - An unspecified flaw exists in shared_worker_devtools_manager.cc that allows a remote attacker to have an unspecified impact.
    last seen 2019-02-21
    modified 2019-01-02
    plugin id 91717
    published 2016-06-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91717
    title Google Chrome < 51.0.2704.103 Multiple Vulnerabilities (Mac OS X)
  • NASL family Windows
    NASL id GOOGLE_CHROME_51_0_2704_103.NASL
    description The version of Google Chrome installed on the remote Windows host is prior to 51.0.2704.103. It is, therefore, affected by multiple vulnerabilities : - A flaw exists in the individualCharacterRanges() function in CachingWordShaper.cpp that is triggered when handling invalid glyph shaping results. A remote attacker can exploit this issue to corrupt memory, resulting in the execution of code. - A use-after-free error exists in the OnChannelMessage() function in node_channel.cc that allows a remote attacker to dereference already freed memory, resulting in the execution of arbitrary code. - An unspecified flaw exists in shared_worker_devtools_manager.cc that allows a remote attacker to have an unspecified impact.
    last seen 2019-02-21
    modified 2019-01-02
    plugin id 91716
    published 2016-06-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91716
    title Google Chrome < 51.0.2704.103 Multiple Vulnerabilities
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-3637.NASL
    description Several vulnerabilities have been discovered in the chromium web browser. - CVE-2016-1704 The chrome development team found and fixed various issues during internal auditing. - CVE-2016-1705 The chrome development team found and fixed various issues during internal auditing. - CVE-2016-1706 Pinkie Pie discovered a way to escape the Pepper Plugin API sandbox. - CVE-2016-1707 xisigr discovered a URL spoofing issue. - CVE-2016-1708 Adam Varsan discovered a use-after-free issue. - CVE-2016-1709 ChenQin discovered a buffer overflow issue in the sfntly library. - CVE-2016-1710 Mariusz Mlynski discovered a same-origin bypass. - CVE-2016-1711 Mariusz Mlynski discovered another same-origin bypass. - CVE-2016-5127 cloudfuzzer discovered a use-after-free issue. - CVE-2016-5128 A same-origin bypass issue was discovered in the v8 JavaScript library. - CVE-2016-5129 Jeonghoon Shin discovered a memory corruption issue in the v8 JavaScript library. - CVE-2016-5130 Widih Matar discovered a URL spoofing issue. - CVE-2016-5131 Nick Wellnhofer discovered a use-after-free issue in the libxml2 library. - CVE-2016-5132 Ben Kelly discovered a same-origin bypass. - CVE-2016-5133 Patch Eudor discovered an issue in proxy authentication. - CVE-2016-5134 Paul Stone discovered an information leak in the Proxy Auto-Config feature. - CVE-2016-5135 ShenYeYinJiu discovered a way to bypass the Content Security Policy. - CVE-2016-5136 Rob Wu discovered a use-after-free issue. - CVE-2016-5137 Xiaoyin Liu discovered a way to discover whether an HSTS website had been visited.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 92666
    published 2016-08-02
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=92666
    title Debian DSA-3637-1 : chromium-browser - security update
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2016-1262.NASL
    description An update for chromium-browser is now available for Red Hat Enterprise Linux 6 Supplementary. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section. Chromium is an open source web browser, powered by WebKit (Blink). This update upgrades Chromium to version 51.0.2704.103. Security Fix(es) : * Multiple flaws were found in the processing of malformed web content. A web page containing malicious content could cause Chromium to crash, execute arbitrary code, or disclose sensitive information when visited by the victim. (CVE-2016-1704)
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 91724
    published 2016-06-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91724
    title RHEL 6 : chromium-browser (RHSA-2016:1262)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-741.NASL
    description Chromium was updated to 51.0.2704.103 to fix three vulnerabilities : - CVE-2016-1704: Various fixes from internal audits, fuzzing and other initiatives (shared identifier) (boo#985397)
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 91707
    published 2016-06-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91707
    title openSUSE Security Update : Chromium (openSUSE-2016-741)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_D59EBED434BE11E6BE253065EC8FD3EC.NASL
    description Google Chrome Releases reports : 3 security fixes in this release, including : - [620742] CVE-2016-1704: Various fixes from internal audits, fuzzing and other initiatives.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 91700
    published 2016-06-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91700
    title FreeBSD : chromium -- multiple vulnerabilities (d59ebed4-34be-11e6-be25-3065ec8fd3ec)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-756.NASL
    description Chromium was updated to 51.0.2704.103 to fix three vulnerabilities : - CVE-2016-1704: Various fixes from internal audits, fuzzing and other initiatives (shared identifier) (boo#985397) Includes vulnerability fixes from 50.0.2661.102 (boo#979859) : - CVE-2016-1667: Same origin bypass in DOM - CVE-2016-1668: Same origin bypass in Blink V8 bindings - CVE-2016-1669: Buffer overflow in V8 - CVE-2016-1670: Race condition in loader Includes vulnerability fixes from 50.0.2661.94 (boo#977830) : - CVE-2016-1660: Out-of-bounds write in Blink - CVE-2016-1661: Memory corruption in cross-process frames - CVE-2016-1662: Use-after-free in extensions - CVE-2016-1663: Use-after-free in Blink’s V8 bindings - CVE-2016-1664: Address bar spoofing - CVE-2016-1665: Information leak in V8 - CVE-2016-1666: Various fixes from internal audits, fuzzing and other initiatives
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 91848
    published 2016-06-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91848
    title openSUSE Security Update : Chromium (openSUSE-2016-756)
redhat via4
advisories
rhsa
id RHSA-2016:1262
refmap via4
confirm
debian DSA-3637
suse
  • openSUSE-SU-2016:1623
  • openSUSE-SU-2016:1624
  • openSUSE-SU-2016:1626
  • openSUSE-SU-2016:1655
ubuntu USN-3015-1
Last major update 28-11-2016 - 15:01
Published 03-07-2016 - 17:59
Last modified 30-10-2018 - 12:27
Back to Top