ID CVE-2016-1666
Summary Multiple unspecified vulnerabilities in Google Chrome before 50.0.2661.94 allow attackers to cause a denial of service or possibly have other impact via unknown vectors.
References
Vulnerable Configurations
  • Red Hat Enterprise Linux Desktop Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_desktop_supplementary:6.0
  • Red Hat Enterprise Linux Server Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_server_supplementary:6.0
  • Red Hat Enterprise Linux Server Supplementary EUS 6.7z
    cpe:2.3:o:redhat:enterprise_linux_server_supplementary_eus:6.7z
  • Red Hat Enterprise Linux Workstation Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_workstation_supplementary:6.0
  • OpenSUSE 13.1
    cpe:2.3:o:opensuse:opensuse:13.1
  • Google Chrome 50.0.2661.87
    cpe:2.3:a:google:chrome:50.0.2661.87
CVSS
Base: 7.5 (as of 15-07-2016 - 09:40)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
nessus via4
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2016-0707.NASL
    description An update for chromium-browser is now available for Red Hat Enterprise Linux 6 Supplementary. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section. Chromium is an open source web browser, powered by WebKit (Blink). This update upgrades Chromium to version 50.0.2661.94. Security Fix(es) : * Multiple flaws were found in the processing of malformed web content. A web page containing malicious content could cause Chromium to crash, execute arbitrary code, or disclose sensitive information when visited by the victim. (CVE-2016-1660, CVE-2016-1661, CVE-2016-1662, CVE-2016-1663, CVE-2016-1666, CVE-2016-1664, CVE-2016-1665)
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 90852
    published 2016-05-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90852
    title RHEL 6 : chromium-browser (RHSA-2016:0707)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-3564.NASL
    description Several vulnerabilities have been discovered in the chromium web browser. - CVE-2016-1660 Atte Kettunen discovered an out-of-bounds write issue. - CVE-2016-1661 Wadih Matar discovered a memory corruption issue. - CVE-2016-1662 Rob Wu discovered a use-after-free issue related to extensions. - CVE-2016-1663 A use-after-free issue was discovered in Blink's bindings to V8. - CVE-2016-1664 Wadih Matar discovered a way to spoof URLs. - CVE-2016-1665 gksgudtjr456 discovered an information leak in the v8 JavaScript library. - CVE-2016-1666 The chrome development team found and fixed various issues during internal auditing.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 90840
    published 2016-05-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90840
    title Debian DSA-3564-1 : chromium-browser - security update
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201605-02.NASL
    description The remote host is affected by the vulnerability described in GLSA-201605-02 (Chromium: Multiple vulnerabilities) Multiple vulnerabilities have been discovered in the Chromium web browser. Please review the CVE identifiers referenced below for details. Impact : A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, obtain sensitive information, or bypass security restrictions. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2016-10-10
    plugin id 91176
    published 2016-05-17
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91176
    title GLSA-201605-02 : Chromium: Multiple vulnerabilities
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_GOOGLE_CHROME_50_0_2661_94.NASL
    description The version of Google Chrome installed on the remote Mac OS X host is prior to 50.0.2661.94. It is, therefore, affected by multiple vulnerabilities : - An out-of-bounds write error exists in Blink that allows a context-dependent attacker to execute arbitrary code. (CVE-2016-1660) - A flaw exists due to improper validation of user-supplied input when handling cross-process frames. A context-dependent attacker can exploit this to corrupt memory, resulting in the execution of arbitrary code. (CVE-2016-1661) - A use-after-free error exists in the extensions component. A context-dependent attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1662) - A use-after-free free error exists in Blink's V8 bindings. A context-dependent attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1663) - An unspecified flaw exists that allows a context-dependent attacker to spoof the address bar. (CVE-2016-1664) - An unspecified flaw exists in V8 that allows a context-dependent attacker to disclose sensitive information. (CVE-2016-1665) - Multiple unspecified vulnerabilities exist that allow a a context-dependent attacker to execute arbitrary code. (CVE-2016-1666) - A same-origin bypass vulnerability exists in Skia in the pinToByte() function in effects/SkArithmeticMode.cpp due to improper handling of intermediate color values. An unauthenticated, remote attacker can exploit this, via timing attacks using the SVG 'feComposite' filter, to bypass the same-origin policy. (CVE-2016-5168)
    last seen 2019-02-21
    modified 2018-07-16
    plugin id 90795
    published 2016-04-29
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90795
    title Google Chrome < 50.0.2661.94 Multiple Vulnerabilities (Mac OS X)
  • NASL family Windows
    NASL id GOOGLE_CHROME_50_0_2661_94.NASL
    description The version of Google Chrome installed on the remote Windows host is prior to 50.0.2661.94. It is, therefore, affected by multiple vulnerabilities : - An out-of-bounds write error exists in Blink that allows a context-dependent attacker to execute arbitrary code. (CVE-2016-1660) - A flaw exists due to improper validation of user-supplied input when handling cross-process frames. A context-dependent attacker can exploit this to corrupt memory, resulting in the execution of arbitrary code. (CVE-2016-1661) - A use-after-free error exists in the extensions component. A context-dependent attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1662) - A use-after-free free error exists in Blink's V8 bindings. A context-dependent attacker can exploit this to dereference already freed memory, resulting in the execution of arbitrary code. (CVE-2016-1663) - An unspecified flaw exists that allows a context-dependent attacker to spoof the address bar. (CVE-2016-1664) - An unspecified flaw exists in V8 that allows a context-dependent attacker to disclose sensitive information. (CVE-2016-1665) - Multiple unspecified vulnerabilities exist that allow a a context-dependent attacker to execute arbitrary code. (CVE-2016-1666) - A same-origin bypass vulnerability exists in Skia in the pinToByte() function in effects/SkArithmeticMode.cpp due to improper handling of intermediate color values. An unauthenticated, remote attacker can exploit this, via timing attacks using the SVG 'feComposite' filter, to bypass the same-origin policy. (CVE-2016-5168)
    last seen 2019-02-21
    modified 2018-07-13
    plugin id 90794
    published 2016-04-29
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90794
    title Google Chrome < 50.0.2661.94 Multiple Vulnerabilities
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-538.NASL
    description Chromium was updated to 50.0.2661.94 to fix a number of vulnerabilities (boo#977830) : - CVE-2016-1660: Out-of-bounds write in Blink - CVE-2016-1661: Memory corruption in cross-process frames - CVE-2016-1662: Use-after-free in extensions - CVE-2016-1663: Use-after-free in Blink’s V8 bindings - CVE-2016-1664: Address bar spoofing - CVE-2016-1665: Information leak in V8 - CVE-2016-1666: Various fixes from internal audits, fuzzing and other initiatives
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 90878
    published 2016-05-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90878
    title openSUSE Security Update : Chromium (openSUSE-2016-538)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-539.NASL
    description Chromium was updated to 50.0.2661.94 to fix a number of vulnerabilities (boo#977830) : - CVE-2016-1660: Out-of-bounds write in Blink - CVE-2016-1661: Memory corruption in cross-process frames - CVE-2016-1662: Use-after-free in extensions - CVE-2016-1663: Use-after-free in Blink’s V8 bindings - CVE-2016-1664: Address bar spoofing - CVE-2016-1665: Information leak in V8 - CVE-2016-1666: Various fixes from internal audits, fuzzing and other initiatives
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 90879
    published 2016-05-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=90879
    title openSUSE Security Update : Chromium (openSUSE-2016-539)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_7DA1DA9624BB11E6BD313065EC8FD3EC.NASL
    description Google Chrome Releases reports : 9 security fixes in this release, including : - [574802] High CVE-2016-1660: Out-of-bounds write in Blink. Credit to Atte Kettunen of OUSPG. - [601629] High CVE-2016-1661: Memory corruption in cross-process frames. Credit to Wadih Matar. - [603732] High CVE-2016-1662: Use-after-free in extensions. Credit to Rob Wu. - [603987] High CVE-2016-1663: Use-after-free in Blink's V8 bindings. Credit to anonymous. - [597322] Medium CVE-2016-1664: Address bar spoofing. Credit to Wadih Matar. - [606181] Medium CVE-2016-1665: Information leak in V8. Credit to HyungSeok Han. - [607652] CVE-2016-1666: Various fixes from internal audits, fuzzing and other initiatives.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 91374
    published 2016-05-31
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91374
    title FreeBSD : chromium -- multiple vulnerabilities (7da1da96-24bb-11e6-bd31-3065ec8fd3ec)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2016-756.NASL
    description Chromium was updated to 51.0.2704.103 to fix three vulnerabilities : - CVE-2016-1704: Various fixes from internal audits, fuzzing and other initiatives (shared identifier) (boo#985397) Includes vulnerability fixes from 50.0.2661.102 (boo#979859) : - CVE-2016-1667: Same origin bypass in DOM - CVE-2016-1668: Same origin bypass in Blink V8 bindings - CVE-2016-1669: Buffer overflow in V8 - CVE-2016-1670: Race condition in loader Includes vulnerability fixes from 50.0.2661.94 (boo#977830) : - CVE-2016-1660: Out-of-bounds write in Blink - CVE-2016-1661: Memory corruption in cross-process frames - CVE-2016-1662: Use-after-free in extensions - CVE-2016-1663: Use-after-free in Blink’s V8 bindings - CVE-2016-1664: Address bar spoofing - CVE-2016-1665: Information leak in V8 - CVE-2016-1666: Various fixes from internal audits, fuzzing and other initiatives
    last seen 2019-02-21
    modified 2016-10-13
    plugin id 91848
    published 2016-06-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91848
    title openSUSE Security Update : Chromium (openSUSE-2016-756)
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-2960-1.NASL
    description An out of bounds write was discovered in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code. (CVE-2016-1660) It was discovered that Blink assumes that a frame which passes same-origin checks is local in some cases. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code. (CVE-2016-1661) A use-after-free was discovered in the V8 bindings in Blink. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code. (CVE-2016-1663) It was discovered that the JSGenericLowering class in V8 mishandles comparison operators. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to obtain sensitive information. (CVE-2016-1665) Multiple security issues were discovered in Chromium. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to read uninitialized memory, cause a denial of service via application crash or execute arbitrary code. (CVE-2016-1666) It was discovered that the TreeScope::adoptIfNeeded function in Blink does not prevent script execution during node-adoption operations. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same origin restrictions. (CVE-2016-1667) It was discovered that the forEachForBinding in the V8 bindings in Blink uses an improper creation context. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same origin restrictions. (CVE-2016-1668) A buffer overflow was discovered in V8. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via renderer crash, or execute arbitrary code. (CVE-2016-1669) A race condition was discovered in ResourceDispatcherHostImpl in Chromium. An attacker could potentially exploit this to make arbitrary HTTP requests. (CVE-2016-1670). Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-12-01
    plugin id 91257
    published 2016-05-19
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=91257
    title Ubuntu 14.04 LTS / 15.10 / 16.04 LTS : oxide-qt vulnerabilities (USN-2960-1)
redhat via4
advisories
rhsa
id RHSA-2016:0707
refmap via4
bid 89106
confirm
debian DSA-3564
gentoo GLSA-201605-02
suse
  • openSUSE-SU-2016:1207
  • openSUSE-SU-2016:1208
  • openSUSE-SU-2016:1209
  • openSUSE-SU-2016:1655
ubuntu USN-2960-1
Last major update 26-04-2017 - 21:59
Published 14-05-2016 - 17:59
Last modified 30-10-2018 - 12:27
Back to Top