ID CVE-2016-10244
Summary The parse_charstrings function in type1/t1load.c in FreeType 2 before 2.7 does not ensure that a font contains a glyph name, which allows remote attackers to cause a denial of service (heap-based buffer over-read) or possibly have unspecified other impact via a crafted file.
References
Vulnerable Configurations
  • cpe:2.3:a:freetype:freetype2:2.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.3:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.4:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.4:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.5:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.5:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.6:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.6:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.7:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.7:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.8:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.8:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.9:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.9:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.10:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.10:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.11:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.11:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.4.12:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.4.12:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.0:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.0:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.0.1:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.0.1:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.1:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.1:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.2:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.2:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.3:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.3:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.4:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.4:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.5.5:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.5.5:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.0:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.2:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.2:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.3:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.3:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.4:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.4:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.6.5:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.6.5:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.7:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.7:*:*:*:*:*:*:*
  • cpe:2.3:a:freetype:freetype2:2.7.0:*:*:*:*:*:*:*
    cpe:2.3:a:freetype:freetype2:2.7.0:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
    cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
CVSS
Base: 6.8 (as of 18-01-2018 - 22:45)
Impact:
Exploitability:
CWE CWE-125
CAPEC
  • Overread Buffers
    An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:P/I:P/A:P
refmap via4
bid 97405
confirm
debian DSA-3839
gentoo GLSA-201706-14
sectrack
  • 1038090
  • 1038201
Last major update 18-01-2018 - 22:45
Published 06-03-2017 - 06:59
Back to Top