ID CVE-2016-1007
Summary Adobe Reader and Acrobat before 11.0.15, Acrobat and Acrobat Reader DC Classic before 15.006.30121, and Acrobat and Acrobat Reader DC Continuous before 15.010.20060 on Windows and OS X allow attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2016-1009.
References
Vulnerable Configurations
  • Adobe Acrobat Reader DC 15.010.20059 Continuous
    cpe:2.3:a:adobe:acrobat_reader_dc:15.010.20059:-:-:-:continuous
  • Adobe Acrobat DC 15.010.20059 Continuous
    cpe:2.3:a:adobe:acrobat_dc:15.010.20059:-:-:-:continuous
  • Adobe Acrobat Reader DC 15.006.30119 Classic
    cpe:2.3:a:adobe:acrobat_reader_dc:15.006.30119:-:-:-:classic
  • Adobe Acrobat DC 15.006.30119 Classic
    cpe:2.3:a:adobe:acrobat_dc:15.006.30119:-:-:-:classic
  • Adobe Acrobat 11.0.14
    cpe:2.3:a:adobe:acrobat:11.0.14
  • Adobe Acrobat Reader 11.0.14
    cpe:2.3:a:adobe:acrobat_reader:11.0.14
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
CVSS
Base: 10.0 (as of 10-03-2016 - 13:57)
Impact:
Exploitability:
CWE CWE-119
CAPEC
  • Buffer Overflow via Environment Variables
    This attack pattern involves causing a buffer overflow through manipulation of environment variables. Once the attacker finds that they can modify an environment variable, they may try to overflow associated buffers. This attack leverages implicit trust often placed in environment variables.
  • Overflow Buffers
    Buffer Overflow attacks target improper or missing bounds checking on buffer operations, typically triggered by input injected by an attacker. As a consequence, an attacker is able to write past the boundaries of allocated buffer regions in memory, causing a program crash or potentially redirection of execution as per the attackers' choice.
  • Client-side Injection-induced Buffer Overflow
    This type of attack exploits a buffer overflow vulnerability in targeted client software through injection of malicious content from a custom-built hostile service.
  • Filter Failure through Buffer Overflow
    In this attack, the idea is to cause an active filter to fail by causing an oversized transaction. An attacker may try to feed overly long input strings to the program in an attempt to overwhelm the filter (by causing a buffer overflow) and hoping that the filter does not fail securely (i.e. the user input is let into the system unfiltered).
  • MIME Conversion
    An attacker exploits a weakness in the MIME conversion routine to cause a buffer overflow and gain control over the mail server machine. The MIME system is designed to allow various different information formats to be interpreted and sent via e-mail. Attack points exist when data are converted to MIME compatible format and back.
  • Overflow Binary Resource File
    An attack of this type exploits a buffer overflow vulnerability in the handling of binary resources. Binary resources may include music files like MP3, image files like JPEG files, and any other binary file. These attacks may pass unnoticed to the client machine through normal usage of files, such as a browser loading a seemingly innocent JPEG file. This can allow the attacker access to the execution stack and execute arbitrary code in the target process. This attack pattern is a variant of standard buffer overflow attacks using an unexpected vector (binary files) to wrap its attack and open up a new attack vector. The attacker is required to either directly serve the binary content to the victim, or place it in a locale like a MP3 sharing application, for the victim to download. The attacker then is notified upon the download or otherwise locates the vulnerability opened up by the buffer overflow.
  • Buffer Overflow via Symbolic Links
    This type of attack leverages the use of symbolic links to cause buffer overflows. An attacker can try to create or manipulate a symbolic link file such that its contents result in out of bounds data. When the target software processes the symbolic link file, it could potentially overflow internal buffers with insufficient bounds checking.
  • Overflow Variables and Tags
    This type of attack leverages the use of tags or variables from a formatted configuration data to cause buffer overflow. The attacker crafts a malicious HTML page or configuration file that includes oversized strings, thus causing an overflow.
  • Buffer Overflow via Parameter Expansion
    In this attack, the target software is given input that the attacker knows will be modified and expanded in size during processing. This attack relies on the target software failing to anticipate that the expanded data may exceed some internal limit, thereby creating a buffer overflow.
  • Buffer Overflow in an API Call
    This attack targets libraries or shared code modules which are vulnerable to buffer overflow attacks. An attacker who has access to an API may try to embed malicious code in the API function call and exploit a buffer overflow vulnerability in the function's implementation. All clients that make use of the code library thus become vulnerable by association. This has a very broad effect on security across a system, usually affecting more than one software process.
  • Buffer Overflow in Local Command-Line Utilities
    This attack targets command-line utilities available in a number of shells. An attacker can leverage a vulnerability found in a command-line utility to escalate privilege to root.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family Windows
    NASL id ADOBE_READER_APSB16-09.NASL
    description The version of Adobe Reader installed on the remote Windows host is prior to 11.0.15, 15.006.30121, or 15.010.20060. It is, therefore, affected by multiple vulnerabilities : - A memory corruption issue exists due to the use of uninitialized memory when handling annotation gestures. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1007) - A flaw exists related to searching and loading dynamic-link library (DLL) files due to using a search path that may contain directories which are not trusted or under the user's control. An attacker can exploit this, by injecting a malicious DLL into the path, to gain elevated privileges. (CVE-2016-1008) - An array indexing error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1009) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-06-29
    plugin id 89831
    published 2016-03-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89831
    title Adobe Reader < 11.0.15 / 15.006.30121 / 15.010.20060 Multiple Vulnerabilities (APSB16-09)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_READER_APSB16-09.NASL
    description The version of Adobe Reader installed on the remote Mac OS X host is prior to 11.0.15, 15.006.30121, or 15.010.20060. It is, therefore, affected by multiple vulnerabilities : - A memory corruption issue exists due to the use of uninitialized memory when handling annotation gestures. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1007) - A flaw exists related to searching and loading dynamic-link library (DLL) files due to using a search path that may contain directories which are not trusted or under the user's control. An attacker can exploit this, by injecting a malicious DLL into the path, to gain elevated privileges. (CVE-2016-1008) - An array indexing error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1009) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 89833
    published 2016-03-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89833
    title Adobe Reader < 11.0.15 / 15.006.30121 / 15.010.20060 Multiple Vulnerabilities (APSB16-09) (Mac OS X)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_ACROBAT_APSB16-09.NASL
    description The version of Adobe Acrobat installed on the remote Mac OS X host is prior to 11.0.15, 15.006.30121, or 15.010.20060. It is, therefore, affected by multiple vulnerabilities : - A memory corruption issue exists due to the use of uninitialized memory when handling annotation gestures. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1007) - A flaw exists related to searching and loading dynamic-link library (DLL) files due to using a search path that may contain directories which are not trusted or under the user's control. An attacker can exploit this, by injecting a malicious DLL into the path, to gain elevated privileges. (CVE-2016-1008) - An array indexing error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1009) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 89832
    published 2016-03-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89832
    title Adobe Acrobat < 11.0.15 / 15.006.30121 / 15.010.20060 Multiple Vulnerabilities (APSB16-09) (Mac OS X)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSB16-09.NASL
    description The version of Adobe Acrobat installed on the remote Windows host is prior to 11.0.15, 15.006.30121, or 15.010.20060. It is, therefore, affected by multiple vulnerabilities : - A memory corruption issue exists due to the use of uninitialized memory when handling annotation gestures. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1007) - A flaw exists related to searching and loading dynamic-link library (DLL) files due to using a search path that may contain directories which are not trusted or under the user's control. An attacker can exploit this, by injecting a malicious DLL into the path, to gain elevated privileges. (CVE-2016-1008) - An array indexing error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a crafted PDF file, to corrupt memory, resulting in a denial of service or the execution of arbitrary code. (CVE-2016-1009) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-06-29
    plugin id 89830
    published 2016-03-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=89830
    title Adobe Acrobat < 11.0.15 / 15.006.30121 / 15.010.20060 Multiple Vulnerabilities (APSB16-09)
refmap via4
bid 84215
confirm https://helpx.adobe.com/security/products/acrobat/apsb16-09.html
misc http://www.zerodayinitiative.com/advisories/ZDI-16-189
sectrack 1035199
Last major update 02-12-2016 - 22:19
Published 09-03-2016 - 06:59
Back to Top