ID CVE-2015-3042
Summary Adobe Flash Player before 13.0.0.281 and 14.x through 17.x before 17.0.0.169 on Windows and OS X and before 11.2.202.457 on Linux allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, and CVE-2015-3043.
References
Vulnerable Configurations
  • Adobe Flash Player 11.2.202.451
    cpe:2.3:a:adobe:flash_player:11.2.202.451
  • Linux Kernel
    cpe:2.3:o:linux:linux_kernel
  • Adobe Flash Player 13.0.0.264
    cpe:2.3:a:adobe:flash_player:13.0.0.264
  • Adobe Flash Player 14.0.0.125
    cpe:2.3:a:adobe:flash_player:14.0.0.125
  • Adobe Flash Player 14.0.0.145
    cpe:2.3:a:adobe:flash_player:14.0.0.145
  • Adobe Flash Player 14.0.0.176
    cpe:2.3:a:adobe:flash_player:14.0.0.176
  • Adobe Flash Player 14.0.0.179
    cpe:2.3:a:adobe:flash_player:14.0.0.179
  • Adobe Flash Player 15.0.0.152
    cpe:2.3:a:adobe:flash_player:15.0.0.152
  • Adobe Flash Player 15.0.0.167
    cpe:2.3:a:adobe:flash_player:15.0.0.167
  • Adobe Flash Player 15.0.0.189
    cpe:2.3:a:adobe:flash_player:15.0.0.189
  • Adobe Flash Player 15.0.0.223
    cpe:2.3:a:adobe:flash_player:15.0.0.223
  • Adobe Flash Player 15.0.0.239
    cpe:2.3:a:adobe:flash_player:15.0.0.239
  • Adobe Flash Player 15.0.0.246
    cpe:2.3:a:adobe:flash_player:15.0.0.246
  • Adobe Flash Player 16.0.0.235
    cpe:2.3:a:adobe:flash_player:16.0.0.235
  • Adobe Flash Player 16.0.0.257
    cpe:2.3:a:adobe:flash_player:16.0.0.257
  • Adobe Flash Player 16.0.0.287
    cpe:2.3:a:adobe:flash_player:16.0.0.287
  • Adobe Flash Player 16.0.0.296
    cpe:2.3:a:adobe:flash_player:16.0.0.296
  • Adobe Flash Player 17.0.0.134
    cpe:2.3:a:adobe:flash_player:17.0.0.134
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • OpenSUSE 13.1
    cpe:2.3:o:opensuse:opensuse:13.1
  • OpenSUSE 13.2
    cpe:2.3:o:opensuse:opensuse:13.2
  • SUSE SUSE Linux Enterprise Desktop 11.0 Service Pack 3
    cpe:2.3:o:suse:suse_linux_enterprise_desktop:11.0:sp3
  • cpe:2.3:o:suse:suse_linux_enterprise_desktop:12.0
    cpe:2.3:o:suse:suse_linux_enterprise_desktop:12.0
  • cpe:2.3:o:suse:suse_linux_workstation_extension:12.0
    cpe:2.3:o:suse:suse_linux_workstation_extension:12.0
  • Red Hat Enterprise Linux Desktop Supplementary 5.0
    cpe:2.3:o:redhat:enterprise_linux_desktop_supplementary:5.0
  • Red Hat Enterprise Linux Desktop Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_desktop_supplementary:6.0
  • Red Hat Enterprise Linux Server Supplementary 5.0
    cpe:2.3:o:redhat:enterprise_linux_server_supplementary:5.0
  • Red Hat Enterprise Linux Server Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_server_supplementary:6.0
  • cpe:2.3:o:redhat:enterprise_linux_server_supplementary_eus:6.6.z
    cpe:2.3:o:redhat:enterprise_linux_server_supplementary_eus:6.6.z
  • Red Hat Enterprise Linux Workstation Supplementary 6.0 (v. 6)
    cpe:2.3:o:redhat:enterprise_linux_workstation_supplementary:6.0
CVSS
Base: 10.0 (as of 09-11-2016 - 14:18)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
exploit-db via4
description Flash PCRE Regex Compilation Zero-Length Assertion Arbitrary Bytecode Execution. CVE-2015-3042. Dos exploit for linux platform
file exploits/linux/dos/37839.txt
id EDB-ID:37839
last seen 2016-02-04
modified 2015-08-19
platform linux
port
published 2015-08-19
reporter Google Security Research
source https://www.exploit-db.com/download/37839/
title Flash PCRE Regex Compilation Zero-Length Assertion Arbitrary Bytecode Execution
type dos
nessus via4
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201504-07.NASL
    description The remote host is affected by the vulnerability described in GLSA-201504-07 (Adobe Flash Player: Multiple vulnerabilities) Multiple vulnerabilities have been discovered in Adobe Flash Player. Please review the CVE identifiers referenced below for details. Impact : A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2016-05-20
    plugin id 84072
    published 2015-06-10
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=84072
    title GLSA-201504-07 : Adobe Flash Player: Multiple vulnerabilities
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2015-304.NASL
    description Adobe Flash Player was updated to 11.2.202.457 to fix several security issues that could lead to remote code execution. An exploit for CVE-2015-3043 was reported to exist in the wild. The following vulnerabilities were fixed : - Memory corruption vulnerabilities that could lead to code execution (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043). - Type confusion vulnerability that could lead to code execution (CVE-2015-0356). - Buffer overflow vulnerability that could lead to code execution (CVE-2015-0348). - Use-after-free vulnerabilities that could lead to code execution (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039). - Double-free vulnerabilities that could lead to code execution (CVE-2015-0346, CVE-2015-0359). - Memory leak vulnerabilities that could be used to bypass ASLR (CVE-2015-0357, CVE-2015-3040). - Security bypass vulnerability that could lead to information disclosure (CVE-2015-3044).
    last seen 2019-02-21
    modified 2015-07-06
    plugin id 82807
    published 2015-04-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82807
    title openSUSE Security Update : Adobe Flash Player (openSUSE-2015-304)
  • NASL family Windows
    NASL id FLASH_PLAYER_APSB15-06.NASL
    description The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 17.0.0.134. It is, therefore, affected by multiple vulnerabilities : - Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359) - Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) - A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348) - Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039) - An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356) - Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040) - An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2018-07-11
    plugin id 82781
    published 2015-04-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82781
    title Adobe Flash Player <= 17.0.0.134 Multiple Vulnerabilities (APSB15-06)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_3364D497E4E611E4A265C485083CA99C.NASL
    description Adobe reports : Adobe has released security updates for Adobe Flash Player for Windows, Macintosh and Linux. These updates address vulnerabilities that could potentially allow an attacker to take control of the affected system. Adobe is aware of a report that an exploit for CVE-2015-3043 exists in the wild, and recommends users update their product installations to the latest versions. - These updates resolve memory corruption vulnerabilities that could lead to code execution (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043). - These updates resolve a type confusion vulnerability that could lead to code execution (CVE-2015-0356). - These updates resolve a buffer overflow vulnerability that could lead to code execution (CVE-2015-0348). - These updates resolve use-after-free vulnerabilities that could lead to code execution (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039). - These updates resolve double-free vulnerabilities that could lead to code execution (CVE-2015-0346, CVE-2015-0359). - These updates resolve memory leak vulnerabilities that could be used to bypass ASLR (CVE-2015-0357, CVE-2015-3040). - These updates resolve a security bypass vulnerability that could lead to information disclosure (CVE-2015-3044).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 82890
    published 2015-04-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82890
    title FreeBSD : Adobe Flash Player -- critical vulnerabilities (3364d497-e4e6-11e4-a265-c485083ca99c)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2015-0813.NASL
    description An updated Adobe Flash Player package that fixes multiple security issues is now available for Red Hat Enterprise Linux 5 and 6 Supplementary. Red Hat Product Security has rated this update as having Critical security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section. The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in. This update fixes multiple vulnerabilities in Adobe Flash Player. These vulnerabilities are detailed in the Adobe Security Bulletin APSB15-06 listed in the References section. Multiple flaws were found in the way flash-plugin displayed certain SWF content. An attacker could use these flaws to create a specially crafted SWF file that would cause flash-plugin to crash or, potentially, execute arbitrary code when the victim loaded a page containing the malicious SWF content. (CVE-2015-0346, CVE-2015-0347, CVE-2015-0348, CVE-2015-0349, CVE-2015-0350, CVE-2015-0351, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0356, CVE-2015-0358, CVE-2015-0359, CVE-2015-0360, CVE-2015-3038, CVE-2015-3039, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) A security bypass flaw was found in flash-plugin that could lead to the disclosure of sensitive information. (CVE-2015-3044) Two memory information leak flaws were found in flash-plugin that could allow an attacker to potentially bypass ASLR (Address Space Layout Randomization) protection, and make it easier to exploit other flaws. (CVE-2015-0357, CVE-2015-3040) All users of Adobe Flash Player should install this updated package, which upgrades Flash Player to version 11.2.202.457.
    last seen 2019-02-21
    modified 2018-12-27
    plugin id 82812
    published 2015-04-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82812
    title RHEL 5 / 6 : flash-plugin (RHSA-2015:0813)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_FLASH-PLAYER-150415.NASL
    description Adobe Flash Player was updated to version 11.2.202.457 to fix several security issues that could have lead to remote code execution. An exploit for CVE-2015-3043 was reported to exist in the wild. The following vulnerabilities have been fixed : - Memory corruption vulnerabilities that could have lead to code execution. (CVE-2015-0347 / CVE-2015-0350 / CVE-2015-0352 / CVE-2015-0353 / CVE-2015-0354 / CVE-2015-0355 / CVE-2015-0360 / CVE-2015-3038 / CVE-2015-3041 / CVE-2015-3042 / CVE-2015-3043) - Type confusion vulnerability that could have lead to code execution. (CVE-2015-0356) - Buffer overflow vulnerability that could have lead to code execution. (CVE-2015-0348) - Use-after-free vulnerabilities that could have lead to code execution. (CVE-2015-0349 / CVE-2015-0351 / CVE-2015-0358 / CVE-2015-3039) - Double-free vulnerabilities that could have lead to code execution. (CVE-2015-0346 / CVE-2015-0359) - Memory leak vulnerabilities that could have been used to bypass ASLR. (CVE-2015-0357 / CVE-2015-3040) - Security bypass vulnerability that could have lead to information disclosure. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2016-12-21
    plugin id 82819
    published 2015-04-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82819
    title SuSE 11.3 Security Update : flash-player (SAT Patch Number 10615)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_AIR_APSB15-06.NASL
    description According to its version, the installation of Adobe AIR on the remote Mac OS X host is equal or prior to 17.0.0.144. It is, therefore, affected by multiple vulnerabilities : - Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359) - Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) - A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348) - Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039) - An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356) - Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040) - An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 84160
    published 2015-06-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=84160
    title Adobe AIR for Mac <= 17.0.0.144 Multiple Vulnerabilities (APSB15-06)
  • NASL family Windows
    NASL id SMB_KB3049508.NASL
    description The remote Windows host is missing KB3049508. It is, therefore, affected by the following vulnerabilities : - Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359) - Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) - A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348) - Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039) - An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356) - Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040) - An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 82823
    published 2015-04-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82823
    title MS KB3049508: Update for Vulnerabilities in Adobe Flash Player in Internet Explorer
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_FLASH_PLAYER_APSA15-06.NASL
    description The version of Adobe Flash Player installed on the remote Mac OS X host is equal or prior to version 17.0.0.134. It is, therefore, affected by multiple vulnerabilities : - Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359) - Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) - A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348) - Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039) - An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356) - Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040) - An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 82782
    published 2015-04-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=82782
    title Adobe Flash Player <= 17.0.0.134 Multiple Vulnerabilities (APSB15-06)
  • NASL family Windows
    NASL id ADOBE_AIR_APSB15-06.NASL
    description According to its version, the installation of Adobe AIR on the remote Windows host is equal or prior to 17.0.0.144. It is, therefore, affected by multiple vulnerabilities : - Multiple double-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0346, CVE-2015-0359) - Multiple memory corruption flaws exist due to improper validation of user-supplied input. A remote attacker can exploit these flaws, via specially crafted flash content, to corrupt memory and execute arbitrary code. (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043) - A unspecified buffer overflow condition exists due to improper validation of user-supplied input. A remote attacker can exploit this to execute arbitrary code. (CVE-2015-0348) - Multiple unspecified use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039) - An unspecified type confusion flaw exists that allows an attacker to execute arbitrary code. (CVE-2015-0356) - Multiple unspecified memory leaks exist that allows an attacker to bypass the Address Space Layout Randomization (ASLR) feature. (CVE-2015-0357, CVE-2015-3040) - An unspecified security bypass flaw exists that allows an attacker to disclose information. (CVE-2015-3044)
    last seen 2019-02-21
    modified 2018-06-27
    plugin id 84156
    published 2015-06-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=84156
    title Adobe AIR <= 17.0.0.144 Multiple Vulnerabilities (APSB15-06)
redhat via4
advisories
rhsa
id RHSA-2015:0813
refmap via4
bid 74062
confirm https://helpx.adobe.com/security/products/flash-player/apsb15-06.html
exploit-db 37839
gentoo GLSA-201504-07
sectrack 1032105
suse
  • SUSE-SU-2015:0722
  • SUSE-SU-2015:0723
  • openSUSE-SU-2015:0718
  • openSUSE-SU-2015:0725
Last major update 02-01-2017 - 21:59
Published 14-04-2015 - 18:59
Last modified 30-10-2018 - 12:27
Back to Top