ID CVE-2014-6166
Summary The Communications Enabled Applications (CEA) service in IBM WebSphere Application Server 8.0.x before 8.0.0.10 and 8.5.x before 8.5.5.4, and Feature Pack for CEA 1.x before 1.0.0.15, allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
References
Vulnerable Configurations
  • IBM WebSphere Application Server 8.0.0.0
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.0
  • IBM WebSphere Application Server 8.0.0.1
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.1
  • IBM WebSphere Application Server 8.0.0.2 (Fix Pack 2)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.2
  • IBM WebSphere Application Server 8.0.0.3 (Fix Pack 3)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.3
  • IBM WebSphere Application Server 8.0.0.4 (Fix Pack 4)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.4
  • IBM WebSphere Application Server 8.0.0.5 (FixPack 5)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.5
  • IBM WebSphere Application Server 8.0.0.6 (Fix Pack 6)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.6
  • IBM WebSphere Application Server 8.0.0.7 (Fix Pack 7)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.7
  • IBM WebSphere Application Server 8.0.0.8 (Fix Pack 8)
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.8
  • IBM WebSphere Application Server 8.0.0.9
    cpe:2.3:a:ibm:websphere_application_server:8.0.0.9
  • IBM WebSphere Application Server 8.5.0.0
    cpe:2.3:a:ibm:websphere_application_server:8.5.0.0
  • IBM WebSphere Application Server 8.5.0.1 (Fix Pack 1)
    cpe:2.3:a:ibm:websphere_application_server:8.5.0.1
  • IBM WebSphere Application Server 8.5.0.2 (Fix Pack 2)
    cpe:2.3:a:ibm:websphere_application_server:8.5.0.2
  • IBM WebSphere Application Server 8.5.5.0
    cpe:2.3:a:ibm:websphere_application_server:8.5.5.0
  • IBM WebSphere Application Server 8.5.5.1
    cpe:2.3:a:ibm:websphere_application_server:8.5.5.1
  • IBM WebSphere Application Server 8.5.5.2
    cpe:2.3:a:ibm:websphere_application_server:8.5.5.2
  • IBM WebSphere Application Server 8.5.5.33 (Fix Pack 3)
    cpe:2.3:a:ibm:websphere_application_server:8.5.5.3
CVSS
Base: 4.3 (as of 18-12-2014 - 14:51)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
nessus via4
  • NASL family Web Servers
    NASL id WEBSPHERE_8_5_5_4.NASL
    description The IBM WebSphere Application Server running on the remote host is version 8.5 prior to Fix Pack 8.5.5.4. It is, therefore, affected by the following vulnerabilities : - Multiple errors exist related to the included IBM HTTP server that can allow remote code execution or denial of service. (CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231 / PI22070) - An unspecified error exists related to HTTP headers that can allow information disclosure. (CVE-2014-3021 / PI08268) - An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A man-in-the-middle attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566 / PI28435, PI28436, PI28437) - An unspecified input validation errors exist related to the administrative console that can allow cross-site scripting and cross-site request forgery attacks. (CVE-2014-4770, CVE-2014-4816 / PI23055) - An unspecified error exists that can allow OpenID and OpenID Connect cookies to be spoofed, allowing information disclosure. (CVE-2014-6164 / PI23430) - An error exists related to the Communications Enabled Applications (CEA) service that can allow XML External Entity Injection (XXE) attacks leading to information disclosure. This only occurs if CEA is enabled. By default this is disabled. (CVE-2014-6166 / PI25310) - An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819) - An error exists related to the administrative console that can allow 'click-jacking' attacks. (CVE-2014-6174 / PI27152) - An error exists related to deployment descriptor security constraints and ServletSecurity annotations on a servlet that can allow privilege escalation. Note that this issue only affects the 'Liberty Profile'. (CVE-2014-8890 / PI29911)
    last seen 2019-01-16
    modified 2018-11-15
    plugin id 80398
    published 2015-01-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=80398
    title IBM WebSphere Application Server 8.5 < Fix Pack 8.5.5.4 Multiple Vulnerabilities (POODLE)
  • NASL family Web Servers
    NASL id WEBSPHERE_8_0_0_10.NASL
    description The remote host is running IBM WebSphere Application Server version 8.0 prior to Fix Pack 10. It is, therefore, affected by the following vulnerabilities : - Multiple errors exist related to the included IBM HTTP server that can allow remote code execution or denial of service. (CVE-2013-5704, CVE-2014-0118, CVE-2014-0226, CVE-2014-0231 / PI22070) - An error exists related to the implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) that could allow nonce disclosure via the 'FLUSH+RELOAD' cache side-channel attack. (CVE-2014-0076 / PI19700) - An unspecified error exists related to HTTP headers that can allow information disclosure. (CVE-2014-3021 / PI08268) - An unspecified error caused by improper account creation with the Virtual Member Manager SPI Admin Task 'addFileRegistryAccount' can allow remote attackers to bypass security restrictions. (CVE-2014-3070 / PI16765) - An information disclosure vulnerability exists due to a failure to restrict access to resources located within the web application. A remote attacker can exploit this to obtain configuration data and other sensitive information. (CVE-2014-3083 / PI17768, PI30579 ) - A man-in-the-middle (MitM) information disclosure vulnerability known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. (CVE-2014-3566 / PI28435, PI28436, PI28437) - An unspecified flaw in the Load Balancer for IPv4 Dispatcher component allows a remote attacker to cause a denial of service. (CVE-2014-4764 / PI21189) - An unspecified input validation error exists related to the administrative console that can allow cross-site scripting and cross-site request forgery attacks. (CVE-2014-4770, CVE-2014-4816 / PI23055) - An error exists related to the Communications Enabled Applications (CEA) service that can allow XML External Entity Injection (XXE) attacks leading to information disclosure. This only occurs if CEA is enabled, and by default this is disabled. (CVE-2014-6166 / PI25310) - An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819) - An error exists related to the administrative console that can allow click-jacking attacks. (CVE-2014-6174 / PI27152)
    last seen 2019-01-16
    modified 2018-08-06
    plugin id 81401
    published 2015-02-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=81401
    title IBM WebSphere Application Server 8.0 < Fix Pack 10 Multiple Vulnerabilities (POODLE)
refmap via4
aixapar
  • PI25310
  • PI28632
confirm http://www-01.ibm.com/support/docview.wss?uid=swg21690185
xf ibm-websphere-cve20146166-info-disc(97746)
Last major update 18-12-2014 - 14:57
Published 18-12-2014 - 11:59
Last modified 07-09-2017 - 21:29
Back to Top