ID CVE-2014-5146
Summary Certain MMU virtualization operations in Xen 4.2.x through 4.4.x before the xsa97-hap patch, when using Hardware Assisted Paging (HAP), are not preemptible, which allows local HVM guest to cause a denial of service (vcpu consumption) by invoking these operations, which process every page assigned to a guest, a different vulnerability than CVE-2014-5149.
References
Vulnerable Configurations
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
    cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.2.0:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.2.0:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.2.1:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.2.1:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.2.2:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.2.2:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.2.3:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.2.3:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.3.0:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.3.0:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.3.1:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.3.1:*:*:*:*:*:*:*
  • cpe:2.3:o:xen:xen:4.4.0:*:*:*:*:*:*:*
    cpe:2.3:o:xen:xen:4.4.0:*:*:*:*:*:*:*
CVSS
Base: 4.7 (as of 30-10-2018 - 16:27)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE COMPLETE
cvss-vector via4 AV:L/AC:M/Au:N/C:N/I:N/A:C
refmap via4
bid 69198
confirm http://xenbits.xen.org/xsa/advisory-97.html
fedora
  • FEDORA-2014-9472
  • FEDORA-2014-9493
gentoo GLSA-201504-04
sectrack 1030723
suse
  • openSUSE-SU-2015:0226
  • openSUSE-SU-2015:0256
xf xen-cve20145146-dos(95234)
Last major update 30-10-2018 - 16:27
Published 22-08-2014 - 14:55
Back to Top