ID CVE-2014-0560
Summary Use-after-free vulnerability in Adobe Reader and Acrobat 10.x before 10.1.12 and 11.x before 11.0.09 on Windows and OS X allows attackers to execute arbitrary code via unspecified vectors.
References
Vulnerable Configurations
  • Adobe Acrobat Reader 11.0
    cpe:2.3:a:adobe:acrobat_reader:11.0
  • Adobe Acrobat Reader XI (11.0.1)
    cpe:2.3:a:adobe:acrobat_reader:11.0.1
  • Adobe Acrobat Reader XI (11.0.2)
    cpe:2.3:a:adobe:acrobat_reader:11.0.2
  • Adobe Acrobat Reader XI (11.0.3)
    cpe:2.3:a:adobe:acrobat_reader:11.0.3
  • Adobe Acrobat Reader 11.0.4
    cpe:2.3:a:adobe:acrobat_reader:11.0.4
  • Adobe Acrobat Reader 11.0.5
    cpe:2.3:a:adobe:acrobat_reader:11.0.5:-:-:-:-:windows
  • Adobe Acrobat Reader 11.0.6
    cpe:2.3:a:adobe:acrobat_reader:11.0.6
  • Adobe Acrobat Reader 11.0.7
    cpe:2.3:a:adobe:acrobat_reader:11.0.7
  • Adobe Acrobat Reader 11.0.8
    cpe:2.3:a:adobe:acrobat_reader:11.0.8
  • Adobe Acrobat Reader X (10.0)
    cpe:2.3:a:adobe:acrobat_reader:10.0
  • Adobe Acrobat Reader X (10.0.1)
    cpe:2.3:a:adobe:acrobat_reader:10.0.1
  • Adobe Acrobat Reader X (10.0.2)
    cpe:2.3:a:adobe:acrobat_reader:10.0.2
  • Adobe Acrobat Reader X (10.0.3)
    cpe:2.3:a:adobe:acrobat_reader:10.0.3
  • Adobe Acrobat Reader X 10.1
    cpe:2.3:a:adobe:acrobat_reader:10.1
  • Adobe Acrobat Reader X 10.1.1
    cpe:2.3:a:adobe:acrobat_reader:10.1.1
  • Adobe Acrobat Reader X (10.1.2)
    cpe:2.3:a:adobe:acrobat_reader:10.1.2
  • Adobe Acrobat Reader X (10.1.3)
    cpe:2.3:a:adobe:acrobat_reader:10.1.3
  • Adobe Acrobat Reader X (10.1.4)
    cpe:2.3:a:adobe:acrobat_reader:10.1.4
  • Adobe Acrobat Reader 10.1.5
    cpe:2.3:a:adobe:acrobat_reader:10.1.5
  • Adobe Acrobat Reader X (10.1.6)
    cpe:2.3:a:adobe:acrobat_reader:10.1.6
  • Adobe Acrobat Reader X (10.1.7)
    cpe:2.3:a:adobe:acrobat_reader:10.1.7
  • Adobe Acrobat Reader 10.1.8
    cpe:2.3:a:adobe:acrobat_reader:10.1.8
  • Adobe Acrobat Reader 10.1.9
    cpe:2.3:a:adobe:acrobat_reader:10.1.9
  • Adobe Acrobat Reader X 10.1.10
    cpe:2.3:a:adobe:acrobat_reader:10.1.10
  • Adobe Acrobat Reader 10.1.11
    cpe:2.3:a:adobe:acrobat_reader:10.1.11
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • Adobe Acrobat X (10.0)
    cpe:2.3:a:adobe:acrobat:10.0
  • Adobe Acrobat X Professional
    cpe:2.3:a:adobe:acrobat:10.0:-:pro
  • Adobe Acrobat X (10.0.1)
    cpe:2.3:a:adobe:acrobat:10.0.1
  • Adobe Acrobat 10.0.1 Professional
    cpe:2.3:a:adobe:acrobat:10.0.1:-:pro
  • Adobe Acrobat X (10.0.2)
    cpe:2.3:a:adobe:acrobat:10.0.2
  • Adobe Acrobat X (10.0.3)
    cpe:2.3:a:adobe:acrobat:10.0.3
  • Adobe Acrobat X (10.1)
    cpe:2.3:a:adobe:acrobat:10.1
  • Adobe Acrobat X (10.1.1)
    cpe:2.3:a:adobe:acrobat:10.1.1
  • Adobe Acrobat X (10.1.2)
    cpe:2.3:a:adobe:acrobat:10.1.2
  • Adobe Acrobat X (10.1.3)
    cpe:2.3:a:adobe:acrobat:10.1.3
  • Adobe Acrobat X (10.1.4)
    cpe:2.3:a:adobe:acrobat:10.1.4
  • Adobe Acrobat 10.1.5
    cpe:2.3:a:adobe:acrobat:10.1.5
  • Adobe Acrobat 10.1.6
    cpe:2.3:a:adobe:acrobat:10.1.6
  • Adobe Acrobat 10.1.7
    cpe:2.3:a:adobe:acrobat:10.1.7
  • Adobe Acrobat 10.1.8
    cpe:2.3:a:adobe:acrobat:10.1.8
  • Adobe Acrobat 10.1.9
    cpe:2.3:a:adobe:acrobat:10.1.9
  • Adobe Acrobat X (10.1.10)
    cpe:2.3:a:adobe:acrobat:10.1.10
  • Adobe Acrobat 10.1.11
    cpe:2.3:a:adobe:acrobat:10.1.11
  • Adobe Acrobat 11.0
    cpe:2.3:a:adobe:acrobat:11.0
  • Adobe Acrobat XI (11.0.1)
    cpe:2.3:a:adobe:acrobat:11.0.1
  • Adobe Acrobat XI (11.0.2)
    cpe:2.3:a:adobe:acrobat:11.0.2
  • Adobe Acrobat XI (11.0.3)
    cpe:2.3:a:adobe:acrobat:11.0.3
  • Adobe Acrobat 11.0.4
    cpe:2.3:a:adobe:acrobat:11.0.4
  • Adobe Acrobat 11.0.5
    cpe:2.3:a:adobe:acrobat:11.0.5:-:-:-:-:windows
  • Adobe Acrobat 11.0.6
    cpe:2.3:a:adobe:acrobat:11.0.6
  • Adobe Acrobat 11.0.7
    cpe:2.3:a:adobe:acrobat:11.0.7
  • Adobe Acrobat 11.0.8
    cpe:2.3:a:adobe:acrobat:11.0.8
  • Apple Mac OS X
    cpe:2.3:o:apple:mac_os_x
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
CVSS
Base: 10.0 (as of 17-09-2014 - 09:10)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_READER_APSB14-20.NASL
    description The version of Adobe Reader installed on the remote host is version 10.x equal to or prior to 10.1.10, or 11.x equal to or prior to 11.0.07. It is, therefore, affected by multiple vulnerabilities : - A use-after-free error exists that allows arbitrary code execution. (CVE-2014-0560) - A heap-based buffer overflow exists that allows arbitrary code execution. (CVE-2014-0561, CVE-2014-0567) - An input-validation error exists that allows universal cross-site scripting (UXSS) attacks. (CVE-2014-0562) - A memory corruption error exists that allows denial of service attacks. (CVE-2014-0563) - Memory corruption errors exist that allow arbitrary code execution. (CVE-2014-0565, CVE-2014-0566) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 77714
    published 2014-09-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77714
    title Adobe Reader <= 10.1.10 / 11.0.07 Multiple Vulnerabilities (APSB14-20) (Mac OS X)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSB14-20.NASL
    description The version of Adobe Acrobat installed on the remote host is a version prior to 10.1.12 / 11.0.09. It is, therefore, affected by the following vulnerabilities : - A use-after-free error exists that allows arbitrary code execution. (CVE-2014-0560) - A heap-based buffer overflow exists that allows arbitrary code execution. (CVE-2014-0561, CVE-2014-0567) - A memory corruption error exists that allows denial of service attacks. (CVE-2014-0563) - Memory corruption errors exist that allows arbitrary code execution. (CVE-2014-0565, CVE-2014-0566) - An unspecified error exists that allows the bypassing of the sandbox security restrictions. (CVE-2014-0568) - A race condition exists in the 'MoveFileEx' call hook feature that allows attackers to bypass the sandbox protection mechanism to write files to arbitrary locations. Note that this issue only affects Adobe Acrobat 11.x. This issue has not been officially fixed in APSB14-20; however, it is unlikely to be exploitable due to a related defense-in-depth change in version 11.0.09. (CVE-2014-9150) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-08-31
    plugin id 77711
    published 2014-09-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77711
    title Adobe Acrobat < 10.1.12 / 11.0.09 Multiple Vulnerabilities (APSB14-20)
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_ACROBAT_APSB14-20.NASL
    description The version of Adobe Acrobat installed on the remote host is version 10.x equal to or prior to 10.1.10, or 11.x equal to or prior to 11.0.07. It is, therefore, affected by multiple vulnerabilities : - A use-after-free error exists that allows arbitrary code execution. (CVE-2014-0560) - A heap-based buffer overflow exists that allows arbitrary code execution. (CVE-2014-0561, CVE-2014-0567) - An input-validation error exists that allows universal cross-site scripting (UXSS) attacks. (CVE-2014-0562) - A memory corruption error exists that allows denial of service attacks. (CVE-2014-0563) - Memory corruption errors exist that allow arbitrary code execution. (CVE-2014-0565, CVE-2014-0566) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 77713
    published 2014-09-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77713
    title Adobe Acrobat <= 10.1.10 / 11.0.07 Multiple Vulnerabilities (APSB14-20) (Mac OS X)
  • NASL family Windows
    NASL id ADOBE_READER_APSB14-20.NASL
    description The version of Adobe Reader installed on the remote host is a version prior to 10.1.12 / 11.0.09. It is, therefore, affected by the following vulnerabilities : - A use-after-free error exists that allows arbitrary code execution. (CVE-2014-0560) - A heap-based buffer overflow exists that allows arbitrary code execution. (CVE-2014-0561, CVE-2014-0567) - A memory corruption error exists that allows denial of service attacks. (CVE-2014-0563) - Memory corruption errors exist that allows arbitrary code execution. (CVE-2014-0565, CVE-2014-0566) - An unspecified error exists that allows the bypassing of the sandbox security restrictions. (CVE-2014-0568) - A race condition exists in the 'MoveFileEx' call hook feature that allows attackers to bypass the sandbox protection mechanism to write files to arbitrary locations. Note that this issue only affects Adobe Reader 11.x. This issue has not been officially fixed in APSB14-20; however, it is unlikely to be exploitable due to a related defense-in-depth change in version 11.0.09. (CVE-2014-9150) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-08-31
    plugin id 77712
    published 2014-09-16
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77712
    title Adobe Reader < 10.1.12 / 11.0.09 Multiple Vulnerabilities (APSB14-20)
refmap via4
bid 69823
confirm http://helpx.adobe.com/security/products/reader/apsb14-20.html
sectrack 1030853
xf adobe-reader-cve20140560-code-exec(96001)
Last major update 06-01-2017 - 21:59
Published 17-09-2014 - 06:55
Last modified 28-08-2017 - 21:34
Back to Top