ID CVE-2013-6663
Summary Use-after-free vulnerability in the SVGImage::setContainerSize function in core/svg/graphics/SVGImage.cpp in the SVG implementation in Blink, as used in Google Chrome before 33.0.1750.146, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to the resizing of a view.
References
Vulnerable Configurations
  • Google Chrome 33.0.1750.124
    cpe:2.3:a:google:chrome:33.0.1750.124
  • Google Chrome 33.0.1750.125
    cpe:2.3:a:google:chrome:33.0.1750.125
  • Google Chrome 33.0.1750.126
    cpe:2.3:a:google:chrome:33.0.1750.126
  • Google Chrome 33.0.1750.132
    cpe:2.3:a:google:chrome:33.0.1750.132
  • Google Chrome 33.0.1750.133
    cpe:2.3:a:google:chrome:33.0.1750.133
  • Google Chrome 33.0.1750.135
    cpe:2.3:a:google:chrome:33.0.1750.135
  • Google Chrome 33.0.1750.136
    cpe:2.3:a:google:chrome:33.0.1750.136
  • Google Chrome 33.0.1750.144
    cpe:2.3:a:google:chrome:33.0.1750.144
  • Google Chrome 33.0.1750.0
    cpe:2.3:a:google:chrome:33.0.1750.0
  • Google Chrome 33.0.1750.1
    cpe:2.3:a:google:chrome:33.0.1750.1
  • Google Chrome 33.0.1750.10
    cpe:2.3:a:google:chrome:33.0.1750.10
  • Google Chrome 33.0.1750.104
    cpe:2.3:a:google:chrome:33.0.1750.104
  • Google Chrome 33.0.1750.106
    cpe:2.3:a:google:chrome:33.0.1750.106
  • Google Chrome 33.0.1750.107
    cpe:2.3:a:google:chrome:33.0.1750.107
  • Google Chrome 33.0.1750.108
    cpe:2.3:a:google:chrome:33.0.1750.108
  • Google Chrome 33.0.1750.109
    cpe:2.3:a:google:chrome:33.0.1750.109
  • Google Chrome 33.0.1750.11
    cpe:2.3:a:google:chrome:33.0.1750.11
  • Google Chrome 33.0.1750.110
    cpe:2.3:a:google:chrome:33.0.1750.110
  • Google Chrome 33.0.1750.111
    cpe:2.3:a:google:chrome:33.0.1750.111
  • Google Chrome 33.0.1750.112
    cpe:2.3:a:google:chrome:33.0.1750.112
  • Google Chrome 33.0.1750.113
    cpe:2.3:a:google:chrome:33.0.1750.113
  • Google Chrome 33.0.1750.115
    cpe:2.3:a:google:chrome:33.0.1750.115
  • Google Chrome 33.0.1750.116
    cpe:2.3:a:google:chrome:33.0.1750.116
  • Google Chrome 33.0.1750.117
    cpe:2.3:a:google:chrome:33.0.1750.117
  • Google Chrome 33.0.1750.12
    cpe:2.3:a:google:chrome:33.0.1750.12
  • Google Chrome 33.0.1750.13
    cpe:2.3:a:google:chrome:33.0.1750.13
  • Google Chrome 33.0.1750.14
    cpe:2.3:a:google:chrome:33.0.1750.14
  • Google Chrome 33.0.1750.15
    cpe:2.3:a:google:chrome:33.0.1750.15
  • Google Chrome 33.0.1750.16
    cpe:2.3:a:google:chrome:33.0.1750.16
  • Google Chrome 33.0.1750.18
    cpe:2.3:a:google:chrome:33.0.1750.18
  • Google Chrome 33.0.1750.19
    cpe:2.3:a:google:chrome:33.0.1750.19
  • Google Chrome 33.0.1750.2
    cpe:2.3:a:google:chrome:33.0.1750.2
  • Google Chrome 33.0.1750.20
    cpe:2.3:a:google:chrome:33.0.1750.20
  • Google Chrome 33.0.1750.21
    cpe:2.3:a:google:chrome:33.0.1750.21
  • Google Chrome 33.0.1750.22
    cpe:2.3:a:google:chrome:33.0.1750.22
  • Google Chrome 33.0.1750.23
    cpe:2.3:a:google:chrome:33.0.1750.23
  • Google Chrome 33.0.1750.24
    cpe:2.3:a:google:chrome:33.0.1750.24
  • Google Chrome 33.0.1750.25
    cpe:2.3:a:google:chrome:33.0.1750.25
  • Google Chrome 33.0.1750.26
    cpe:2.3:a:google:chrome:33.0.1750.26
  • Google Chrome 33.0.1750.27
    cpe:2.3:a:google:chrome:33.0.1750.27
  • Google Chrome 33.0.1750.28
    cpe:2.3:a:google:chrome:33.0.1750.28
  • Google Chrome 33.0.1750.29
    cpe:2.3:a:google:chrome:33.0.1750.29
  • Google Chrome 33.0.1750.3
    cpe:2.3:a:google:chrome:33.0.1750.3
  • Google Chrome 33.0.1750.30
    cpe:2.3:a:google:chrome:33.0.1750.30
  • Google Chrome 33.0.1750.31
    cpe:2.3:a:google:chrome:33.0.1750.31
  • Google Chrome 33.0.1750.34
    cpe:2.3:a:google:chrome:33.0.1750.34
  • Google Chrome 33.0.1750.35
    cpe:2.3:a:google:chrome:33.0.1750.35
  • Google Chrome 33.0.1750.36
    cpe:2.3:a:google:chrome:33.0.1750.36
  • Google Chrome 33.0.1750.37
    cpe:2.3:a:google:chrome:33.0.1750.37
  • Google Chrome 33.0.1750.38
    cpe:2.3:a:google:chrome:33.0.1750.38
  • Google Chrome 33.0.1750.39
    cpe:2.3:a:google:chrome:33.0.1750.39
  • Google Chrome 33.0.1750.4
    cpe:2.3:a:google:chrome:33.0.1750.4
  • Google Chrome 33.0.1750.40
    cpe:2.3:a:google:chrome:33.0.1750.40
  • Google Chrome 33.0.1750.41
    cpe:2.3:a:google:chrome:33.0.1750.41
  • Google Chrome 33.0.1750.42
    cpe:2.3:a:google:chrome:33.0.1750.42
  • Google Chrome 33.0.1750.43
    cpe:2.3:a:google:chrome:33.0.1750.43
  • Google Chrome 33.0.1750.44
    cpe:2.3:a:google:chrome:33.0.1750.44
  • Google Chrome 33.0.1750.45
    cpe:2.3:a:google:chrome:33.0.1750.45
  • Google Chrome 33.0.1750.46
    cpe:2.3:a:google:chrome:33.0.1750.46
  • Google Chrome 33.0.1750.47
    cpe:2.3:a:google:chrome:33.0.1750.47
  • Google Chrome 33.0.1750.48
    cpe:2.3:a:google:chrome:33.0.1750.48
  • Google Chrome 33.0.1750.49
    cpe:2.3:a:google:chrome:33.0.1750.49
  • Google Chrome 33.0.1750.5
    cpe:2.3:a:google:chrome:33.0.1750.5
  • Google Chrome 33.0.1750.50
    cpe:2.3:a:google:chrome:33.0.1750.50
  • Google Chrome 33.0.1750.51
    cpe:2.3:a:google:chrome:33.0.1750.51
  • Google Chrome 33.0.1750.52
    cpe:2.3:a:google:chrome:33.0.1750.52
  • Google Chrome 33.0.1750.53
    cpe:2.3:a:google:chrome:33.0.1750.53
  • Google Chrome 33.0.1750.54
    cpe:2.3:a:google:chrome:33.0.1750.54
  • Google Chrome 33.0.1750.55
    cpe:2.3:a:google:chrome:33.0.1750.55
  • Google Chrome 33.0.1750.56
    cpe:2.3:a:google:chrome:33.0.1750.56
  • Google Chrome 33.0.1750.57
    cpe:2.3:a:google:chrome:33.0.1750.57
  • Google Chrome 33.0.1750.58
    cpe:2.3:a:google:chrome:33.0.1750.58
  • Google Chrome 33.0.1750.59
    cpe:2.3:a:google:chrome:33.0.1750.59
  • Google Chrome 33.0.1750.6
    cpe:2.3:a:google:chrome:33.0.1750.6
  • Google Chrome 33.0.1750.60
    cpe:2.3:a:google:chrome:33.0.1750.60
  • Google Chrome 33.0.1750.61
    cpe:2.3:a:google:chrome:33.0.1750.61
  • Google Chrome 33.0.1750.62
    cpe:2.3:a:google:chrome:33.0.1750.62
  • Google Chrome 33.0.1750.63
    cpe:2.3:a:google:chrome:33.0.1750.63
  • Google Chrome 33.0.1750.64
    cpe:2.3:a:google:chrome:33.0.1750.64
  • Google Chrome 33.0.1750.65
    cpe:2.3:a:google:chrome:33.0.1750.65
  • Google Chrome 33.0.1750.66
    cpe:2.3:a:google:chrome:33.0.1750.66
  • Google Chrome 33.0.1750.67
    cpe:2.3:a:google:chrome:33.0.1750.67
  • Google Chrome 33.0.1750.68
    cpe:2.3:a:google:chrome:33.0.1750.68
  • Google Chrome 33.0.1750.69
    cpe:2.3:a:google:chrome:33.0.1750.69
  • Google Chrome 33.0.1750.7
    cpe:2.3:a:google:chrome:33.0.1750.7
  • Google Chrome 33.0.1750.70
    cpe:2.3:a:google:chrome:33.0.1750.70
  • Google Chrome 33.0.1750.71
    cpe:2.3:a:google:chrome:33.0.1750.71
  • Google Chrome 33.0.1750.73
    cpe:2.3:a:google:chrome:33.0.1750.73
  • Google Chrome 33.0.1750.74
    cpe:2.3:a:google:chrome:33.0.1750.74
  • Google Chrome 33.0.1750.75
    cpe:2.3:a:google:chrome:33.0.1750.75
  • Google Chrome 33.0.1750.76
    cpe:2.3:a:google:chrome:33.0.1750.76
  • Google Chrome 33.0.1750.77
    cpe:2.3:a:google:chrome:33.0.1750.77
  • Google Chrome 33.0.1750.79
    cpe:2.3:a:google:chrome:33.0.1750.79
  • Google Chrome 33.0.1750.8
    cpe:2.3:a:google:chrome:33.0.1750.8
  • Google Chrome 33.0.1750.80
    cpe:2.3:a:google:chrome:33.0.1750.80
  • Google Chrome 33.0.1750.81
    cpe:2.3:a:google:chrome:33.0.1750.81
  • Google Chrome 33.0.1750.82
    cpe:2.3:a:google:chrome:33.0.1750.82
  • Google Chrome 33.0.1750.83
    cpe:2.3:a:google:chrome:33.0.1750.83
  • Google Chrome 33.0.1750.85
    cpe:2.3:a:google:chrome:33.0.1750.85
  • Google Chrome 33.0.1750.88
    cpe:2.3:a:google:chrome:33.0.1750.88
  • Google Chrome 33.0.1750.89
    cpe:2.3:a:google:chrome:33.0.1750.89
  • Google Chrome 33.0.1750.9
    cpe:2.3:a:google:chrome:33.0.1750.9
  • Google Chrome 33.0.1750.90
    cpe:2.3:a:google:chrome:33.0.1750.90
  • Google Chrome 33.0.1750.91
    cpe:2.3:a:google:chrome:33.0.1750.91
  • Google Chrome 33.0.1750.92
    cpe:2.3:a:google:chrome:33.0.1750.92
  • Google Chrome 33.0.1750.93
    cpe:2.3:a:google:chrome:33.0.1750.93
CVSS
Base: 7.5 (as of 05-03-2014 - 10:40)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
nessus via4
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_B4023753A4BA11E3BEC200262D5ED8EE.NASL
    description Google Chrome Releases reports : 19 vulnerabilities fixed in this release, including : - [344492] High CVE-2013-6663: Use-after-free in svg images. Credit to Atte Kettunen of OUSPG. - [326854] High CVE-2013-6664: Use-after-free in speech recognition. Credit to Khalil Zhani. - [337882] High CVE-2013-6665: Heap buffer overflow in software rendering. Credit to cloudfuzzer. - [332023] Medium CVE-2013-6666: Chrome allows requests in flash header request. Credit to netfuzzerr. - [348175] CVE-2013-6667: Various fixes from internal audits, fuzzing and other initiatives. - [343964, 344186, 347909] CVE-2013-6668: Multiple vulnerabilities in V8 fixed in version 3.24.35.10.
    last seen 2019-02-21
    modified 2014-03-15
    plugin id 72850
    published 2014-03-06
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=72850
    title FreeBSD : chromium -- multiple vulnerabilities (b4023753-a4ba-11e3-bec2-00262d5ed8ee)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-2883.NASL
    description Several vulnerabilities have been discovered in the chromium web browser. - CVE-2013-6653 Khalil Zhani discovered a use-after-free issue in chromium's web contents color chooser. - CVE-2013-6654 TheShow3511 discovered an issue in SVG handling. - CVE-2013-6655 cloudfuzzer discovered a use-after-free issue in dom event handling. - CVE-2013-6656 NeexEmil discovered an information leak in the XSS auditor. - CVE-2013-6657 NeexEmil discovered a way to bypass the Same Origin policy in the XSS auditor. - CVE-2013-6658 cloudfuzzer discovered multiple use-after-free issues surrounding the updateWidgetPositions function. - CVE-2013-6659 Antoine Delignat-Lavaud and Karthikeyan Bhargavan discovered that it was possible to trigger an unexpected certificate chain during TLS renegotiation. - CVE-2013-6660 bishopjeffreys discovered an information leak in the drag and drop implementation. - CVE-2013-6661 The Google Chrome team discovered and fixed multiple issues in version 33.0.1750.117. - CVE-2013-6663 Atte Kettunen discovered a use-after-free issue in SVG handling. - CVE-2013-6664 Khalil Zhani discovered a use-after-free issue in the speech recognition feature. - CVE-2013-6665 cloudfuzzer discovered a buffer overflow issue in the software renderer. - CVE-2013-6666 netfuzzer discovered a restriction bypass in the Pepper Flash plugin. - CVE-2013-6667 The Google Chrome team discovered and fixed multiple issues in version 33.0.1750.146. - CVE-2013-6668 Multiple vulnerabilities were fixed in version 3.24.35.10 of the V8 JavaScript library. - CVE-2014-1700 Chamal de Silva discovered a use-after-free issue in speech synthesis. - CVE-2014-1701 aidanhs discovered a cross-site scripting issue in event handling. - CVE-2014-1702 Colin Payne discovered a use-after-free issue in the web database implementation. - CVE-2014-1703 VUPEN discovered a use-after-free issue in web sockets that could lead to a sandbox escape. - CVE-2014-1704 Multiple vulnerabilities were fixed in version 3.23.17.18 of the V8 JavaScript library. - CVE-2014-1705 A memory corruption issue was discovered in the V8 JavaScript library. - CVE-2014-1713 A use-after-free issue was discovered in the AttributeSetter function. - CVE-2014-1715 A directory traversal issue was found and fixed.
    last seen 2019-02-21
    modified 2018-11-28
    plugin id 73164
    published 2014-03-25
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=73164
    title Debian DSA-2883-1 : chromium-browser - security update
  • NASL family Misc.
    NASL id APPLETV_7_0.NASL
    description According to its banner, the remote Apple TV device is a version prior to 7. It is, therefore, affected by multiple vulnerabilities, the most serious of which can result in arbitrary code execution.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 77822
    published 2014-09-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77822
    title Apple TV < 7 Multiple Vulnerabilities
  • NASL family Windows
    NASL id OPERA_2000.NASL
    description The version of Opera installed on the remote host is a version prior to version 20. It is, therefore, reportedly affected by multiple unspecified vulnerabilities.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 72884
    published 2014-03-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=72884
    title Opera < 20 Multiple Vulnerabilities
  • NASL family Windows
    NASL id GOOGLE_CHROME_33_0_1750_146.NASL
    description The version of Google Chrome installed on the remote host is a version prior to 33.0.1750.146. It is, therefore, affected by the following vulnerabilities : - Use-after-free errors exist related to handling SVG images and speech recognition processing. (CVE-2013-6663, CVE-2013-6664) - An error exists related to software rendering that could allow heap-based buffer overflows. (CVE-2013-6665) - An error exists related to Flash header requests. (CVE-2013-6666) - Various unspecified errors exist having unspecified impacts. (CVE-2013-6667) - Unspecified errors exist related to the V8 JavaScript engine that could have unspecified impacts. (CVE-2013-6668)
    last seen 2019-02-21
    modified 2018-07-12
    plugin id 72800
    published 2014-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=72800
    title Google Chrome < 33.0.1750.146 Multiple Vulnerabilities
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_SAFARI7_1.NASL
    description The version of Apple Safari installed on the remote Mac OS X host is a version prior to 6.2 or 7.1. It is, therefore, affected by the following vulnerabilities : - An error exists related to saved passwords and the incorrect automatic filling of HTML forms. A remote attacker can exploit this to obtain sensitive information. (CVE-2014-4363) - Multiple memory corruption errors exist related to the included version of WebKit that can allow application crashes or arbitrary code execution. (CVE-2013-6663, CVE-2014-4410, CVE-2014-4411, CVE-2014-4412, CVE-2014-4413, CVE-2014-4414, CVE-2014-4415) - An error exists related to HTML5 application cache data handling and the included version of WebKit that allows the disclosure of sensitive information from private browsing sessions. (CVE-2014-4409)
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 77747
    published 2014-09-18
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=77747
    title Mac OS X : Apple Safari < 6.2 / 7.1 Multiple Vulnerabilities
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_GOOGLE_CHROME_33_0_1750_146.NASL
    description The version of Google Chrome installed on the remote Mac OS X host is a version prior to 33.0.1750.146. It is, therefore, affected by the following vulnerabilities : - Use-after-free errors exist related to handling SVG images and speech recognition processing. (CVE-2013-6663, CVE-2013-6664) - An error exists related to software rendering that could allow heap-based buffer overflows. (CVE-2013-6665) - An error exists related to Flash header requests. (CVE-2013-6666) - Various unspecified errors exist having unspecified impacts. (CVE-2013-6667) - Unspecified errors exist related to the V8 JavaScript engine that could have unspecified impacts. (CVE-2013-6668)
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 72801
    published 2014-03-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=72801
    title Google Chrome < 33.0.1750.146 Multiple Vulnerabilities (Mac OS X)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201403-01.NASL
    description The remote host is affected by the vulnerability described in GLSA-201403-01 (Chromium, V8: Multiple vulnerabilities) Multiple vulnerabilities have been discovered in Chromium and V8. Please review the CVE identifiers and release notes referenced below for details. Impact : A context-dependent attacker could entice a user to open a specially crafted website or JavaScript program using Chromium or V8, possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition. Furthermore, a remote attacker may be able to bypass security restrictions or have other unspecified impact. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-10-29
    plugin id 72851
    published 2014-03-06
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=72851
    title GLSA-201403-01 : Chromium, V8: Multiple vulnerabilities
  • NASL family Windows
    NASL id ITUNES_12_0_1.NASL
    description The version of Apple iTunes installed on the remote Windows host is prior to 12.0.1. It is, therefore, affected by multiple vulnerabilities due to the included version of WebKit. The errors could lead to application crashes or arbitrary code execution. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 78597
    published 2014-10-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=78597
    title Apple iTunes < 12.0.1 Multiple Vulnerabilities (credentialed check)
  • NASL family Peer-To-Peer File Sharing
    NASL id ITUNES_12_0_1_BANNER.NASL
    description The version of Apple iTunes on the remote host is prior to version 12.0.1. It is, therefore, affected by multiple vulnerabilities related to the included version of WebKit. The errors could lead to application crashes or arbitrary code execution. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 78598
    published 2014-10-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=78598
    title Apple iTunes < 12.0.1 Multiple Vulnerabilities (uncredentialed check)
refmap via4
apple
  • APPLE-SA-2014-09-17-1
  • APPLE-SA-2014-09-17-2
bid 65930
confirm
debian DSA-2883
secunia
  • 61306
  • 61318
Last major update 06-01-2017 - 21:59
Published 05-03-2014 - 00:11
Back to Top