ID CVE-2013-4288
Summary Race condition in PolicyKit (aka polkit) allows local users to bypass intended PolicyKit restrictions and gain privileges by starting a setuid or pkexec process before the authorization check is performed, related to (1) the polkit_unix_process_new API function, (2) the dbus API, or (3) the --process (unix-process) option for authorization to pkcheck.
References
Vulnerable Configurations
  • OpenSUSE 12.2
    cpe:2.3:o:opensuse:opensuse:12.2
  • OpenSUSE 12.3
    cpe:2.3:o:opensuse:opensuse:12.3
  • Polkit Project Policykit (aka polkit)
    cpe:2.3:a:polkit_project:polkit
  • Canonical Ubuntu Linux 10.04 LTS
    cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts
  • Canonical Ubuntu Linux 12.04 LTS (Long-Term Support)
    cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts
  • Canonical Ubuntu Linux 12.10
    cpe:2.3:o:canonical:ubuntu_linux:12.10
  • Canonical Ubuntu Linux 13.04
    cpe:2.3:o:canonical:ubuntu_linux:13.04
  • Red Hat Enterprise Linux 6.0
    cpe:2.3:o:redhat:enterprise_linux:6.0
CVSS
Base: 7.2 (as of 23-10-2013 - 09:56)
Impact:
Exploitability:
CWE CWE-362
CAPEC
  • Leveraging Race Conditions
    This attack targets a race condition occurring when multiple processes access and manipulate the same resource concurrently and the outcome of the execution depends on the particular order in which the access takes place. The attacker can leverage a race condition by "running the race", modifying the resource and modifying the normal execution flow. For instance a race condition can occur while accessing a file, the attacker can trick the system by replacing the original file with his version and cause the system to read the malicious file.
  • Leveraging Time-of-Check and Time-of-Use (TOCTOU) Race Conditions
    This attack targets a race condition occurring between the time of check (state) for a resource and the time of use of a resource. The typical example is the file access. The attacker can leverage a file access race condition by "running the race", meaning that he would modify the resource between the first time the target program accesses the file and the time the target program uses the file. During that period of time, the attacker could do something such as replace the file and cause an escalation of privilege.
Access
VectorComplexityAuthentication
LOCAL LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2013-17160.NASL
    description This release fixes CVE-2013-4288: Race condition with process subjects that do not have securely determined uid. pkcheck(1) now supports a new format for the --process argument; all applications need to use the new format to avoid a race condition (or use --system-bus-name to identify the process instead). Similarly, applications using the API should always use polkit_unix_process_new_for_owner(). polkit_unix_process_new() and polkit_unix_process_new_full() are unsafe and have been deprecated. Thanks to Sebastian Krahmer of the SUSE Security Team for reporting this issue. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-11-28
    plugin id 70063
    published 2013-09-23
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70063
    title Fedora 20 : polkit-0.112-1.fc20 (2013-17160)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2013-1270.NASL
    description Updated polkit packages that fix one security issue are now available for Red Hat Enterprise Linux 6. The Red Hat Security Response Team has rated this update as having important security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section. PolicyKit is a toolkit for defining and handling authorizations. A race condition was found in the way the PolicyKit pkcheck utility checked process authorization when the process was specified by its process ID via the --process option. A local user could use this flaw to bypass intended PolicyKit authorizations and escalate their privileges. (CVE-2013-4288) Note: Applications that invoke pkcheck with the --process option need to be modified to use the pid,pid-start-time,uid argument for that option, to allow pkcheck to check process authorization correctly. Red Hat would like to thank Sebastian Krahmer of the SUSE Security Team for reporting this issue. All polkit users should upgrade to these updated packages, which contain a backported patch to correct this issue. The system must be rebooted for this update to take effect.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 69998
    published 2013-09-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=69998
    title CentOS 6 : polkit (CESA-2013:1270)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2013-17191.NASL
    description This release fixes CVE-2013-4288: Race condition with process subjects that do not have securely determined uid. pkcheck(1) now supports a new format for the --process argument; all applications need to use the new format to avoid a race condition (or use --system-bus-name to identify the process instead). Similarly, applications using the API should always use polkit_unix_process_new_for_owner(). polkit_unix_process_new() and polkit_unix_process_new_full() are unsafe and have been deprecated. Thanks to Sebastian Krahmer of the SUSE Security Team for reporting this issue. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-11-28
    plugin id 70038
    published 2013-09-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70038
    title Fedora 19 : polkit-0.112-1.fc19 (2013-17191)
  • NASL family Mandriva Local Security Checks
    NASL id MANDRIVA_MDVSA-2013-243.NASL
    description Updated polkit packages fix security vulnerability : A race condition was found in the way the PolicyKit pkcheck utility checked process authorization when the process was specified by its process ID via the --process option. A local user could use this flaw to bypass intended PolicyKit authorizations and escalate their privileges (CVE-2013-4288). Note: Applications that invoke pkcheck with the --process option need to be modified to use the pid,pid-start-time,uid argument for that option, to allow pkcheck to check process authorization correctly. Because of the change in the PolicyKit API, hplip (CVE-2013-4325), rtkit (CVE-2013-4326), and systemd (CVE-2013-4327) packages have been updated to use a different API that is not affected by this PolicyKit vulnerability.
    last seen 2019-02-21
    modified 2019-01-02
    plugin id 70185
    published 2013-09-28
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70185
    title Mandriva Linux Security Advisory : polkit (MDVSA-2013:243)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201406-27.NASL
    description The remote host is affected by the vulnerability described in GLSA-201406-27 (polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation) polkit has a race condition which potentially allows a process to change its UID/EUID via suid or pkexec before authentication is completed. Impact : A local attacker could start a suid or pkexec process through a polkit-enabled application, which could result in privilege escalation or bypass of polkit restrictions. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-12-05
    plugin id 76271
    published 2014-06-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=76271
    title GLSA-201406-27 : polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2013-738.NASL
    description This systemd update fixes several security issue. - polkit-Avoid-race-condition-in-scraping-proc.patch VUL-0: polkit: process subject race condition (bnc#836932) CVE-2013-4288.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 75159
    published 2014-06-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=75159
    title openSUSE Security Update : systemd (openSUSE-SU-2013:1527-1)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2013-812.NASL
    description the following security issue was fixed for HPLIP 3.13.10: usage of an insecure polkit DBUS API (fix for bnc#836937 and CVE-2013-4325 that are related to CVE-2013-4288 and bnc#835827).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 75183
    published 2014-06-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=75183
    title openSUSE Security Update : hplip (openSUSE-SU-2013:1617-1)
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-1953-1.NASL
    description It was discovered that polkit didn't allow applications to use the pkcheck tool in a way which prevented a race condition in the UID lookup. A local attacker could use this flaw to possibly escalate privileges. Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-12-01
    plugin id 69971
    published 2013-09-19
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=69971
    title Ubuntu 10.04 LTS / 12.04 LTS / 12.10 / 13.04 : policykit-1 vulnerability (USN-1953-1)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2013-1460.NASL
    description An updated rhev-hypervisor6 package that fixes one security issue and various bugs is now available. The Red Hat Security Response Team has rated this update as having important security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section. The rhev-hypervisor6 package provides a Red Hat Enterprise Virtualization Hypervisor ISO disk image. The Red Hat Enterprise Virtualization Hypervisor is a dedicated Kernel-based Virtual Machine (KVM) hypervisor. It includes everything necessary to run and manage virtual machines: A subset of the Red Hat Enterprise Linux operating environment and the Red Hat Enterprise Virtualization Agent. Note: Red Hat Enterprise Virtualization Hypervisor is only available for the Intel 64 and AMD64 architectures with virtualization extensions. Upgrade Note: If you upgrade the Red Hat Enterprise Virtualization Hypervisor through the 3.2 Manager administration portal, the Host may appear with the status of 'Install Failed'. If this happens, place the host into maintenance mode, then activate it again to get the host back to an 'Up' state A stack-based buffer overflow flaw was found in the way the reds_handle_ticket() function in the spice-server library handled decryption of ticket data provided by the client. A remote attacker able to initiate a SPICE connection to the guest could use this flaw to crash the guest. (CVE-2013-4282) This issue was discovered by Tomas Jamrisko of Red Hat. This updated package provides updated components that include fixes for various security issues. These issues have no security impact on Red Hat Enterprise Virtualization Hypervisor itself, however. The security fixes included in this update address the following CVE numbers : CVE-2013-4162 and CVE-2013-4299 (kernel issues) CVE-2013-4296 and CVE-2013-4311 (libvirt issues) CVE-2013-4288 (polkit issue) This update also contains the fixes from the following advisories : * vdsm: https://rhn.redhat.com/errata/RHBA-2013-1462.html * ovirt-node: https://rhn.redhat.com/errata/RHBA-2013-1461.html Users of the Red Hat Enterprise Virtualization Hypervisor are advised to upgrade to this updated package, which corrects these issues.
    last seen 2019-02-21
    modified 2018-12-20
    plugin id 78977
    published 2014-11-08
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=78977
    title RHEL 6 : rhev-hypervisor6 (RHSA-2013:1460)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2013-1270.NASL
    description Updated polkit packages that fix one security issue are now available for Red Hat Enterprise Linux 6. The Red Hat Security Response Team has rated this update as having important security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section. PolicyKit is a toolkit for defining and handling authorizations. A race condition was found in the way the PolicyKit pkcheck utility checked process authorization when the process was specified by its process ID via the --process option. A local user could use this flaw to bypass intended PolicyKit authorizations and escalate their privileges. (CVE-2013-4288) Note: Applications that invoke pkcheck with the --process option need to be modified to use the pid,pid-start-time,uid argument for that option, to allow pkcheck to check process authorization correctly. Red Hat would like to thank Sebastian Krahmer of the SUSE Security Team for reporting this issue. All polkit users should upgrade to these updated packages, which contain a backported patch to correct this issue. The system must be rebooted for this update to take effect.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 70010
    published 2013-09-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70010
    title RHEL 6 : polkit (RHSA-2013:1270)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2013-17197.NASL
    description This release fixes CVE-2013-4288: Race condition with process subjects that do not have securely determined uid. pkcheck(1) now supports a new format for the --process argument; all applications need to use the new format to avoid a race condition (or use --system-bus-name to identify the process instead). Similarly, applications using the API should always use polkit_unix_process_new_for_owner(). polkit_unix_process_new() and polkit_unix_process_new_full() are unsafe and have been deprecated. Thanks to Sebastian Krahmer of the SUSE Security Team for reporting this issue. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-11-28
    plugin id 70047
    published 2013-09-22
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70047
    title Fedora 18 : polkit-0.107-6.fc18 (2013-17197)
  • NASL family Scientific Linux Local Security Checks
    NASL id SL_20130919_POLKIT_ON_SL6_X.NASL
    description A race condition was found in the way the PolicyKit pkcheck utility checked process authorization when the process was specified by its process ID via the --process option. A local user could use this flaw to bypass intended PolicyKit authorizations and escalate their privileges. (CVE-2013-4288) Note: Applications that invoke pkcheck with the --process option need to be modified to use the pid,pid-start-time,uid argument for that option, to allow pkcheck to check process authorization correctly. The system must be rebooted for this update to take effect.
    last seen 2019-02-21
    modified 2018-12-31
    plugin id 70016
    published 2013-09-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70016
    title Scientific Linux Security Update : polkit on SL6.x i386/x86_64
  • NASL family Oracle Linux Local Security Checks
    NASL id ORACLELINUX_ELSA-2013-1270.NASL
    description From Red Hat Security Advisory 2013:1270 : Updated polkit packages that fix one security issue are now available for Red Hat Enterprise Linux 6. The Red Hat Security Response Team has rated this update as having important security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section. PolicyKit is a toolkit for defining and handling authorizations. A race condition was found in the way the PolicyKit pkcheck utility checked process authorization when the process was specified by its process ID via the --process option. A local user could use this flaw to bypass intended PolicyKit authorizations and escalate their privileges. (CVE-2013-4288) Note: Applications that invoke pkcheck with the --process option need to be modified to use the pid,pid-start-time,uid argument for that option, to allow pkcheck to check process authorization correctly. Red Hat would like to thank Sebastian Krahmer of the SUSE Security Team for reporting this issue. All polkit users should upgrade to these updated packages, which contain a backported patch to correct this issue. The system must be rebooted for this update to take effect.
    last seen 2019-02-21
    modified 2018-07-18
    plugin id 70006
    published 2013-09-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=70006
    title Oracle Linux 6 : polkit (ELSA-2013-1270)
  • NASL family SuSE Local Security Checks
    NASL id OPENSUSE-2013-737.NASL
    description This systemd update fixes several security and non-security issues. - polkit-Avoid-race-condition-in-scraping-proc.patch: VUL-0: polkit: process subject race condition (bnc#836932) CVE-2013-4288. - Don't use a trigger to create symlink for sysctl.conf, always run the test on %post (bnc#840864). - Move symlink migration trigger to post (bnc#821800). - Add systemd-fix-crash-listing-session-files.patch (bnc#840055).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 75158
    published 2014-06-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=75158
    title openSUSE Security Update : systemd (openSUSE-SU-2013:1528-1)
redhat via4
advisories
  • bugzilla
    id 1002375
    title CVE-2013-4288 polkit: unix-process subject for authorization is racy
    oval
    AND
    • OR
      • comment Red Hat Enterprise Linux 6 Client is installed
        oval oval:com.redhat.rhsa:tst:20100842001
      • comment Red Hat Enterprise Linux 6 Server is installed
        oval oval:com.redhat.rhsa:tst:20100842002
      • comment Red Hat Enterprise Linux 6 Workstation is installed
        oval oval:com.redhat.rhsa:tst:20100842003
      • comment Red Hat Enterprise Linux 6 ComputeNode is installed
        oval oval:com.redhat.rhsa:tst:20100842004
    • OR
      • AND
        • comment polkit is earlier than 0:0.96-5.el6_4
          oval oval:com.redhat.rhsa:tst:20131270005
        • comment polkit is signed with Red Hat redhatrelease2 key
          oval oval:com.redhat.rhsa:tst:20110455006
      • AND
        • comment polkit-desktop-policy is earlier than 0:0.96-5.el6_4
          oval oval:com.redhat.rhsa:tst:20131270009
        • comment polkit-desktop-policy is signed with Red Hat redhatrelease2 key
          oval oval:com.redhat.rhsa:tst:20110455012
      • AND
        • comment polkit-devel is earlier than 0:0.96-5.el6_4
          oval oval:com.redhat.rhsa:tst:20131270007
        • comment polkit-devel is signed with Red Hat redhatrelease2 key
          oval oval:com.redhat.rhsa:tst:20110455008
      • AND
        • comment polkit-docs is earlier than 0:0.96-5.el6_4
          oval oval:com.redhat.rhsa:tst:20131270011
        • comment polkit-docs is signed with Red Hat redhatrelease2 key
          oval oval:com.redhat.rhsa:tst:20110455010
    rhsa
    id RHSA-2013:1270
    released 2013-09-19
    severity Important
    title RHSA-2013:1270: polkit security update (Important)
  • rhsa
    id RHSA-2013:1460
rpms
  • polkit-0:0.96-5.el6_4
  • polkit-desktop-policy-0:0.96-5.el6_4
  • polkit-devel-0:0.96-5.el6_4
  • polkit-docs-0:0.96-5.el6_4
refmap via4
misc http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=1002375
mlist
  • [oss-security] 20130918 Fwd: [vs-plain] polkit races
  • [oss-security] 20130918 Re: Fwd: [vs-plain] polkit races
suse
  • openSUSE-SU-2013:1527
  • openSUSE-SU-2013:1528
  • openSUSE-SU-2013:1617
  • openSUSE-SU-2013:1620
ubuntu USN-1953-1
Last major update 08-12-2013 - 01:00
Published 03-10-2013 - 17:55
Last modified 22-04-2019 - 13:48
Back to Top