ID CVE-2012-4915
Summary Directory traversal vulnerability in the Google Doc Embedder plugin before 2.5.4 for WordPress allows remote attackers to read arbitrary files via a .. (dot dot) in the file parameter to libs/pdf.php.
References
Vulnerable Configurations
  • Google Doc Embedder 2.5.3
    cpe:2.3:a:davistribe:google_doc_embedder:2.5.3
  • Google Doc Embedder 2.5.2
    cpe:2.3:a:davistribe:google_doc_embedder:2.5.2
  • Google Doc Embedder 2.5.11
    cpe:2.3:a:davistribe:google_doc_embedder:2.5.1
  • Google Doc Embedder 2.5
    cpe:2.3:a:davistribe:google_doc_embedder:2.5
  • Google Doc Embedder 2.4.6
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.6
  • Google Doc Embedder 2.4.5
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.5
  • Google Doc Embedder 2.4.4
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.4
  • Google Doc Embedder 2.4.3
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.3
  • Google Doc Embedder 2.4.2
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.2
  • Google Doc Embedder 2.4.1
    cpe:2.3:a:davistribe:google_doc_embedder:2.4.1
  • Google Doc Embedder 2.4
    cpe:2.3:a:davistribe:google_doc_embedder:2.4
  • Google Doc Embedder 2.3
    cpe:2.3:a:davistribe:google_doc_embedder:2.3
  • Google Doc Embedder 2.2.3
    cpe:2.3:a:davistribe:google_doc_embedder:2.2.3
  • Google Doc Embedder 2.2.2
    cpe:2.3:a:davistribe:google_doc_embedder:2.2.2
  • Google Doc Embedder 2.2.1
    cpe:2.3:a:davistribe:google_doc_embedder:2.2.1
  • Google Doc Embedder 2.2
    cpe:2.3:a:davistribe:google_doc_embedder:2.2
  • Google Doc Embedder 2.1
    cpe:2.3:a:davistribe:google_doc_embedder:2.1
  • Google Doc Embedder 2.0
    cpe:2.3:a:davistribe:google_doc_embedder:2.0
  • WordPress
    cpe:2.3:a:wordpress:wordpress
CVSS
Base: 5.0 (as of 29-05-2014 - 11:53)
Impact:
Exploitability:
CWE CWE-22
CAPEC
  • Relative Path Traversal
    An attacker exploits a weakness in input validation on the target by supplying a specially constructed path utilizing dot and slash characters for the purpose of obtaining access to arbitrary files or resources. An attacker modifies a known path on the target in order to reach material that is not available through intended channels. These attacks normally involve adding additional path separators (/ or \) and/or dots (.), or encodings thereof, in various combinations in order to reach parent directories or entirely separate trees of the target's directory structure.
  • Directory Traversal
    An attacker with access to file system resources, either directly or via application logic, will use various file path specification or navigation mechanisms such as ".." in path strings and absolute paths to extend their range of access to inappropriate areas of the file system. The attacker attempts to either explore the file system for recon purposes or access directories and files that are intended to be restricted from their access. Exploring the file system can be achieved through constructing paths presented to directory listing programs, such as "ls" and 'dir', or through specially crafted programs that attempt to explore the file system. The attacker engaging in this type of activity is searching for information that can be used later in a more exploitive attack. Access to restricted directories or files can be achieved through modification of path references utilized by system applications.
  • File System Function Injection, Content Based
    An attack of this type exploits the host's trust in executing remote content including binary files. The files are poisoned with a malicious payload (targeting the file systems accessible by the target software) by the attacker and may be passed through standard channels such as via email, and standard web content like PDF and multimedia files. The attacker exploits known vulnerabilities or handling routines in the target processes. Vulnerabilities of this type have been found in a wide variety of commercial applications from Microsoft Office to Adobe Acrobat and Apple Safari web browser. When the attacker knows the standard handling routines and can identify vulnerabilities and entry points they can be exploited by otherwise seemingly normal content. Once the attack is executed, the attackers' program can access relative directories such as C:\Program Files or other standard system directories to launch further attacks. In a worst case scenario, these programs are combined with other propagation logic and work as a virus.
  • Using Slashes and URL Encoding Combined to Bypass Validation Logic
    This attack targets the encoding of the URL combined with the encoding of the slash characters. An attacker can take advantage of the multiple way of encoding an URL and abuse the interpretation of the URL. An URL may contain special character that need special syntax handling in order to be interpreted. Special characters are represented using a percentage character followed by two digits representing the octet code of the original character (%HEX-CODE). For instance US-ASCII space character would be represented with %20. This is often referred as escaped ending or percent-encoding. Since the server decodes the URL from the requests, it may restrict the access to some URL paths by validating and filtering out the URL requests it received. An attacker will try to craft an URL with a sequence of special characters which once interpreted by the server will be equivalent to a forbidden URL. It can be difficult to protect against this attack since the URL can contain other format of encoding such as UTF-8 encoding, Unicode-encoding, etc.
  • Manipulating Input to File System Calls
    An attacker manipulates inputs to the target software which the target software passes to file system calls in the OS. The goal is to gain access to, and perhaps modify, areas of the file system that the target software did not intend to be accessible.
  • Using Escaped Slashes in Alternate Encoding
    This attack targets the use of the backslash in alternate encoding. An attacker can provide a backslash as a leading character and causes a parser to believe that the next character is special. This is called an escape. By using that trick, the attacker tries to exploit alternate ways to encode the same character which leads to filter problems and opens avenues to attack.
  • Using Slashes in Alternate Encoding
    This attack targets the encoding of the Slash characters. An attacker would try to exploit common filtering problems related to the use of the slashes characters to gain access to resources on the target host. Directory-driven systems, such as file systems and databases, typically use the slash character to indicate traversal between directories or other container components. For murky historical reasons, PCs (and, as a result, Microsoft OSs) choose to use a backslash, whereas the UNIX world typically makes use of the forward slash. The schizophrenic result is that many MS-based systems are required to understand both forms of the slash. This gives the attacker many opportunities to discover and abuse a number of common filtering problems. The goal of this pattern is to discover server software that only applies filters to one version, but not the other.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
exploit-db via4
description WordPress Plugin Google Document Embedder Arbitrary File Disclosure. CVE-2012-4915. Webapps exploit for php platform
id EDB-ID:23970
last seen 2016-02-02
modified 2013-01-08
published 2013-01-08
reporter metasploit
source https://www.exploit-db.com/download/23970/
title WordPress Plugin Google Document Embedder - Arbitrary File Disclosure
metasploit via4
description This module exploits an arbitrary file disclosure flaw in the WordPress blogging software plugin known as Google Document Embedder. The vulnerability allows for database credential disclosure via the /libs/pdf.php script. The Google Document Embedder plug-in versions 2.4.6 and below are vulnerable. This exploit only works when the MySQL server is exposed on an accessible IP and WordPress has filesystem write access. Please note: The admin password may get changed if the exploit does not run to the end.
id MSF:EXPLOIT/UNIX/WEBAPP/WP_GOOGLE_DOCUMENT_EMBEDDER_EXEC
last seen 2019-02-02
modified 2017-09-08
published 2013-01-05
reliability Normal
reporter Rapid7
source https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/unix/webapp/wp_google_document_embedder_exec.rb
title WordPress Plugin Google Document Embedder Arbitrary File Disclosure
nessus via4
NASL family CGI abuses
NASL id WORDPRESS_GOOGLE_DOC_EMBEDDER_FILE_DISCLOSURE.NASL
description The Google Doc Embedder Plugin for WordPress installed on the remote host is affected by a file disclosure vulnerability due to a failure to properly sanitize user-supplied input to the 'file' parameter of the 'libs/pdf.php' script. This vulnerability could allow an unauthenticated, remote attacker to read arbitrary files by forming a request containing directory traversal sequences.
last seen 2019-02-21
modified 2018-08-07
plugin id 63687
published 2013-01-24
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=63687
title Google Doc Embedder Plugin for WordPress 'File' Parameter Traversal Arbitrary File Disclosure
packetstorm via4
data source https://packetstormsecurity.com/files/download/119329/wp_google_document_embedder_exec.rb.txt
id PACKETSTORM:119329
last seen 2016-12-05
published 2013-01-08
reporter Charlie Eriksen
source https://packetstormsecurity.com/files/119329/WordPress-Google-Document-Embedder-Arbitrary-File-Disclosure.html
title WordPress Google Document Embedder Arbitrary File Disclosure
refmap via4
bid 57133
osvdb 88891
secunia 50832
xf googledocembedder-pdf-file-disclosure(80930)
Last major update 29-05-2014 - 19:20
Published 29-05-2014 - 10:19
Last modified 28-08-2017 - 21:32
Back to Top