ID CVE-2012-1856
Summary The TabStrip ActiveX control in the Common Controls in MSCOMCTL.OCX in Microsoft Office 2003 SP3, Office 2003 Web Components SP3, Office 2007 SP2 and SP3, Office 2010 SP1, SQL Server 2000 SP4, SQL Server 2005 SP4, SQL Server 2008 SP2, SP3, R2, R2 SP1, and R2 SP2, Commerce Server 2002 SP4, Commerce Server 2007 SP2, Commerce Server 2009 Gold and R2, Host Integration Server 2004 SP1, Visual FoxPro 8.0 SP1, Visual FoxPro 9.0 SP2, and Visual Basic 6.0 Runtime allows remote attackers to execute arbitrary code via a crafted (1) document or (2) web page that triggers system-state corruption, aka "MSCOMCTL.OCX RCE Vulnerability."
References
Vulnerable Configurations
  • Microsoft Commerce Server 2002 Service Pack 4
    cpe:2.3:a:microsoft:commerce_server:2002:sp4
  • Microsoft Commerce Server 2007 Service Pack 2
    cpe:2.3:a:microsoft:commerce_server:2007:sp2
  • Microsoft Commerce Server 2009
    cpe:2.3:a:microsoft:commerce_server:2009
  • Microsoft Commerce Server 2009 R2
    cpe:2.3:a:microsoft:commerce_server:2009:r2
  • Microsoft Host Integration Server (HIS) 2004 Service Pack 1
    cpe:2.3:a:microsoft:host_integration_server:2004:sp1
  • Microsoft Office 2003 Service Pack 3
    cpe:2.3:a:microsoft:office:2003:sp3
  • Microsoft Office 2007 Service Pack 2
    cpe:2.3:a:microsoft:office:2007:sp2
  • Microsoft Office 2007 Service Pack 3
    cpe:2.3:a:microsoft:office:2007:sp3
  • Microsoft Office 2010 for x86 (32-bit Systems) Service Pack 1
    cpe:2.3:a:microsoft:office:2010:sp1:x86
  • Microsoft Office 2003 Web Components Service Pack 3
    cpe:2.3:a:microsoft:office_web_components:2003:sp3
  • Microsoft SQL Server 2000 Service Pack 4
    cpe:2.3:a:microsoft:sql_server:2000:sp4
  • Microsoft SQL Server 2000 Service Pack 4 Analysis Services
    cpe:2.3:a:microsoft:sql_server:2000:sp4:analysis_services
  • Microsoft SQL Server 2005 Express Edition with Advanced Services Service Pack 4
    cpe:2.3:a:microsoft:sql_server:2005:sp4:express_advanced_services
  • Microsoft SQL Server 2005 Service Pack 4 Itanium
    cpe:2.3:a:microsoft:sql_server:2005:sp4:itanium
  • Microsoft SQL Server 2005 Service Pack 4 64-bit (X64)
    cpe:2.3:a:microsoft:sql_server:2005:sp4:x64
  • Microsoft SQL Server 2005 Service Pack 4 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2005:sp4:x86
  • Microsoft SQL Server 2008 R2 Itanium
    cpe:2.3:a:microsoft:sql_server:2008:r2:itanium
  • Microsoft SQL Server 2008 R2 64-bit (X64)
    cpe:2.3:a:microsoft:sql_server:2008:r2:x64
  • Microsoft SQL Server 2008 R2 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2008:r2:x86
  • Microsoft SQL Server 2008 R2 Service Pack 1 Itanium
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp1:itanium
  • Microsoft SQL Server 2008 R2 Service Pack 1 X64 (64-bit)
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp1:x64
  • Microsoft SQL Server 2008 R2 Service Pack 1 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp1:x86
  • Microsoft SQL Server 2008 R2 Service Pack 2 Itanium
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp2:itanium
  • Microsoft SQL Server 2008 R2 Service Pack 2X64 (64-bit)
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp2:x64
  • Microsoft SQL Server 2008 R2 Service Pack 2 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2008:r2_sp2:x86
  • Microsoft SQL Server 2008 Service Pack 2 Itanium Based System
    cpe:2.3:a:microsoft:sql_server:2008:sp2:itanium
  • Microsoft SQL Server 2008 Service Pack 2 64-bit (X64)
    cpe:2.3:a:microsoft:sql_server:2008:sp2:x64
  • Microsoft SQL Server 2008 Service Pack 2 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2008:sp2:x86
  • Microsoft SQL Server 2008 Service Pack 3 Itanium Based System
    cpe:2.3:a:microsoft:sql_server:2008:sp3:itanium
  • Microsoft SQL Server 2008 Service Pack 3 64-bit (X64)
    cpe:2.3:a:microsoft:sql_server:2008:sp3:x64
  • Microsoft SQL Server 2008 Service Pack 3 x86 (32-bit)
    cpe:2.3:a:microsoft:sql_server:2008:sp3:x86
  • Microsoft Visual Basic 6.0 Runtime
    cpe:2.3:a:microsoft:visual_basic:6.0:-:runtime_extended_files
  • Microsoft Visual FoxPro 8.0 Service Pack 1
    cpe:2.3:a:microsoft:visual_foxpro:8.0:sp1
  • Microsoft Visual FoxPro 9.0 Service Pack 2
    cpe:2.3:a:microsoft:visual_foxpro:9.0:sp2
CVSS
Base: 9.3 (as of 15-08-2012 - 11:27)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files, when the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high. The attack can be directed at a client system, such as causing buffer overrun through loading seemingly benign image files, as in Microsoft Security Bulletin MS04-028 where specially crafted JPEG files could cause a buffer overrun once loaded into the browser. Another example targets clients reading pdf files. In this case the attacker simply appends javascript to the end of a legitimate url for a pdf (http://www.gnucitizen.org/blog/danger-danger-danger/) http://path/to/pdf/file.pdf#whatever_name_you_want=javascript:your_code_here The client assumes that they are reading a pdf, but the attacker has modified the resource and loaded executable javascript into the client's browser process. The attack can also target server processes. The attacker edits the resource or configuration file, for example a web.xml file used to configure security permissions for a J2EE app server, adding role name "public" grants all users with the public role the ability to use the administration functionality. The server trusts its configuration file to be correct, but when they are manipulated, the attacker gains full control.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
msbulletin via4
bulletin_id MS12-060
bulletin_url
date 2012-08-14T00:00:00
impact Remote Code Execution
knowledgebase_id 2720573
knowledgebase_url
severity Critical
title Vulnerability in Windows Common Controls Could Allow Remote Code Execution
nessus via4
NASL family Windows : Microsoft Bulletins
NASL id SMB_NT_MS12-060.NASL
description There is an unspecified remote code execution vulnerability in Windows common controls, which is included in several Microsoft products. An attacker could exploit this by tricking a user into viewing a maliciously crafted web page, resulting in arbitrary code execution.
last seen 2019-02-21
modified 2018-11-15
plugin id 61535
published 2012-08-15
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=61535
title MS12-060: Vulnerability in Windows Common Controls Could Allow Remote Code Execution (2720573)
oval via4
accepted 2014-06-09T04:00:13.929-04:00
class vulnerability
contributors
  • name SecPod Team
    organization SecPod Technologies
  • name Chandan S
    organization SecPod Technologies
  • name Pradeep R B
    organization SecPod Technologies
  • name Pradeep R B
    organization SecPod Technologies
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment Microsoft Office 2003 SP3 is installed
    oval oval:org.mitre.oval:def:15626
  • comment Microsoft Office 2003 Web Components SP3 is installed
    oval oval:org.mitre.oval:def:15325
  • comment Microsoft Office 2010 SP1 is installed
    oval oval:org.mitre.oval:def:15198
  • comment Microsoft Office 2007 SP2 is installed
    oval oval:org.mitre.oval:def:15607
  • comment Microsoft Office 2007 SP3 is installed
    oval oval:org.mitre.oval:def:15704
  • comment Microsoft SQL Server 2008 SP3 is installed
    oval oval:org.mitre.oval:def:15497
  • comment Microsoft SQL Server 2008 R2 SP1 is installed
    oval oval:org.mitre.oval:def:15808
  • comment Microsoft SQL Server 2008 R2 is installed
    oval oval:org.mitre.oval:def:12596
  • comment Microsoft SQL Server 2008 SP2 is installed
    oval oval:org.mitre.oval:def:12310
  • comment Microsoft SQL Server 2008 R2 SP2 is installed
    oval oval:org.mitre.oval:def:15803
  • comment Microsoft SQL Server 2005 SP4 is installed
    oval oval:org.mitre.oval:def:12442
  • comment Microsoft Commerce Server 2002 SP4 is installed
    oval oval:org.mitre.oval:def:15722
  • comment Microsoft Commerce Server 2007 SP2 is installed
    oval oval:org.mitre.oval:def:15552
  • comment Microsoft Commerce Server 2009 is installed
    oval oval:org.mitre.oval:def:15443
  • comment Microsoft Commerce Server 2009 R2 is installed
    oval oval:org.mitre.oval:def:15274
  • comment Microsoft Visual FoxPro is installed
    oval oval:org.mitre.oval:def:14198
  • comment Microsoft Visual FoxPro is installed
    oval oval:org.mitre.oval:def:14198
  • comment Microsoft Host Integration Server 2004 SP1 is installed
    oval oval:org.mitre.oval:def:5430
  • comment Microsoft Visual Basic 6.0 is installed
    oval oval:org.mitre.oval:def:15369
  • comment Microsoft SQL Server 2000 Analysis Services SP4 is installed
    oval oval:org.mitre.oval:def:15730
  • comment Microsoft SQL Server 2000 SP4 is installed
    oval oval:org.mitre.oval:def:15762
description The TabStrip ActiveX control in the Common Controls in MSCOMCTL.OCX in Microsoft Office 2003 SP3, Office 2003 Web Components SP3, Office 2007 SP2 and SP3, Office 2010 SP1, SQL Server 2000 SP4, SQL Server 2005 SP4, SQL Server 2008 SP2, SP3, R2, R2 SP1, and R2 SP2, Commerce Server 2002 SP4, Commerce Server 2007 SP2, Commerce Server 2009 Gold and R2, Host Integration Server 2004 SP1, Visual FoxPro 8.0 SP1, Visual FoxPro 9.0 SP2, and Visual Basic 6.0 Runtime allows remote attackers to execute arbitrary code via a crafted (1) document or (2) web page that triggers system-state corruption, aka "MSCOMCTL.OCX RCE Vulnerability."
family windows
id oval:org.mitre.oval:def:15447
status accepted
submitted 2012-08-21T11:30:57
title MSCOMCTL.OCX RCE Vulnerability - MS12-060
version 90
refmap via4
bid 54948
cert TA12-227A
ms MS12-060
the hacker news via4
id THN:59AA6ADFEEB67D7E156CDF3579330697
last seen 2017-01-08
modified 2013-09-27
published 2013-09-27
reporter Mohit Kumar
source http://thehackernews.com/2013/09/chinese-apt-espionage-campaign-dubbed.html
title Chinese APT Espionage campaign, dubbed 'Icefog' targeted Military contractors and Governments
Last major update 02-11-2013 - 23:23
Published 14-08-2012 - 21:55
Last modified 07-11-2018 - 06:29
Back to Top