ID CVE-2011-2100
Summary Untrusted search path vulnerability in Adobe Reader and Acrobat 8.x before 8.3, 9.x before 9.4.5, and 10.x before 10.1 on Windows allows local users to gain privileges via a Trojan horse DLL in the current working directory.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:acrobat_reader:8.0
  • Adobe Acrobat Reader 8.1
    cpe:2.3:a:adobe:acrobat_reader:8.1
  • Adobe Acrobat Reader 8.1.1
    cpe:2.3:a:adobe:acrobat_reader:8.1.1
  • Adobe Acrobat Reader 8.1.2
    cpe:2.3:a:adobe:acrobat_reader:8.1.2
  • Adobe Acrobat Reader 8.1.4
    cpe:2.3:a:adobe:acrobat_reader:8.1.4
  • Adobe Acrobat Reader 8.1.5
    cpe:2.3:a:adobe:acrobat_reader:8.1.5
  • Adobe Acrobat Reader 8.1.6
    cpe:2.3:a:adobe:acrobat_reader:8.1.6
  • Adobe Acrobat Reader 8.1.7
    cpe:2.3:a:adobe:acrobat_reader:8.1.7
  • Adobe Acrobat Reader 8.2
    cpe:2.3:a:adobe:acrobat_reader:8.2
  • Adobe Acrobat Reader 8.2.1
    cpe:2.3:a:adobe:acrobat_reader:8.2.1
  • Adobe Acrobat Reader 8.2.2
    cpe:2.3:a:adobe:acrobat_reader:8.2.2
  • Adobe Acrobat Reader 8.2.3
    cpe:2.3:a:adobe:acrobat_reader:8.2.3
  • Adobe Acrobat Reader 8.2.4
    cpe:2.3:a:adobe:acrobat_reader:8.2.4
  • Adobe Acrobat Reader 8.2.6
    cpe:2.3:a:adobe:acrobat_reader:8.2.6
  • Adobe Acrobat Reader 8.1.3
    cpe:2.3:a:adobe:acrobat_reader:8.1.3
  • Adobe Acrobat Reader 9.0
    cpe:2.3:a:adobe:acrobat_reader:9.0
  • Adobe Acrobat Reader 9.1
    cpe:2.3:a:adobe:acrobat_reader:9.1
  • Adobe Acrobat Reader 9.1.1
    cpe:2.3:a:adobe:acrobat_reader:9.1.1
  • Adobe Acrobat Reader 9.1.2
    cpe:2.3:a:adobe:acrobat_reader:9.1.2
  • Adobe Acrobat Reader 9.1.3
    cpe:2.3:a:adobe:acrobat_reader:9.1.3
  • Adobe Acrobat Reader 9.2
    cpe:2.3:a:adobe:acrobat_reader:9.2
  • Adobe Acrobat Reader 9.3
    cpe:2.3:a:adobe:acrobat_reader:9.3
  • Adobe Acrobat Reader 9.3.1
    cpe:2.3:a:adobe:acrobat_reader:9.3.1
  • Adobe Acrobat Reader 9.3.2
    cpe:2.3:a:adobe:acrobat_reader:9.3.2
  • Adobe Acrobat Reader 9.3.3
    cpe:2.3:a:adobe:acrobat_reader:9.3.3
  • Adobe Acrobat Reader 9.3.4
    cpe:2.3:a:adobe:acrobat_reader:9.3.4
  • Adobe Acrobat Reader 9.4
    cpe:2.3:a:adobe:acrobat_reader:9.4
  • Adobe Acrobat Reader 9.4.1
    cpe:2.3:a:adobe:acrobat_reader:9.4.1
  • Adobe Acrobat Reader 9.4.2
    cpe:2.3:a:adobe:acrobat_reader:9.4.2
  • Adobe Acrobat Reader 9.4.3
    cpe:2.3:a:adobe:acrobat_reader:9.4.3
  • Adobe Acrobat Reader 9.4.4
    cpe:2.3:a:adobe:acrobat_reader:9.4.4
  • Adobe Acrobat Reader X (10.0)
    cpe:2.3:a:adobe:acrobat_reader:10.0
  • Adobe Acrobat Reader X (10.0.1)
    cpe:2.3:a:adobe:acrobat_reader:10.0.1
  • Adobe Acrobat Reader X (10.0.2)
    cpe:2.3:a:adobe:acrobat_reader:10.0.2
  • Adobe Acrobat Reader X (10.0.3)
    cpe:2.3:a:adobe:acrobat_reader:10.0.3
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
  • Adobe Acrobat 8.0
    cpe:2.3:a:adobe:acrobat:8.0
  • cpe:2.3:a:adobe:acrobat:8.1
  • cpe:2.3:a:adobe:acrobat:8.1.1
  • Adobe Acrobat 8.1.2
    cpe:2.3:a:adobe:acrobat:8.1.2
  • Adobe Acrobat 8.1.3
    cpe:2.3:a:adobe:acrobat:8.1.3
  • Adobe Acrobat 8.1.4
    cpe:2.3:a:adobe:acrobat:8.1.4
  • Adobe Acrobat 8.1.5
    cpe:2.3:a:adobe:acrobat:8.1.5
  • Adobe Acrobat 8.1.6
    cpe:2.3:a:adobe:acrobat:8.1.6
  • Adobe Acrobat 8.1.7
    cpe:2.3:a:adobe:acrobat:8.1.7
  • Adobe Acrobat 8.2
    cpe:2.3:a:adobe:acrobat:8.2
  • Adobe Acrobat 8.2.1
    cpe:2.3:a:adobe:acrobat:8.2.1
  • Adobe Acrobat 8.2.2
    cpe:2.3:a:adobe:acrobat:8.2.2
  • Adobe Acrobat 8.2.3
    cpe:2.3:a:adobe:acrobat:8.2.3
  • Adobe Acrobat 8.2.4
    cpe:2.3:a:adobe:acrobat:8.2.4
  • Adobe Acrobat 8.2.5
    cpe:2.3:a:adobe:acrobat:8.2.5
  • Adobe Acrobat 8.2.6
    cpe:2.3:a:adobe:acrobat:8.2.6
  • cpe:2.3:a:adobe:acrobat:9.0
  • Adobe Acrobat 9.1
    cpe:2.3:a:adobe:acrobat:9.1
  • Adobe Acrobat 9.1.1
    cpe:2.3:a:adobe:acrobat:9.1.1
  • cpe:2.3:a:adobe:acrobat:9.1.2
  • Adobe Acrobat 9.1.3
    cpe:2.3:a:adobe:acrobat:9.1.3
  • Adobe Acrobat 9.2
    cpe:2.3:a:adobe:acrobat:9.2
  • Adobe Acrobat 9.3
    cpe:2.3:a:adobe:acrobat:9.3
  • Adobe Acrobat 9.3.1
    cpe:2.3:a:adobe:acrobat:9.3.1
  • Adobe Acrobat 9.3.2
    cpe:2.3:a:adobe:acrobat:9.3.2
  • Adobe Acrobat 9.3.3
    cpe:2.3:a:adobe:acrobat:9.3.3
  • Adobe Acrobat 9.3.4
    cpe:2.3:a:adobe:acrobat:9.3.4
  • Adobe Acrobat 9.4
    cpe:2.3:a:adobe:acrobat:9.4
  • Adobe Acrobat 9.4.1
    cpe:2.3:a:adobe:acrobat:9.4.1
  • Adobe Acrobat 9.4.2
    cpe:2.3:a:adobe:acrobat:9.4.2
  • Adobe Acrobat 9.4.3
    cpe:2.3:a:adobe:acrobat:9.4.3
  • Adobe Acrobat 9.4.4
    cpe:2.3:a:adobe:acrobat:9.4.4
  • Adobe Acrobat X (10.0)
    cpe:2.3:a:adobe:acrobat:10.0
  • Adobe Acrobat X (10.0.1)
    cpe:2.3:a:adobe:acrobat:10.0.1
  • Adobe Acrobat X (10.0.2)
    cpe:2.3:a:adobe:acrobat:10.0.2
  • Adobe Acrobat X (10.0.3)
    cpe:2.3:a:adobe:acrobat:10.0.3
  • Microsoft Windows
    cpe:2.3:o:microsoft:windows
CVSS
Base: 6.9 (as of 17-06-2011 - 10:12)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
LOCAL MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family MacOS X Local Security Checks
    NASL id MACOSX_ADOBE_READER_APSB11-16.NASL
    description The version of Adobe Reader installed on the remote Mac OS X host is prior to 10.1, 9.4.5, or 8.3. It is, therefore, affected by the following vulnerabilities : - Multiple buffer overflow conditions exist that allow an attacker to execute arbitrary code. (CVE-2011-2094, CVE-2011-2095, CVE-2011-2097) - A heap overflow condition exists that allows an attacker to execute arbitrary code. (CVE-2011-2096) - Multiple memory corruption issues exist that allow an attacker to execute arbitrary code. (CVE-2011-2098, CVE-2011-2099, CVE-2011-2103, CVE-2011-2105, CVE-2011-2106) - Multiple memory corruption issues exist that allow an attacker to crash the application. (CVE-2011-2104, CVE-2011-2105) - A DLL loading vulnerability exists that allows an attacker to execute arbitrary code. (CVE-2011-2100) - A cross-document script execution vulnerability exists that allows an attacker to execute arbitrary code. (CVE-2011-2101) - A unspecified vulnerability exists that allows an attacker to bypass security restrictions. (CVE-2011-2102) Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
    last seen 2019-02-21
    modified 2018-07-14
    plugin id 55421
    published 2011-06-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=55421
    title Adobe Reader < 10.1 / 9.4.5 / 8.3 Multiple Vulnerabilities (APSB11-12, APSB11-12, APSB11-16) (Mac OS X)
  • NASL family Windows
    NASL id ADOBE_READER_APSB11-16.NASL
    description The version of Adobe Reader installed on the remote host is earlier than 10.1 / 9.4.5 / 8.3. Such versions are reportedly affected by multiple vulnerabilities : - Multiple buffer overflow vulnerabilities exist that could lead to code execution. (CVE-2011-2094, CVE-2011-2095, CVE-2011-2097) - A heap overflow vulnerability exists that could lead to code execution. (CVE-2011-2096) - Multiple memory corruption vulnerabilities exist that could lead to code execution. (CVE-2011-2098, CVE-2011-2099, CVE-2011-2103, CVE-2011-2105) - Multiple memory corruption vulnerabilities exist that could cause the application to crash. (CVE-2011-2104, CVE-2011-2105) - A DLL loading vulnerability exists that could lead to code execution. (CVE-2011-2100) - A cross document script execution vulnerability exists that could lead to code execution. (CVE-2011-2101) - A security bypass vulnerability exists that could lead to bypassing security restrictions. (CVE-2011-2102)
    last seen 2019-02-21
    modified 2018-06-27
    plugin id 55144
    published 2011-06-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=55144
    title Adobe Reader < 10.1 / 9.4.5 / 8.3 Multiple Vulnerabilities (APSB11-16)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSB11-16.NASL
    description The version of Adobe Acrobat installed on the remote host is earlier than 10.1 / 9.4.5 / 8.3. Such versions are reportedly affected by multiple vulnerabilities : - Multiple buffer overflow vulnerabilities exist that could lead to code execution. (CVE-2011-2094, CVE-2011-2095, CVE-2011-2097) - A heap overflow vulnerability exists that could lead to code execution. (CVE-2011-2096) - Multiple memory corruption vulnerabilities exist that could lead to code execution. (CVE-2011-2098, CVE-2011-2099, CVE-2011-2103, CVE-2011-2105) - Multiple memory corruption vulnerabilities exist that could cause the application to crash. (CVE-2011-2104, CVE-2011-2105) - A DLL loading vulnerability exists that could lead to code execution. (CVE-2011-2100) - A cross document script execution vulnerability exists that could lead to code execution. (CVE-2011-2101) - A security bypass vulnerability exists that could lead to bypassing security restrictions. (CVE-2011-2102)
    last seen 2019-02-21
    modified 2018-06-27
    plugin id 55143
    published 2011-06-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=55143
    title Adobe Acrobat < 10.1 / 9.4.5 / 8.3 Multiple Vulnerabilities (APSB11-16)
oval via4
accepted 2014-10-06T04:01:05.618-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization DTCC
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Shane Shaffer
    organization G2, Inc.
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Mikhno
    organization ALTX-SOFT
  • name Maria Mikhno
    organization ALTX-SOFT
definition_extensions
  • comment Adobe Acrobat 10.x is installed
    oval oval:org.mitre.oval:def:11989
  • comment Adobe Acrobat 9 Series is installed
    oval oval:org.mitre.oval:def:6013
  • comment Adobe Acrobat 8 Series is installed
    oval oval:org.mitre.oval:def:6452
  • comment Adobe Reader 9 Series is installed
    oval oval:org.mitre.oval:def:6523
  • comment Adobe Reader 8 Series is installed
    oval oval:org.mitre.oval:def:6390
  • comment Adobe Reader 10.x is installed
    oval oval:org.mitre.oval:def:12283
description Untrusted search path vulnerability in Adobe Reader and Acrobat 8.x before 8.3, 9.x before 9.4.5, and 10.x before 10.1 on Windows allows local users to gain privileges via a Trojan horse DLL in the current working directory.
family windows
id oval:org.mitre.oval:def:14057
status accepted
submitted 2011-11-04T14:33:15.000-05:00
title Untrusted search path vulnerability in Adobe Reader and Acrobat 8.x before 8.3, 9.x before 9.4.5, and 10.x before 10.1 on Windows allows local users to gain privileges via a Trojan horse DLL in the current working directory.
version 18
refmap via4
bid 48252
cert TA11-166A
confirm http://www.adobe.com/support/security/bulletins/apsb11-16.html
osvdb 73062
sectrack 1025658
xf adobe-reader-dll-ce(68014)
Last major update 26-01-2012 - 23:00
Published 16-06-2011 - 19:55
Last modified 18-09-2017 - 21:32
Back to Top