ID CVE-2010-3625
Summary Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code via unspecified vectors, related to a "prefix protocol handler vulnerability."
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:acrobat:8.0
  • Adobe Acrobat 8.1
    cpe:2.3:a:adobe:acrobat:8.1
  • Adobe Acrobat 8.1.1
    cpe:2.3:a:adobe:acrobat:8.1.1
  • Adobe Acrobat 8.1.2
    cpe:2.3:a:adobe:acrobat:8.1.2
  • cpe:2.3:a:adobe:acrobat:8.1.3
  • Adobe Acrobat 8.1.4
    cpe:2.3:a:adobe:acrobat:8.1.4
  • Adobe Acrobat 8.1.5
    cpe:2.3:a:adobe:acrobat:8.1.5
  • Adobe Acrobat 8.1.6
    cpe:2.3:a:adobe:acrobat:8.1.6
  • Adobe Acrobat 8.1.7
    cpe:2.3:a:adobe:acrobat:8.1.7
  • Adobe Acrobat 8.2
    cpe:2.3:a:adobe:acrobat:8.2
  • Adobe Acrobat 8.2.1
    cpe:2.3:a:adobe:acrobat:8.2.1
  • Adobe Acrobat 8.2.2
    cpe:2.3:a:adobe:acrobat:8.2.2
  • Adobe Acrobat 8.2.3
    cpe:2.3:a:adobe:acrobat:8.2.3
  • Adobe Acrobat 8.2.4
    cpe:2.3:a:adobe:acrobat:8.2.4
  • Adobe Acrobat Reader 8.0
    cpe:2.3:a:adobe:acrobat_reader:8.0
  • cpe:2.3:a:adobe:acrobat_reader:8.1
  • Adobe Acrobat Reader 8.1.1
    cpe:2.3:a:adobe:acrobat_reader:8.1.1
  • Adobe Acrobat Reader 8.1.2
    cpe:2.3:a:adobe:acrobat_reader:8.1.2
  • Adobe Acrobat Reader 8.1.4
    cpe:2.3:a:adobe:acrobat_reader:8.1.4
  • Adobe Acrobat Reader 8.1.5
    cpe:2.3:a:adobe:acrobat_reader:8.1.5
  • Adobe Acrobat Reader 8.1.6
    cpe:2.3:a:adobe:acrobat_reader:8.1.6
  • Adobe Acrobat Reader 8.1.7
    cpe:2.3:a:adobe:acrobat_reader:8.1.7
  • Adobe Acrobat Reader 8.2
    cpe:2.3:a:adobe:acrobat_reader:8.2
  • Adobe Acrobat Reader 8.2.1
    cpe:2.3:a:adobe:acrobat_reader:8.2.1
  • Adobe Acrobat Reader 8.2.2
    cpe:2.3:a:adobe:acrobat_reader:8.2.2
  • Adobe Acrobat Reader 8.2.3
    cpe:2.3:a:adobe:acrobat_reader:8.2.3
  • Adobe Acrobat Reader 8.2.4
    cpe:2.3:a:adobe:acrobat_reader:8.2.4
  • Adobe Acrobat 9.0
    cpe:2.3:a:adobe:acrobat:9.0
  • cpe:2.3:a:adobe:acrobat:9.1
  • Adobe Acrobat 9.1.1
    cpe:2.3:a:adobe:acrobat:9.1.1
  • cpe:2.3:a:adobe:acrobat:9.1.2
  • Adobe Acrobat 9.1.3
    cpe:2.3:a:adobe:acrobat:9.1.3
  • Adobe Acrobat 9.2
    cpe:2.3:a:adobe:acrobat:9.2
  • Adobe Acrobat 9.3
    cpe:2.3:a:adobe:acrobat:9.3
  • Adobe Acrobat 9.3.1
    cpe:2.3:a:adobe:acrobat:9.3.1
  • Adobe Acrobat 9.3.2
    cpe:2.3:a:adobe:acrobat:9.3.2
  • Adobe Acrobat 9.3.3
    cpe:2.3:a:adobe:acrobat:9.3.3
  • Adobe Acrobat 9.3.4
    cpe:2.3:a:adobe:acrobat:9.3.4
  • Adobe Acrobat Reader 9.0
    cpe:2.3:a:adobe:acrobat_reader:9.0
  • Adobe Acrobat Reader 9.1
    cpe:2.3:a:adobe:acrobat_reader:9.1
  • Adobe Acrobat Reader 9.1.1
    cpe:2.3:a:adobe:acrobat_reader:9.1.1
  • Adobe Acrobat Reader 9.1.2
    cpe:2.3:a:adobe:acrobat_reader:9.1.2
  • Adobe Acrobat Reader 9.1.3
    cpe:2.3:a:adobe:acrobat_reader:9.1.3
  • Adobe Acrobat Reader 9.2
    cpe:2.3:a:adobe:acrobat_reader:9.2
  • Adobe Acrobat Reader 9.3
    cpe:2.3:a:adobe:acrobat_reader:9.3
  • Adobe Acrobat Reader 9.3.1
    cpe:2.3:a:adobe:acrobat_reader:9.3.1
  • Adobe Acrobat Reader 9.3.2
    cpe:2.3:a:adobe:acrobat_reader:9.3.2
  • Adobe Acrobat Reader 9.3.3
    cpe:2.3:a:adobe:acrobat_reader:9.3.3
  • Adobe Acrobat Reader 9.3.4
    cpe:2.3:a:adobe:acrobat_reader:9.3.4
CVSS
Base: 9.3 (as of 07-10-2010 - 11:48)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files, when the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high. The attack can be directed at a client system, such as causing buffer overrun through loading seemingly benign image files, as in Microsoft Security Bulletin MS04-028 where specially crafted JPEG files could cause a buffer overrun once loaded into the browser. Another example targets clients reading pdf files. In this case the attacker simply appends javascript to the end of a legitimate url for a pdf (http://www.gnucitizen.org/blog/danger-danger-danger/) http://path/to/pdf/file.pdf#whatever_name_you_want=javascript:your_code_here The client assumes that they are reading a pdf, but the attacker has modified the resource and loaded executable javascript into the client's browser process. The attack can also target server processes. The attacker edits the resource or configuration file, for example a web.xml file used to configure security permissions for a J2EE app server, adding role name "public" grants all users with the public role the ability to use the administration functionality. The server trusts its configuration file to be correct, but when they are manipulated, the attacker gains full control.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
nessus via4
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_ACROREAD_JA-101007.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code. (CVE-2010-2883 / CVE-2010-2884 / CVE-2010-2887 / CVE-2010-2889 / CVE-2010-2890 / CVE-2010-3619 / CVE-2010-3620 / CVE-2010-3621 / CVE-2010-3622 / CVE-2010-3623 / CVE-2010-3624 / CVE-2010-3625 / CVE-2010-3626 / CVE-2010-3627 / CVE-2010-3628 / CVE-2010-3629 / CVE-2010-3630 / CVE-2010-3631 / CVE-2010-3632 / CVE-2010-3656 / CVE-2010-3657 / CVE-2010-3658)
    last seen 2019-02-21
    modified 2014-07-23
    plugin id 50888
    published 2010-12-02
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=50888
    title SuSE 11 / 11.1 Security Update : acroread_ja (SAT Patch Numbers 3272 / 3273)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_ACROREAD_JA-7182.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code. (CVE-2010-2883 / CVE-2010-2884 / CVE-2010-2887 / CVE-2010-2889 / CVE-2010-2890 / CVE-2010-3619 / CVE-2010-3620 / CVE-2010-3621 / CVE-2010-3622 / CVE-2010-3623 / CVE-2010-3624 / CVE-2010-3625 / CVE-2010-3626 / CVE-2010-3627 / CVE-2010-3628 / CVE-2010-3629 / CVE-2010-3630 / CVE-2010-3631 / CVE-2010-3632 / CVE-2010-3656 / CVE-2010-3657 / CVE-2010-3658)
    last seen 2019-02-21
    modified 2014-07-23
    plugin id 51715
    published 2011-01-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=51715
    title SuSE 10 Security Update : acroread_ja (ZYPP Patch Number 7182)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_3_ACROREAD-101007.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code (CVE-2010-2883, CVE-2010-2884, CVE-2010-2887, CVE-2010-2889, CVE-2010-2890, CVE-2010-3619, CVE-2010-3620, CVE-2010-3621, CVE-2010-3622, CVE-2010-3623, CVE-2010-3624, CVE-2010-3625, CVE-2010-3626, CVE-2010-3627, CVE-2010-3628, CVE-2010-3629, CVE-2010-3630, CVE-2010-3631, CVE-2010-3632, CVE-2010-3656, CVE-2010-3657, CVE-2010-3658).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 75419
    published 2014-06-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=75419
    title openSUSE Security Update : acroread (openSUSE-SU-2010:0706-1)
  • NASL family Windows
    NASL id ADOBE_READER_APSA10-02.NASL
    description The version of Adobe Reader installed on the remote host is earlier than 9.4 / 8.2.5. Such versions are affected by multiple code execution vulnerabilities. Note that there have been reports that one or more of these issues are being actively exploited in the wild.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 49173
    published 2010-09-09
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=49173
    title Adobe Reader < 9.4 / 8.2.5 Multiple Vulnerabilities (APSB10-21)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-201101-08.NASL
    description The remote host is affected by the vulnerability described in GLSA-201101-08 (Adobe Reader: Multiple vulnerabilities) Multiple vulnerabilities were discovered in Adobe Reader. For further information please consult the CVE entries and the Adobe Security Bulletins referenced below. Impact : A remote attacker might entice a user to open a specially crafted PDF file, possibly resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-07-11
    plugin id 51657
    published 2011-01-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=51657
    title GLSA-201101-08 : Adobe Reader: Multiple vulnerabilities
  • NASL family SuSE Local Security Checks
    NASL id SUSE_ACROREAD-7181.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code. (CVE-2010-2883 / CVE-2010-2884 / CVE-2010-2887 / CVE-2010-2889 / CVE-2010-2890 / CVE-2010-3619 / CVE-2010-3620 / CVE-2010-3621 / CVE-2010-3622 / CVE-2010-3623 / CVE-2010-3624 / CVE-2010-3625 / CVE-2010-3626 / CVE-2010-3627 / CVE-2010-3628 / CVE-2010-3629 / CVE-2010-3630 / CVE-2010-3631 / CVE-2010-3632 / CVE-2010-3656 / CVE-2010-3657 / CVE-2010-3658)
    last seen 2019-02-21
    modified 2014-07-23
    plugin id 51703
    published 2011-01-27
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=51703
    title SuSE 10 Security Update : Acrobat Reader (ZYPP Patch Number 7181)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2010-0743.NASL
    description Updated acroread packages that fix multiple security issues are now available for Red Hat Enterprise Linux 4 Extras and Red Hat Enterprise Linux 5 Supplementary. The Red Hat Security Response Team has rated this update as having critical security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section. Adobe Reader allows users to view and print documents in Portable Document Format (PDF). This update fixes multiple vulnerabilities in Adobe Reader. These vulnerabilities are detailed on the Adobe security page APSB10-21, listed in the References section. A specially crafted PDF file could cause Adobe Reader to crash or, potentially, execute arbitrary code as the user running Adobe Reader when opened. (CVE-2010-2883, CVE-2010-2884, CVE-2010-2889, CVE-2010-2890, CVE-2010-3619, CVE-2010-3620, CVE-2010-3621, CVE-2010-3622, CVE-2010-3625, CVE-2010-3626, CVE-2010-3627, CVE-2010-3628, CVE-2010-3629, CVE-2010-3630, CVE-2010-3632, CVE-2010-3658) An insecure relative RPATH (runtime library search path) set in some Adobe Reader libraries could allow a local attacker, who is able to convince another user to run Adobe Reader in an attacker-controlled directory, to execute arbitrary code with the privileges of the victim. (CVE-2010-2887) A specially crafted PDF file could cause Adobe Reader to crash when opened. (CVE-2010-3656, CVE-2010-3657) All Adobe Reader users should install these updated packages. They contain Adobe Reader version 9.4, which is not vulnerable to these issues. All running instances of Adobe Reader must be restarted for the update to take effect.
    last seen 2019-02-21
    modified 2018-11-28
    plugin id 49786
    published 2010-10-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=49786
    title RHEL 4 / 5 : acroread (RHSA-2010:0743)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_1_ACROREAD-101007.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code (CVE-2010-2883, CVE-2010-2884, CVE-2010-2887, CVE-2010-2889, CVE-2010-2890, CVE-2010-3619, CVE-2010-3620, CVE-2010-3621, CVE-2010-3622, CVE-2010-3623, CVE-2010-3624, CVE-2010-3625, CVE-2010-3626, CVE-2010-3627, CVE-2010-3628, CVE-2010-3629, CVE-2010-3630, CVE-2010-3631, CVE-2010-3632, CVE-2010-3656, CVE-2010-3657, CVE-2010-3658).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 49824
    published 2010-10-11
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=49824
    title openSUSE Security Update : acroread (openSUSE-SU-2010:0706-1)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_2_ACROREAD-101007.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code (CVE-2010-2883, CVE-2010-2884, CVE-2010-2887, CVE-2010-2889, CVE-2010-2890, CVE-2010-3619, CVE-2010-3620, CVE-2010-3621, CVE-2010-3622, CVE-2010-3623, CVE-2010-3624, CVE-2010-3625, CVE-2010-3626, CVE-2010-3627, CVE-2010-3628, CVE-2010-3629, CVE-2010-3630, CVE-2010-3631, CVE-2010-3632, CVE-2010-3656, CVE-2010-3657, CVE-2010-3658).
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 49825
    published 2010-10-11
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=49825
    title openSUSE Security Update : acroread (openSUSE-SU-2010:0706-1)
  • NASL family Windows
    NASL id ADOBE_ACROBAT_APSA10-02.NASL
    description The version of Adobe Acrobat installed on the remote host is earlier than 9.4 / 8.2.5. Such versions are affected by multiple code execution vulnerabilities. Note that there have been reports that one or more of these issues are being actively exploited in the wild.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 49172
    published 2010-09-09
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=49172
    title Adobe Acrobat < 9.4 / 8.2.5 Multiple Vulnerabilities (APSB10-21)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_11_ACROREAD-101007.NASL
    description Specially crafted PDF documents could crash acroread or lead to execution of arbitrary code. (CVE-2010-2883 / CVE-2010-2884 / CVE-2010-2887 / CVE-2010-2889 / CVE-2010-2890 / CVE-2010-3619 / CVE-2010-3620 / CVE-2010-3621 / CVE-2010-3622 / CVE-2010-3623 / CVE-2010-3624 / CVE-2010-3625 / CVE-2010-3626 / CVE-2010-3627 / CVE-2010-3628 / CVE-2010-3629 / CVE-2010-3630 / CVE-2010-3631 / CVE-2010-3632 / CVE-2010-3656 / CVE-2010-3657 / CVE-2010-3658)
    last seen 2019-02-21
    modified 2014-07-23
    plugin id 50884
    published 2010-12-02
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=50884
    title SuSE 11 / 11.1 Security Update : Acrobat Reader (SAT Patch Numbers 3268 / 3270)
oval via4
accepted 2014-10-06T04:04:17.403-04:00
class vulnerability
contributors
  • name SecPod Team
    organization SecPod Technologies
  • name SecPod Team
    organization SecPod Technologies
  • name SecPod Team
    organization SecPod Technologies
  • name Shane Shaffer
    organization G2, Inc.
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Shane Shaffer
    organization G2, Inc.
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Mikhno
    organization ALTX-SOFT
definition_extensions
  • comment Adobe Reader 8 Series is installed
    oval oval:org.mitre.oval:def:6390
  • comment Adobe Reader 9 Series is installed
    oval oval:org.mitre.oval:def:6523
  • comment Adobe Acrobat 9 Series is installed
    oval oval:org.mitre.oval:def:6013
  • comment Adobe Acrobat 8 Series is installed
    oval oval:org.mitre.oval:def:6452
description Adobe Reader and Acrobat 9.x before 9.4, and 8.x before 8.2.5 on Windows and Mac OS X, allow attackers to execute arbitrary code via unspecified vectors, related to a "prefix protocol handler vulnerability."
family windows
id oval:org.mitre.oval:def:6772
status accepted
submitted 2010-10-08T17:30:00.000-05:00
title Adobe Reader and Acrobat Prefix Protocol Handler Code Execution Vulnerability.
version 23
redhat via4
advisories
rhsa
id RHSA-2010:0743
refmap via4
cert TA10-279A
confirm http://www.adobe.com/support/security/bulletins/apsb10-21.html
gentoo GLSA-201101-08
secunia 43025
suse
  • SUSE-SA:2010:048
  • SUSE-SR:2010:019
vupen ADV-2011-0191
Last major update 18-07-2011 - 22:40
Published 06-10-2010 - 13:00
Last modified 30-10-2018 - 12:25
Back to Top