ID CVE-2009-4764
Summary Adobe Reader 8.x and 9.x on Windows is able to execute EXE files that are embedded in a PDF document, which makes it easier for remote attackers to trick users into executing arbitrary code via a crafted document.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:acrobat_reader:8.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.4:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.4:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.5:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.5:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.6:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.6:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:8.1.7:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:8.1.7:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.1.1:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.1.1:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.1.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.1.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.1.3:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.1.3:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.2:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.2:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:acrobat_reader:9.3:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:acrobat_reader:9.3:*:*:*:*:*:*:*
  • cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
    cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
CVSS
Base: 9.3 (as of 19-09-2017 - 01:30)
Impact:
Exploitability:
CWE CWE-94
CAPEC
  • Code Injection
    An adversary exploits a weakness in input validation on the target to inject new code into that which is currently executing. This differs from code inclusion in that code inclusion involves the addition or replacement of a reference to a code file, which is subsequently loaded by the target and used as part of the code of some application.
  • Leverage Executable Code in Non-Executable Files
    An attack of this type exploits a system's trust in configuration and resource files. When the executable loads the resource (such as an image file or configuration file) the attacker has modified the file to either execute malicious code directly or manipulate the target process (e.g. application server) to execute based on the malicious configuration parameters. Since systems are increasingly interrelated mashing up resources from local and remote sources the possibility of this attack occurring is high.
  • Manipulating User-Controlled Variables
    This attack targets user controlled variables (DEBUG=1, PHP Globals, and So Forth). An attacker can override environment variables leveraging user-supplied, untrusted query variables directly used on the application server without any data sanitization. In extreme cases, the attacker can change variables controlling the business logic of the application. For instance, in languages like PHP, a number of poorly set default configurations may allow the user to override variables.
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:N/AC:M/Au:N/C:C/I:C/A:C
oval via4
accepted 2013-08-12T04:09:54.936-04:00
class vulnerability
contributors
  • name Preeti Subramanian
    organization SecPod Technologies
  • name SecPod Team
    organization SecPod Technologies
  • name SecPod Team
    organization SecPod Technologies
  • name Shane Shaffer
    organization G2, Inc.
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Sergey Artykhov
    organization ALTX-SOFT
  • name Maria Kedovskaya
    organization ALTX-SOFT
  • name Maria Kedovskaya
    organization ALTX-SOFT
definition_extensions
  • comment Adobe Reader 8 Series is installed
    oval oval:org.mitre.oval:def:6390
  • comment Adobe Reader 9 Series is installed
    oval oval:org.mitre.oval:def:6523
description Adobe Reader 8.x and 9.x on Windows is able to execute EXE files that are embedded in a PDF document, which makes it easier for remote attackers to trick users into executing arbitrary code via a crafted document.
family windows
id oval:org.mitre.oval:def:6976
status accepted
submitted 2010-05-18T03:34:03
title Vulnerability in Adobe Reader 8.x and 9.x on Windows - to execute EXE files embedded in a PDF document
version 18
refmap via4
misc
mlist [dailydave] 20100401 0day, it may not be
xf adobereader-exe-code-execution(57994)
Last major update 19-09-2017 - 01:30
Published 05-04-2010 - 15:30
Back to Top