ID CVE-2009-1692
Summary WebKit before r41741, as used in Apple iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Safari, and other software, allows remote attackers to cause a denial of service (memory consumption or device reset) via a web page containing an HTMLSelectElement object with a large length attribute, related to the length property of a Select object.
References
Vulnerable Configurations
  • cpe:2.3:o:apple:iphone_os:1.0.0:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.0.0:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.0.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.0.1:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.0.2:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.0.2:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.0:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.0:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.1:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.2:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.2:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.3:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.3:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.4:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.4:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:1.1.5:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:1.1.5:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.0:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.0:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.0.0:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.0.0:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.0.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.0.1:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.0.2:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.0.2:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.1:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.1.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.1.1:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.2:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.2:*:*:*:*:*:*:*
  • cpe:2.3:o:apple:iphone_os:2.2.1:*:*:*:*:*:*:*
    cpe:2.3:o:apple:iphone_os:2.2.1:*:*:*:*:*:*:*
  • cpe:2.3:h:apple:iphone:*:*:*:*:*:*:*:*
    cpe:2.3:h:apple:iphone:*:*:*:*:*:*:*:*
  • cpe:2.3:h:apple:ipod_touch:*:*:*:*:*:*:*:*
    cpe:2.3:h:apple:ipod_touch:*:*:*:*:*:*:*:*
  • cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
    cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
CVSS
Base: 7.1 (as of 10-10-2018 - 19:37)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE COMPLETE
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:C
refmap via4
apple APPLE-SA-2009-06-17-1
bid
  • 35414
  • 35446
bugtraq
  • 20090715 Re: [GSEC-TZO-44-2009] One bug to rule them all - Firefox, IE, Safari,Opera, Chrome,Seamonkey,iPhone,iPod,Wii,PS3....
  • 20090715 Re:[GSEC-TZO-44-2009] One bug to rule them all - Firefox, IE, Safari,Opera, Chrome,Seamonkey,iPhone,iPod,Wii,PS3....
  • 20090715 [GSEC-TZO-44-2009] One bug to rule them all - Firefox, IE, Safari,Opera, Chrome,Seamonkey,iPhone,iPod,Wii,PS3....
  • 20090716 Re[2]: [GSEC-TZO-44-2009] One bug to rule them all - Firefox, IE, Safari,Opera, Chrome,Seamonkey,iPhone,iPod,Wii,PS3....
confirm
debian DSA-1950
exploit-db 9160
misc
osvdb 55242
secunia
  • 36977
  • 37746
  • 43068
suse SUSE-SR:2011:002
vupen
  • ADV-2009-1621
  • ADV-2011-0212
Last major update 10-10-2018 - 19:37
Published 19-06-2009 - 16:30
Back to Top