ID CVE-2007-3948
Summary connections.c in lighttpd before 1.4.16 might accept more connections than the configured maximum, which allows remote attackers to cause a denial of service (failed assertion) via a large number of connection attempts. The vendor has released an upgrade which solves the vulnerability: http://trac.lighttpd.net/trac/
References
Vulnerable Configurations
  • cpe:2.3:a:lighttpd:lighttpd:1.3.11:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.11:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.3.12:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.12:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.3.13:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.13:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.3.14:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.14:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.3.15:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.15:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.3.16:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.3.16:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.3:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.4:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.4:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.5:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.5:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.6:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.6:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.7:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.7:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.8:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.8:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.9:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.9:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.10:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.10:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.11:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.11:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.12:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.12:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.13:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.13:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.14:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.14:*:*:*:*:*:*:*
  • cpe:2.3:a:lighttpd:lighttpd:1.4.15:*:*:*:*:*:*:*
    cpe:2.3:a:lighttpd:lighttpd:1.4.15:*:*:*:*:*:*:*
CVSS
Base: 4.3 (as of 15-10-2018 - 21:32)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
cvss-vector via4 AV:N/AC:M/Au:N/C:N/I:N/A:P
refmap via4
bid 24967
bugtraq 20070719 rPSA-2007-0145-1 lighttpd
confirm http://trac.lighttpd.net/trac/ticket/1216
debian DSA-1609
gentoo GLSA-200708-11
misc http://trac.lighttpd.net/trac/changeset/1873
osvdb 38312
secunia
  • 26130
  • 26158
  • 26505
  • 31104
suse SUSE-SR:2007:015
vupen ADV-2007-2585
Last major update 15-10-2018 - 21:32
Published 24-07-2007 - 00:30
Back to Top