ID CVE-2007-2693
Summary MySQL before 5.1.18 allows remote authenticated users without SELECT privileges to obtain sensitive information from partitioned tables via an ALTER TABLE statement.
References
Vulnerable Configurations
  • MySQL 5.1.10
    cpe:2.3:a:mysql:mysql:5.1.10
  • MySQL 5.1.11
    cpe:2.3:a:mysql:mysql:5.1.11
  • MySQL 5.1.12
    cpe:2.3:a:mysql:mysql:5.1.12
  • MySQL 5.1.13
    cpe:2.3:a:mysql:mysql:5.1.13
  • MySQL 5.1.14
    cpe:2.3:a:mysql:mysql:5.1.14
  • MySQL 5.1.15
    cpe:2.3:a:mysql:mysql:5.1.15
  • MySQL 5.1.16
    cpe:2.3:a:mysql:mysql:5.1.16
  • MySQL 5.1.17
    cpe:2.3:a:mysql:mysql:5.1.17
  • MySQL 5.1.5
    cpe:2.3:a:mysql:mysql:5.1.5
  • MySQL 5.1.6
    cpe:2.3:a:mysql:mysql:5.1.6
  • MySQL 5.1.9
    cpe:2.3:a:mysql:mysql:5.1.9
CVSS
Base: 3.5 (as of 17-05-2007 - 10:59)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK MEDIUM SINGLE_INSTANCE
Impact
ConfidentialityIntegrityAvailability
PARTIAL NONE NONE
nessus via4
NASL family Databases
NASL id MYSQL_5_1_18.NASL
description The version of MySQL installed on the remote host reportedly is affected by several issues : - Evaluation of an 'IN()' predicate with a decimal-valued argument causes a service crash. - A user can rename a table even though he does not have DROP privileges. - If a stored routine is declared as 'SQL SECURITY INVOKER', a user may be able to gain privileges by invoking that routine. - A user with only ALTER privileges on a partitioned table can discover information about the table that should require SELECT privileges.
last seen 2019-02-21
modified 2018-11-15
plugin id 25242
published 2007-05-17
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=25242
title MySQL 5.1 < 5.1.18 Multiple Vulnerabilities
refmap via4
bid 24008
confirm http://dev.mysql.com/doc/refman/5.1/en/news-5-1-18.html
misc http://bugs.mysql.com/bug.php?id=23675
sectrack 1018071
secunia 25301
vupen ADV-2007-1804
xf mysql-alter-information-disclosure(34349)
statements via4
contributor Joshua Bressers
lastmodified 2007-06-14
organization Red Hat
statement Not vulnerable. These issues did not affect the versions of mysql as shipped with Red Hat Enterprise Linux 2.1, 3, 4, or 5.
Last major update 07-03-2011 - 21:54
Published 15-05-2007 - 21:19
Last modified 28-07-2017 - 21:31
Back to Top