ID CVE-2007-1701
Summary PHP 4 before 4.4.5, and PHP 5 before 5.2.1, when register_globals is enabled, allows context-dependent attackers to execute arbitrary code via deserialization of session data, which overwrites arbitrary global variables, as demonstrated by calling session_decode on a string beginning with "_SESSION|s:39:".
References
Vulnerable Configurations
CVSS
Base: 6.8 (as of 28-03-2007 - 14:57)
Impact:
Exploitability:
CWE CWE-502
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
exploit-db via4
description PHP < 4.4.5 / 5.2.1 _SESSION Deserialization Overwrite Exploit. CVE-2007-1701. Local exploit for linux platform
id EDB-ID:3572
last seen 2016-01-31
modified 2007-03-25
published 2007-03-25
reporter Stefan Esser
source https://www.exploit-db.com/download/3572/
title PHP < 4.4.5 / 5.2.1 _SESSION Deserialization Overwrite Exploit
nessus via4
  • NASL family CGI abuses
    NASL id PHP_4_4_5.NASL
    description According to its banner, the version of PHP installed on the remote host is older than 4.4.5. Such versions may be affected by several issues, including buffer overflows, format string vulnerabilities, arbitrary code execution, 'safe_mode' and 'open_basedir' bypasses, and clobbering of super-globals.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 24906
    published 2007-04-02
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=24906
    title PHP < 4.4.5 Multiple Vulnerabilities
  • NASL family CGI abuses
    NASL id PHP_5_2_1.NASL
    description According to its banner, the version of PHP installed on the remote host is older than 5.2.1. Such versions may be affected by several issues, including buffer overflows, format string vulnerabilities, arbitrary code execution, 'safe_mode' and 'open_basedir' bypasses, and clobbering of super-globals.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 24907
    published 2007-04-02
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=24907
    title PHP < 5.2.1 Multiple Vulnerabilities
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2007-0082.NASL
    description Updated PHP packages that fix several security issues are now available for Red Hat Enterprise Linux 5. This update has been rated as having important security impact by the Red Hat Security Response Team. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server. A number of buffer overflow flaws were found in the PHP session extension; the str_replace() function; and the imap_mail_compose() function. If very long strings were passed to the str_replace() function, an integer overflow could occur in memory allocation. If a script used the imap_mail_compose() function to create a new MIME message based on an input body from an untrusted source, it could result in a heap overflow. An attacker with access to a PHP application affected by any these issues could trigger the flaws and possibly execute arbitrary code as the 'apache' user. (CVE-2007-0906) When unserializing untrusted data on 64-bit platforms, the zend_hash_init() function could be forced into an infinite loop, consuming CPU resources for a limited time, until the script timeout alarm aborted execution of the script. (CVE-2007-0988) If the wddx extension was used to import WDDX data from an untrusted source, certain WDDX input packets could expose a random portion of heap memory. (CVE-2007-0908) If the odbc_result_all() function was used to display data from a database, and the database table contents were under an attacker's control, a format string vulnerability was possible which could allow arbitrary code execution. (CVE-2007-0909) A one byte memory read always occurs before the beginning of a buffer. This could be triggered, for example, by any use of the header() function in a script. However it is unlikely that this would have any effect. (CVE-2007-0907) Several flaws in PHP could allow attackers to 'clobber' certain super-global variables via unspecified vectors. (CVE-2007-0910) An input validation bug allowed a remote attacker to trigger a denial of service attack by submitting an input variable with a deeply-nested-array. (CVE-2007-1285) Users of PHP should upgrade to these updated packages which contain backported patches to correct these issues.
    last seen 2019-02-21
    modified 2019-01-02
    plugin id 25317
    published 2007-05-25
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=25317
    title RHEL 5 : php (RHSA-2007:0082)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-200705-19.NASL
    description The remote host is affected by the vulnerability described in GLSA-200705-19 (PHP: Multiple vulnerabilities) Several vulnerabilities were found in PHP, most of them during the Month Of PHP Bugs (MOPB) by Stefan Esser. The most severe of these vulnerabilities are integer overflows in wbmp.c from the GD library (CVE-2007-1001) and in the substr_compare() PHP 5 function (CVE-2007-1375). Ilia Alshanetsky also reported a buffer overflow in the make_http_soap_request() and in the user_filter_factory_create() functions (CVE-2007-2510, CVE-2007-2511), and Stanislav Malyshev discovered another buffer overflow in the bundled XMLRPC library (CVE-2007-1864). Additionally, the session_regenerate_id() and the array_user_key_compare() functions contain a double-free vulnerability (CVE-2007-1484, CVE-2007-1521). Finally, there exist implementation errors in the Zend engine, in the mb_parse_str(), the unserialize() and the mail() functions and other elements. Impact : Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-07-11
    plugin id 25340
    published 2007-05-29
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=25340
    title GLSA-200705-19 : PHP: Multiple vulnerabilities
  • NASL family Oracle Linux Local Security Checks
    NASL id ORACLELINUX_ELSA-2007-0076.NASL
    description From Red Hat Security Advisory 2007:0076 : Updated PHP packages that fix several security issues are now available for Red Hat Enterprise Linux 3 and 4. This update has been rated as having important security impact by the Red Hat Security Response Team. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server. A number of buffer overflow flaws were found in the PHP session extension, the str_replace() function, and the imap_mail_compose() function. If very long strings under the control of an attacker are passed to the str_replace() function then an integer overflow could occur in memory allocation. If a script uses the imap_mail_compose() function to create a new MIME message based on an input body from an untrusted source, it could result in a heap overflow. An attacker who is able to access a PHP application affected by any these issues could trigger these flaws and possibly execute arbitrary code as the 'apache' user. (CVE-2007-0906) If unserializing untrusted data on 64-bit platforms, the zend_hash_init() function can be forced to enter an infinite loop, consuming CPU resources for a limited length of time, until the script timeout alarm aborts execution of the script. (CVE-2007-0988) If the wddx extension is used to import WDDX data from an untrusted source, certain WDDX input packets may allow a random portion of heap memory to be exposed. (CVE-2007-0908) If the odbc_result_all() function is used to display data from a database, and the contents of the database table are under the control of an attacker, a format string vulnerability is possible which could lead to the execution of arbitrary code. (CVE-2007-0909) A one byte memory read will always occur before the beginning of a buffer, which could be triggered for example by any use of the header() function in a script. However it is unlikely that this would have any effect. (CVE-2007-0907) Several flaws in PHP could allows attackers to 'clobber' certain super-global variables via unspecified vectors. (CVE-2007-0910) Users of PHP should upgrade to these updated packages which contain backported patches to correct these issues. Red Hat would like to thank Stefan Esser for his help diagnosing these issues.
    last seen 2019-02-21
    modified 2018-07-18
    plugin id 67451
    published 2013-07-12
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=67451
    title Oracle Linux 3 / 4 : php (ELSA-2007-0076)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2007-0076.NASL
    description Updated PHP packages that fix several security issues are now available for Red Hat Enterprise Linux 3 and 4. This update has been rated as having important security impact by the Red Hat Security Response Team. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server. A number of buffer overflow flaws were found in the PHP session extension, the str_replace() function, and the imap_mail_compose() function. If very long strings under the control of an attacker are passed to the str_replace() function then an integer overflow could occur in memory allocation. If a script uses the imap_mail_compose() function to create a new MIME message based on an input body from an untrusted source, it could result in a heap overflow. An attacker who is able to access a PHP application affected by any these issues could trigger these flaws and possibly execute arbitrary code as the 'apache' user. (CVE-2007-0906) If unserializing untrusted data on 64-bit platforms, the zend_hash_init() function can be forced to enter an infinite loop, consuming CPU resources for a limited length of time, until the script timeout alarm aborts execution of the script. (CVE-2007-0988) If the wddx extension is used to import WDDX data from an untrusted source, certain WDDX input packets may allow a random portion of heap memory to be exposed. (CVE-2007-0908) If the odbc_result_all() function is used to display data from a database, and the contents of the database table are under the control of an attacker, a format string vulnerability is possible which could lead to the execution of arbitrary code. (CVE-2007-0909) A one byte memory read will always occur before the beginning of a buffer, which could be triggered for example by any use of the header() function in a script. However it is unlikely that this would have any effect. (CVE-2007-0907) Several flaws in PHP could allows attackers to 'clobber' certain super-global variables via unspecified vectors. (CVE-2007-0910) Users of PHP should upgrade to these updated packages which contain backported patches to correct these issues. Red Hat would like to thank Stefan Esser for his help diagnosing these issues.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 24673
    published 2007-02-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=24673
    title CentOS 3 / 4 : php (CESA-2007:0076)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2007-0081.NASL
    description Updated PHP packages that fix several security issues are now available for Red Hat Enterprise Linux 2.1. This update has been rated as having important security impact by the Red Hat Security Response Team. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server. A number of buffer overflow flaws were found in the PHP session extension; the str_replace() function; and the imap_mail_compose() function. If very long strings were passed to the str_replace() function, an integer overflow could occur in memory allocation. If a script used the imap_mail_compose() function to create a new MIME message based on an input body from an untrusted source, it could result in a heap overflow. An attacker with access to a PHP application affected by any these issues could trigger the flaws and possibly execute arbitrary code as the 'apache' user. (CVE-2007-0906) When unserializing untrusted data on 64-bit platforms, the zend_hash_init() function could be forced into an infinite loop, consuming CPU resources for a limited time, until the script timeout alarm aborted execution of the script. (CVE-2007-0988) If the wddx extension was used to import WDDX data from an untrusted source, certain WDDX input packets could expose a random portion of heap memory. (CVE-2007-0908) If the odbc_result_all() function was used to display data from a database, and the database table contents were under an attacker's control, a format string vulnerability was possible which could allow arbitrary code execution. (CVE-2007-0909) A one byte memory read always occurs before the beginning of a buffer. This could be triggered, for example, by any use of the header() function in a script. However it is unlikely that this would have any effect. (CVE-2007-0907) Several flaws in PHP could allow attackers to 'clobber' certain super-global variables via unspecified vectors. (CVE-2007-0910) Users of PHP should upgrade to these updated packages which contain backported patches to correct these issues. Red Hat would like to thank Stefan Esser for his help diagnosing these issues.
    last seen 2019-02-21
    modified 2018-11-16
    plugin id 24697
    published 2007-02-23
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=24697
    title RHEL 2.1 : php (RHSA-2007:0081)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2007-0076.NASL
    description Updated PHP packages that fix several security issues are now available for Red Hat Enterprise Linux 3 and 4. This update has been rated as having important security impact by the Red Hat Security Response Team. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server. A number of buffer overflow flaws were found in the PHP session extension, the str_replace() function, and the imap_mail_compose() function. If very long strings under the control of an attacker are passed to the str_replace() function then an integer overflow could occur in memory allocation. If a script uses the imap_mail_compose() function to create a new MIME message based on an input body from an untrusted source, it could result in a heap overflow. An attacker who is able to access a PHP application affected by any these issues could trigger these flaws and possibly execute arbitrary code as the 'apache' user. (CVE-2007-0906) If unserializing untrusted data on 64-bit platforms, the zend_hash_init() function can be forced to enter an infinite loop, consuming CPU resources for a limited length of time, until the script timeout alarm aborts execution of the script. (CVE-2007-0988) If the wddx extension is used to import WDDX data from an untrusted source, certain WDDX input packets may allow a random portion of heap memory to be exposed. (CVE-2007-0908) If the odbc_result_all() function is used to display data from a database, and the contents of the database table are under the control of an attacker, a format string vulnerability is possible which could lead to the execution of arbitrary code. (CVE-2007-0909) A one byte memory read will always occur before the beginning of a buffer, which could be triggered for example by any use of the header() function in a script. However it is unlikely that this would have any effect. (CVE-2007-0907) Several flaws in PHP could allows attackers to 'clobber' certain super-global variables via unspecified vectors. (CVE-2007-0910) Users of PHP should upgrade to these updated packages which contain backported patches to correct these issues. Red Hat would like to thank Stefan Esser for his help diagnosing these issues.
    last seen 2019-02-21
    modified 2018-11-16
    plugin id 24677
    published 2007-02-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=24677
    title RHEL 3 / 4 : php (RHSA-2007:0076)
oval via4
accepted 2013-04-29T04:10:55.412-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
  • comment The operating system installed on the system is Red Hat Enterprise Linux 4
    oval oval:org.mitre.oval:def:11831
  • comment CentOS Linux 4.x
    oval oval:org.mitre.oval:def:16636
  • comment Oracle Linux 4.x
    oval oval:org.mitre.oval:def:15990
  • comment The operating system installed on the system is Red Hat Enterprise Linux 5
    oval oval:org.mitre.oval:def:11414
  • comment The operating system installed on the system is CentOS Linux 5.x
    oval oval:org.mitre.oval:def:15802
  • comment Oracle Linux 5.x
    oval oval:org.mitre.oval:def:15459
description PHP 4 before 4.4.5, and PHP 5 before 5.2.1, when register_globals is enabled, allows context-dependent attackers to execute arbitrary code via deserialization of session data, which overwrites arbitrary global variables, as demonstrated by calling session_decode on a string beginning with "_SESSION|s:39:".
family unix
id oval:org.mitre.oval:def:11034
status accepted
submitted 2010-07-09T03:56:16-04:00
title PHP 4 before 4.4.5, and PHP 5 before 5.2.1, when register_globals is enabled, allows context-dependent attackers to execute arbitrary code via deserialization of session data, which overwrites arbitrary global variables, as demonstrated by calling session_decode on a string beginning with "_SESSIONs:39:".
version 24
redhat via4
rpms
  • php-0:4.3.2-39.ent
  • php-devel-0:4.3.2-39.ent
  • php-imap-0:4.3.2-39.ent
  • php-ldap-0:4.3.2-39.ent
  • php-mysql-0:4.3.2-39.ent
  • php-odbc-0:4.3.2-39.ent
  • php-pgsql-0:4.3.2-39.ent
  • php-0:4.3.9-3.22.3
  • php-devel-0:4.3.9-3.22.3
  • php-domxml-0:4.3.9-3.22.3
  • php-gd-0:4.3.9-3.22.3
  • php-imap-0:4.3.9-3.22.3
  • php-ldap-0:4.3.9-3.22.3
  • php-mbstring-0:4.3.9-3.22.3
  • php-mysql-0:4.3.9-3.22.3
  • php-ncurses-0:4.3.9-3.22.3
  • php-odbc-0:4.3.9-3.22.3
  • php-pear-0:4.3.9-3.22.3
  • php-pgsql-0:4.3.9-3.22.3
  • php-snmp-0:4.3.9-3.22.3
  • php-xmlrpc-0:4.3.9-3.22.3
  • php-0:5.1.6-7.el5
  • php-bcmath-0:5.1.6-7.el5
  • php-cli-0:5.1.6-7.el5
  • php-common-0:5.1.6-7.el5
  • php-dba-0:5.1.6-7.el5
  • php-devel-0:5.1.6-7.el5
  • php-gd-0:5.1.6-7.el5
  • php-imap-0:5.1.6-7.el5
  • php-ldap-0:5.1.6-7.el5
  • php-mbstring-0:5.1.6-7.el5
  • php-mysql-0:5.1.6-7.el5
  • php-ncurses-0:5.1.6-7.el5
  • php-odbc-0:5.1.6-7.el5
  • php-pdo-0:5.1.6-7.el5
  • php-pgsql-0:5.1.6-7.el5
  • php-snmp-0:5.1.6-7.el5
  • php-soap-0:5.1.6-7.el5
  • php-xml-0:5.1.6-7.el5
  • php-xmlrpc-0:5.1.6-7.el5
refmap via4
bid 23120
gentoo GLSA-200705-19
hp
  • HPSBMA02215
  • HPSBTU02232
  • SSRT071423
  • SSRT071429
misc http://www.php-security.org/MOPB/MOPB-31-2007.html
secunia
  • 25423
  • 25445
  • 25850
vupen
  • ADV-2007-1991
  • ADV-2007-2374
xf php-sessiondecode-code-execution(33658)
statements via4
contributor Mark J Cox
lastmodified 2007-05-01
organization Red Hat
statement This CVE name is a duplicate as the vulnerability is addressed by CVE-2007-0910.
Last major update 05-11-2012 - 22:35
Published 26-03-2007 - 21:19
Last modified 19-10-2018 - 14:34
Back to Top