ID CVE-2007-1396
Summary The import_request_variables function in PHP 4.0.7 through 4.4.6, and 5.x before 5.2.2, when called without a prefix, does not prevent the (1) GET, (2) POST, (3) COOKIE, (4) FILES, (5) SERVER, (6) SESSION, and other superglobals from being overwritten, which allows remote attackers to spoof source IP address and Referer data, and have other unspecified impact. NOTE: it could be argued that this is a design limitation of PHP and that only the misuse of this feature, i.e. implementation bugs in applications, should be included in CVE. However, it has been fixed by the vendor.
References
Vulnerable Configurations
  • PHP PHP 4.0.7
    cpe:2.3:a:php:php:4.0.7
  • PHP PHP 4.1.0
    cpe:2.3:a:php:php:4.1.0
  • PHP PHP 4.1.1
    cpe:2.3:a:php:php:4.1.1
  • PHP PHP 4.1.2
    cpe:2.3:a:php:php:4.1.2
  • PHP PHP 4.2.0
    cpe:2.3:a:php:php:4.2.0
  • PHP PHP 4.2.1
    cpe:2.3:a:php:php:4.2.1
  • PHP PHP 4.2.2
    cpe:2.3:a:php:php:4.2.2
  • PHP PHP 4.2.3
    cpe:2.3:a:php:php:4.2.3
  • PHP PHP 4.3.0
    cpe:2.3:a:php:php:4.3.0
  • PHP PHP 4.3.1
    cpe:2.3:a:php:php:4.3.1
  • PHP PHP 4.3.2
    cpe:2.3:a:php:php:4.3.2
  • PHP PHP 4.3.3
    cpe:2.3:a:php:php:4.3.3
  • PHP PHP 4.3.4
    cpe:2.3:a:php:php:4.3.4
  • PHP PHP 4.3.5
    cpe:2.3:a:php:php:4.3.5
  • PHP PHP 4.3.6
    cpe:2.3:a:php:php:4.3.6
  • PHP PHP 4.3.7
    cpe:2.3:a:php:php:4.3.7
  • PHP PHP 4.3.8
    cpe:2.3:a:php:php:4.3.8
  • PHP PHP 4.3.9
    cpe:2.3:a:php:php:4.3.9
  • PHP PHP 4.3.10
    cpe:2.3:a:php:php:4.3.10
  • PHP PHP 4.3.11
    cpe:2.3:a:php:php:4.3.11
  • PHP PHP 4.4.0
    cpe:2.3:a:php:php:4.4.0
  • PHP PHP 4.4.1
    cpe:2.3:a:php:php:4.4.1
  • PHP PHP 4.4.2
    cpe:2.3:a:php:php:4.4.2
  • PHP PHP 4.4.3
    cpe:2.3:a:php:php:4.4.3
  • PHP PHP 4.4.4
    cpe:2.3:a:php:php:4.4.4
  • PHP PHP 4.4.5
    cpe:2.3:a:php:php:4.4.5
  • PHP PHP 4.4.6
    cpe:2.3:a:php:php:4.4.6
  • PHP PHP 5.0.0
    cpe:2.3:a:php:php:5.0.0
  • PHP PHP 5.0.1
    cpe:2.3:a:php:php:5.0.1
  • PHP PHP 5.0.2
    cpe:2.3:a:php:php:5.0.2
  • PHP PHP 5.0.3
    cpe:2.3:a:php:php:5.0.3
  • PHP PHP 5.0.4
    cpe:2.3:a:php:php:5.0.4
  • PHP PHP 5.0.5
    cpe:2.3:a:php:php:5.0.5
  • PHP PHP 5.1.0
    cpe:2.3:a:php:php:5.1.0
  • PHP PHP 5.1.1
    cpe:2.3:a:php:php:5.1.1
  • PHP PHP 5.1.2
    cpe:2.3:a:php:php:5.1.2
  • PHP PHP 5.1.3
    cpe:2.3:a:php:php:5.1.3
  • PHP 5.1.4
    cpe:2.3:a:php:php:5.1.4
  • PHP PHP 5.1.5
    cpe:2.3:a:php:php:5.1.5
  • PHP PHP 5.1.6
    cpe:2.3:a:php:php:5.1.6
  • PHP 5.2.0
    cpe:2.3:a:php:php:5.2.0
  • PHP 5.2.1
    cpe:2.3:a:php:php:5.2.1
CVSS
Base: 6.8 (as of 13-03-2007 - 10:11)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
nessus via4
  • NASL family CGI abuses
    NASL id PHP_4_4_7_OR_5_2_2.NASL
    description According to its banner, the version of PHP installed on the remote host is older than 4.4.7 / 5.2.2. Such versions may be affected by several issues, including buffer overflows in the GD library.
    last seen 2019-02-21
    modified 2018-07-24
    plugin id 25159
    published 2007-05-04
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=25159
    title PHP < 4.4.7 / 5.2.2 Multiple Vulnerabilities
  • NASL family SuSE Local Security Checks
    NASL id SUSE_PHP5-3753.NASL
    description The following issues have been fixed in PHP, which were spotted by the MOPB project or fixed in PHP 5.2.3 release : - missing open_basedir and safe_mode restriction (CVE-2007-3007) - chunk_split() integer overflow (CVE-2007-2872) - DoS condition in libgd's image processing (CVE-2007-2756) - possible super-global overwrite inside import_request_variables() (CVE-2007-1396) - buffer overflow inside user_filter_factory_create() (CVE-2007-2511) - remotely trigger-able buffer overflow inside bundled libxmlrpc (CVE-2007-1864) - CRLF injection inside ftp_putcmd() (CVE-2007-2509) - remotely trigger-able buffer overflow inside make_http_soap_request() (CVE-2007-2510) - MOPB-41-2007:PHP 5 sqlite_udf_decode_binary() Buffer Overflow Vulnerability (CVE-2007-0906) - MOPB-03-2007: deep recursion DoS (CVE-2007-1285)
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 27392
    published 2007-10-17
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=27392
    title openSUSE 10 Security Update : php5 (php5-3753)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_PHP5-3745.NASL
    description The following issues have been fixed in PHP, which were spotted by the MOPB project or fixed in PHP 5.2.3 release : - missing open_basedir and safe_mode restriction (CVE-2007-3007) - chunk_split() integer overflow (CVE-2007-2872) - DoS condition in libgd's image processing (CVE-2007-2756) - possible super-global overwrite inside import_request_variables() (CVE-2007-1396) - buffer overflow inside user_filter_factory_create() (CVE-2007-2511) - remotely trigger-able buffer overflow inside bundled libxmlrpc (CVE-2007-1864) - CRLF injection inside ftp_putcmd() (CVE-2007-2509) - remotely trigger-able buffer overflow inside make_http_soap_request() (CVE-2007-2510) - MOPB-41-2007:PHP 5 sqlite_udf_decode_binary() Buffer Overflow Vulnerability (CVE-2007-0906) - MOPB-03-2007: deep recursion DoS (CVE-2007-1285)
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 27391
    published 2007-10-17
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=27391
    title openSUSE 10 Security Update : php5 (php5-3745)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_PHP5-3754.NASL
    description The following issues have been fixed : - missing open_basedir and safe_mode restriction. (CVE-2007-3007) - chunk_split() integer overflow. (CVE-2007-2872) - DoS condition in libgd's image processing. (CVE-2007-2756) - possible super-global overwrite inside import_request_variables(). (CVE-2007-1396) - buffer overflow inside user_filter_factory_create(). (CVE-2007-2511) - remotely trigger-able buffer overflow inside bundled libxmlrpc. (CVE-2007-1864) - CRLF injection inside ftp_putcmd(). (CVE-2007-2509) - remotely trigger-able buffer overflow inside make_http_soap_request(). (CVE-2007-2510) - MOPB-41-2007:PHP 5 sqlite_udf_decode_binary() Buffer Overflow Vulnerability. (CVE-2007-0906) - MOPB-03-2007: deep recursion DoS (CVE-2007-1285)
    last seen 2019-02-21
    modified 2016-12-22
    plugin id 29552
    published 2007-12-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=29552
    title SuSE 10 Security Update : PHP5 (ZYPP Patch Number 3754)
refmap via4
bid 22886
bugtraq
  • 20070308 PHP import_request_variables() arbitrary variable overwrite
  • 20070310 Re: [Full-disclosure] PHP import_request_variables() arbitrary variable overwrite
  • 20070312 Re: [Full-disclosure] PHP import_request_variables() arbitrary variable overwrite
  • 20070314 Re: Re: [Full-disclosure] PHP import_request_variables() arbitrary variable overwrite
confirm
secunia 26048
sreason 2406
suse SUSE-SA:2007:044
statements via4
contributor Mark J Cox
lastmodified 2007-03-19
organization Red Hat
statement Red Hat does not consider this to be a security vulnerability. Using import_request_variables() is generally a discouraged practice and it is improper use that can lead to security problems, not flaw of PHP itself.
Last major update 05-09-2008 - 17:20
Published 10-03-2007 - 17:19
Last modified 30-10-2018 - 12:25
Back to Top