ID CVE-2007-0071
Summary Integer overflow in Adobe Flash Player 9.0.115.0 and earlier, and 8.0.39.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file with a negative Scene Count value, which passes a signed comparison, is used as an offset of a NULL pointer, and triggers a buffer overflow.
References
Vulnerable Configurations
  • cpe:2.3:a:adobe:flash_player:8.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.22.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.22.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.24.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.24.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.33.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.33.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.34.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.34.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.35.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.35.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:8.0.39.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:8.0.39.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.8.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.8.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.9.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.9.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.16:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.16:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.16.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.16.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.18d60:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.18d60:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.20:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.20:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.20.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.20.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.28:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.28:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.28.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.28.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.31:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.31:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.31.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.31.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.45.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.45.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.47.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.47.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.48.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.48.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.112.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.112.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.114.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.114.0:*:*:*:*:*:*:*
  • cpe:2.3:a:adobe:flash_player:9.0.115.0:*:*:*:*:*:*:*
    cpe:2.3:a:adobe:flash_player:9.0.115.0:*:*:*:*:*:*:*
CVSS
Base: 9.3 (as of 30-10-2018 - 16:26)
Impact:
Exploitability:
CWE CWE-189
CAPEC
Access
VectorComplexityAuthentication
NETWORK MEDIUM NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:N/AC:M/Au:N/C:C/I:C/A:C
oval via4
accepted 2015-08-03T04:00:08.831-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Maria Mikhno
    organization ALTX-SOFT
definition_extensions
  • comment ActiveX Control is installed
    oval oval:org.mitre.oval:def:26707
  • comment Adobe Flash Player 9 is installed
    oval oval:org.mitre.oval:def:7402
  • comment Adobe AIR is installed
    oval oval:org.mitre.oval:def:7479
description Integer overflow in Adobe Flash Player 9.0.115.0 and earlier, and 8.0.39.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file with a negative Scene Count value, which passes a signed comparison, is used as an offset of a NULL pointer, and triggers a buffer overflow.
family windows
id oval:org.mitre.oval:def:10379
status accepted
submitted 2010-07-09T03:56:16-04:00
title Integer overflow in Adobe Flash Player 9.0.115.0 and earlier, and 8.0.39.0 and earlier, allows remote attackers to execute arbitrary code via a crafted SWF file with a negative Scene Count value, which passes a signed comparison, is used as an offset of a NULL pointer, and triggers a buffer overflow.
version 55
redhat via4
advisories
rhsa
id RHSA-2008:0221
refmap via4
apple APPLE-SA-2008-05-28
bid
  • 28695
  • 29386
cert
  • TA08-100A
  • TA08-149A
  • TA08-150A
cert-vn
  • VU#159523
  • VU#395473
confirm http://www.adobe.com/support/security/bulletins/apsb08-11.html
gentoo GLSA-200804-21
iss 20080408 Adobe Flash Player Invalid Pointer Vulnerability
misc
osvdb 44282
sectrack
  • 1019811
  • 1020114
secunia
  • 29763
  • 29865
  • 30404
  • 30430
  • 30507
sunalert 238305
suse SUSE-SA:2008:022
vupen
  • ADV-2008-1662
  • ADV-2008-1697
  • ADV-2008-1724
xf multimedia-file-integer-overflow(37277)
Last major update 30-10-2018 - 16:26
Published 09-04-2008 - 21:05
Back to Top