ID CVE-2005-4421
Summary Dev-Editor 3.0 allows remote attackers to access any directory outside the web root whose name is a substring of the web root directory name.
References
Vulnerable Configurations
  • cpe:2.3:a:dev-editor:dev-editor:2.0:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.0:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.1:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.1:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.1a:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.1a:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.2a:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.2a:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.3:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.3:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.3.1:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.3.1:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:2.3.2:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:2.3.2:*:*:*:*:*:*:*
  • cpe:2.3:a:dev-editor:dev-editor:3.0:*:*:*:*:*:*:*
    cpe:2.3:a:dev-editor:dev-editor:3.0:*:*:*:*:*:*:*
CVSS
Base: 7.5 (as of 20-07-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:N/AC:L/Au:N/C:P/I:P/A:P
refmap via4
bid 15393
confirm http://devedit.sourceforge.net/changelog.shtml
secunia 17537
vupen ADV-2005-2389
xf dev-editor-root-bypass-security(23057)
Last major update 20-07-2017 - 01:29
Published 20-12-2005 - 11:03
Back to Top