ID CVE-2005-3626
Summary Xpdf, as used in products such as gpdf, kpdf, pdftohtml, poppler, teTeX, CUPS, libextractor, and others, allows attackers to cause a denial of service (crash) via a crafted FlateDecode stream that triggers a null dereference.
References
Vulnerable Configurations
  • cpe:2.3:a:easy_software_products:cups:1.1.22
    cpe:2.3:a:easy_software_products:cups:1.1.22
  • cpe:2.3:a:easy_software_products:cups:1.1.22_rc1
    cpe:2.3:a:easy_software_products:cups:1.1.22_rc1
  • cpe:2.3:a:easy_software_products:cups:1.1.23
    cpe:2.3:a:easy_software_products:cups:1.1.23
  • cpe:2.3:a:easy_software_products:cups:1.1.23_rc1
    cpe:2.3:a:easy_software_products:cups:1.1.23_rc1
  • cpe:2.3:a:kde:kdegraphics:3.2
    cpe:2.3:a:kde:kdegraphics:3.2
  • cpe:2.3:a:kde:kdegraphics:3.4.3
    cpe:2.3:a:kde:kdegraphics:3.4.3
  • KDE KOffice 1.4
    cpe:2.3:a:kde:koffice:1.4
  • KDE KOffice 1.4.1
    cpe:2.3:a:kde:koffice:1.4.1
  • KDE KOffice 1.4.2
    cpe:2.3:a:kde:koffice:1.4.2
  • cpe:2.3:a:kde:kpdf:3.2
    cpe:2.3:a:kde:kpdf:3.2
  • cpe:2.3:a:kde:kpdf:3.4.3
    cpe:2.3:a:kde:kpdf:3.4.3
  • cpe:2.3:a:kde:kword:1.4.2
    cpe:2.3:a:kde:kword:1.4.2
  • cpe:2.3:a:libextractor:libextractor
    cpe:2.3:a:libextractor:libextractor
  • cpe:2.3:a:poppler:poppler:0.4.2
    cpe:2.3:a:poppler:poppler:0.4.2
  • cpe:2.3:a:sgi:propack:3.0:sp6
    cpe:2.3:a:sgi:propack:3.0:sp6
  • cpe:2.3:a:tetex:tetex:1.0.7
    cpe:2.3:a:tetex:tetex:1.0.7
  • cpe:2.3:a:tetex:tetex:2.0
    cpe:2.3:a:tetex:tetex:2.0
  • cpe:2.3:a:tetex:tetex:2.0.1
    cpe:2.3:a:tetex:tetex:2.0.1
  • cpe:2.3:a:tetex:tetex:2.0.2
    cpe:2.3:a:tetex:tetex:2.0.2
  • cpe:2.3:a:tetex:tetex:3.0
    cpe:2.3:a:tetex:tetex:3.0
  • cpe:2.3:a:xpdf:xpdf:3.0
    cpe:2.3:a:xpdf:xpdf:3.0
  • Conectiva Linux 10.0
    cpe:2.3:o:conectiva:linux:10.0
  • Debian Debian Linux 3.0
    cpe:2.3:o:debian:debian_linux:3.0
  • cpe:2.3:o:debian:debian_linux:3.0:-:alpha
    cpe:2.3:o:debian:debian_linux:3.0:-:alpha
  • cpe:2.3:o:debian:debian_linux:3.0:-:arm
    cpe:2.3:o:debian:debian_linux:3.0:-:arm
  • cpe:2.3:o:debian:debian_linux:3.0:-:hppa
    cpe:2.3:o:debian:debian_linux:3.0:-:hppa
  • cpe:2.3:o:debian:debian_linux:3.0:-:ia-32
    cpe:2.3:o:debian:debian_linux:3.0:-:ia-32
  • cpe:2.3:o:debian:debian_linux:3.0:-:ia-64
    cpe:2.3:o:debian:debian_linux:3.0:-:ia-64
  • cpe:2.3:o:debian:debian_linux:3.0:-:m68k
    cpe:2.3:o:debian:debian_linux:3.0:-:m68k
  • cpe:2.3:o:debian:debian_linux:3.0:-:mips
    cpe:2.3:o:debian:debian_linux:3.0:-:mips
  • cpe:2.3:o:debian:debian_linux:3.0:-:mipsel
    cpe:2.3:o:debian:debian_linux:3.0:-:mipsel
  • cpe:2.3:o:debian:debian_linux:3.0:-:ppc
    cpe:2.3:o:debian:debian_linux:3.0:-:ppc
  • cpe:2.3:o:debian:debian_linux:3.0:-:s-390
    cpe:2.3:o:debian:debian_linux:3.0:-:s-390
  • cpe:2.3:o:debian:debian_linux:3.0:-:sparc
    cpe:2.3:o:debian:debian_linux:3.0:-:sparc
  • Debian Debian Linux 3.1
    cpe:2.3:o:debian:debian_linux:3.1
  • cpe:2.3:o:debian:debian_linux:3.1:-:alpha
    cpe:2.3:o:debian:debian_linux:3.1:-:alpha
  • cpe:2.3:o:debian:debian_linux:3.1:-:amd64
    cpe:2.3:o:debian:debian_linux:3.1:-:amd64
  • cpe:2.3:o:debian:debian_linux:3.1:-:arm
    cpe:2.3:o:debian:debian_linux:3.1:-:arm
  • cpe:2.3:o:debian:debian_linux:3.1:-:hppa
    cpe:2.3:o:debian:debian_linux:3.1:-:hppa
  • cpe:2.3:o:debian:debian_linux:3.1:-:ia-32
    cpe:2.3:o:debian:debian_linux:3.1:-:ia-32
  • cpe:2.3:o:debian:debian_linux:3.1:-:ia-64
    cpe:2.3:o:debian:debian_linux:3.1:-:ia-64
  • cpe:2.3:o:debian:debian_linux:3.1:-:m68k
    cpe:2.3:o:debian:debian_linux:3.1:-:m68k
  • cpe:2.3:o:debian:debian_linux:3.1:-:mips
    cpe:2.3:o:debian:debian_linux:3.1:-:mips
  • cpe:2.3:o:debian:debian_linux:3.1:-:mipsel
    cpe:2.3:o:debian:debian_linux:3.1:-:mipsel
  • cpe:2.3:o:debian:debian_linux:3.1:-:ppc
    cpe:2.3:o:debian:debian_linux:3.1:-:ppc
  • cpe:2.3:o:debian:debian_linux:3.1:-:s-390
    cpe:2.3:o:debian:debian_linux:3.1:-:s-390
  • cpe:2.3:o:debian:debian_linux:3.1:-:sparc
    cpe:2.3:o:debian:debian_linux:3.1:-:sparc
  • Gentoo Linux
    cpe:2.3:o:gentoo:linux
  • MandrakeSoft Mandrake Linux 10.1
    cpe:2.3:o:mandrakesoft:mandrake_linux:10.1
  • cpe:2.3:o:mandrakesoft:mandrake_linux:10.1:-:x86-64
    cpe:2.3:o:mandrakesoft:mandrake_linux:10.1:-:x86-64
  • MandrakeSoft Mandrake Linux 10.2
    cpe:2.3:o:mandrakesoft:mandrake_linux:10.2
  • cpe:2.3:o:mandrakesoft:mandrake_linux:10.2:-:x86-64
    cpe:2.3:o:mandrakesoft:mandrake_linux:10.2:-:x86-64
  • MandrakeSoft Mandrake Linux 2006.0
    cpe:2.3:o:mandrakesoft:mandrake_linux:2006
  • cpe:2.3:o:mandrakesoft:mandrake_linux:2006:-:x86-64
    cpe:2.3:o:mandrakesoft:mandrake_linux:2006:-:x86-64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
    cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:2.1
  • cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:2.1:-:x86_64
    cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:2.1:-:x86_64
  • MandrakeSoft Mandrake Corporate Server 3.0
    cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:3.0
  • cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:3.0:-:x86_64
    cpe:2.3:o:mandrakesoft:mandrake_linux_corporate_server:3.0:-:x86_64
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:advanced_server
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:advanced_server
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:advanced_server_ia64
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:advanced_server_ia64
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:enterprise_server
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:enterprise_server
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:enterprise_server_ia64
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:enterprise_server_ia64
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:workstation
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:workstation
  • cpe:2.3:o:redhat:enterprise_linux:2.1:-:workstation_ia64
    cpe:2.3:o:redhat:enterprise_linux:2.1:-:workstation_ia64
  • cpe:2.3:o:redhat:enterprise_linux:3.0:-:advanced_server
    cpe:2.3:o:redhat:enterprise_linux:3.0:-:advanced_server
  • cpe:2.3:o:redhat:enterprise_linux:3.0:-:enterprise_server
    cpe:2.3:o:redhat:enterprise_linux:3.0:-:enterprise_server
  • cpe:2.3:o:redhat:enterprise_linux:3.0:-:workstation_server
    cpe:2.3:o:redhat:enterprise_linux:3.0:-:workstation_server
  • cpe:2.3:o:redhat:enterprise_linux:4.0:-:advanced_server
    cpe:2.3:o:redhat:enterprise_linux:4.0:-:advanced_server
  • cpe:2.3:o:redhat:enterprise_linux:4.0:-:enterprise_server
    cpe:2.3:o:redhat:enterprise_linux:4.0:-:enterprise_server
  • cpe:2.3:o:redhat:enterprise_linux:4.0:-:workstation
    cpe:2.3:o:redhat:enterprise_linux:4.0:-:workstation
  • Red Hat Desktop 3.0
    cpe:2.3:o:redhat:enterprise_linux_desktop:3.0
  • Red Hat Desktop 4.0
    cpe:2.3:o:redhat:enterprise_linux_desktop:4.0
  • cpe:2.3:o:redhat:fedora_core:core_1.0
    cpe:2.3:o:redhat:fedora_core:core_1.0
  • cpe:2.3:o:redhat:fedora_core:core_2.0
    cpe:2.3:o:redhat:fedora_core:core_2.0
  • cpe:2.3:o:redhat:fedora_core:core_3.0
    cpe:2.3:o:redhat:fedora_core:core_3.0
  • cpe:2.3:o:redhat:fedora_core:core_4.0
    cpe:2.3:o:redhat:fedora_core:core_4.0
  • cpe:2.3:o:redhat:linux:7.3:-:i386
    cpe:2.3:o:redhat:linux:7.3:-:i386
  • cpe:2.3:o:redhat:linux:9.0:-:i386
    cpe:2.3:o:redhat:linux:9.0:-:i386
  • cpe:2.3:o:redhat:linux_advanced_workstation:2.1:-:ia64
    cpe:2.3:o:redhat:linux_advanced_workstation:2.1:-:ia64
  • cpe:2.3:o:redhat:linux_advanced_workstation:2.1:-:itanium
    cpe:2.3:o:redhat:linux_advanced_workstation:2.1:-:itanium
  • cpe:2.3:o:sco:openserver:5.0.7
    cpe:2.3:o:sco:openserver:5.0.7
  • cpe:2.3:o:sco:openserver:6.0
    cpe:2.3:o:sco:openserver:6.0
  • Slackware Linux 9.0
    cpe:2.3:o:slackware:slackware_linux:9.0
  • Slackware Linux 9.1
    cpe:2.3:o:slackware:slackware_linux:9.1
  • Slackware Linux 10.0
    cpe:2.3:o:slackware:slackware_linux:10.0
  • Slackware Linux 10.1
    cpe:2.3:o:slackware:slackware_linux:10.1
  • Slackware Linux 10.2
    cpe:2.3:o:slackware:slackware_linux:10.2
  • SuSE SuSE Linux 1.0
    cpe:2.3:o:suse:suse_linux:1.0
  • cpe:2.3:o:suse:suse_linux:9.0:-:enterprise_server
    cpe:2.3:o:suse:suse_linux:9.0:-:enterprise_server
  • cpe:2.3:o:suse:suse_linux:9.0:-:personal
    cpe:2.3:o:suse:suse_linux:9.0:-:personal
  • cpe:2.3:o:suse:suse_linux:9.0:-:professional
    cpe:2.3:o:suse:suse_linux:9.0:-:professional
  • cpe:2.3:o:suse:suse_linux:9.0:-:s_390
    cpe:2.3:o:suse:suse_linux:9.0:-:s_390
  • cpe:2.3:o:suse:suse_linux:9.0:-:x86_64
    cpe:2.3:o:suse:suse_linux:9.0:-:x86_64
  • cpe:2.3:o:suse:suse_linux:9.1:-:personal
    cpe:2.3:o:suse:suse_linux:9.1:-:personal
  • cpe:2.3:o:suse:suse_linux:9.1:-:professional
    cpe:2.3:o:suse:suse_linux:9.1:-:professional
  • cpe:2.3:o:suse:suse_linux:9.1:-:x86_64
    cpe:2.3:o:suse:suse_linux:9.1:-:x86_64
  • cpe:2.3:o:suse:suse_linux:9.2:-:personal
    cpe:2.3:o:suse:suse_linux:9.2:-:personal
  • cpe:2.3:o:suse:suse_linux:9.2:-:professional
    cpe:2.3:o:suse:suse_linux:9.2:-:professional
  • cpe:2.3:o:suse:suse_linux:9.2:-:x86_64
    cpe:2.3:o:suse:suse_linux:9.2:-:x86_64
  • cpe:2.3:o:suse:suse_linux:9.3:-:personal
    cpe:2.3:o:suse:suse_linux:9.3:-:personal
  • cpe:2.3:o:suse:suse_linux:9.3:-:professional
    cpe:2.3:o:suse:suse_linux:9.3:-:professional
  • cpe:2.3:o:suse:suse_linux:9.3:-:x86_64
    cpe:2.3:o:suse:suse_linux:9.3:-:x86_64
  • cpe:2.3:o:suse:suse_linux:10.0:-:oss
    cpe:2.3:o:suse:suse_linux:10.0:-:oss
  • cpe:2.3:o:suse:suse_linux:10.0:-:professional
    cpe:2.3:o:suse:suse_linux:10.0:-:professional
  • Trustix Secure Linux 2.0
    cpe:2.3:o:trustix:secure_linux:2.0
  • Trustix Secure Linux 2.2
    cpe:2.3:o:trustix:secure_linux:2.2
  • Trustix Secure Linux 3.0
    cpe:2.3:o:trustix:secure_linux:3.0
  • cpe:2.3:o:turbolinux:turbolinux:10
    cpe:2.3:o:turbolinux:turbolinux:10
  • cpe:2.3:o:turbolinux:turbolinux:fuji
    cpe:2.3:o:turbolinux:turbolinux:fuji
  • cpe:2.3:o:turbolinux:turbolinux_appliance_server:1.0_hosting_edition
    cpe:2.3:o:turbolinux:turbolinux_appliance_server:1.0_hosting_edition
  • cpe:2.3:o:turbolinux:turbolinux_appliance_server:1.0_workgroup_edition
    cpe:2.3:o:turbolinux:turbolinux_appliance_server:1.0_workgroup_edition
  • cpe:2.3:o:turbolinux:turbolinux_desktop:10.0
    cpe:2.3:o:turbolinux:turbolinux_desktop:10.0
  • cpe:2.3:o:turbolinux:turbolinux_home
    cpe:2.3:o:turbolinux:turbolinux_home
  • cpe:2.3:o:turbolinux:turbolinux_multimedia
    cpe:2.3:o:turbolinux:turbolinux_multimedia
  • cpe:2.3:o:turbolinux:turbolinux_personal
    cpe:2.3:o:turbolinux:turbolinux_personal
  • cpe:2.3:o:turbolinux:turbolinux_server:8.0
    cpe:2.3:o:turbolinux:turbolinux_server:8.0
  • cpe:2.3:o:turbolinux:turbolinux_server:10.0
    cpe:2.3:o:turbolinux:turbolinux_server:10.0
  • cpe:2.3:o:turbolinux:turbolinux_server:10.0_x86
    cpe:2.3:o:turbolinux:turbolinux_server:10.0_x86
  • cpe:2.3:o:turbolinux:turbolinux_workstation:8.0
    cpe:2.3:o:turbolinux:turbolinux_workstation:8.0
  • cpe:2.3:o:ubuntu:ubuntu_linux:4.1:-:ia64
    cpe:2.3:o:ubuntu:ubuntu_linux:4.1:-:ia64
  • cpe:2.3:o:ubuntu:ubuntu_linux:4.1:-:ppc
    cpe:2.3:o:ubuntu:ubuntu_linux:4.1:-:ppc
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:amd64
    cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:amd64
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:i386
    cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:i386
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:powerpc
    cpe:2.3:o:ubuntu:ubuntu_linux:5.04:-:powerpc
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:amd64
    cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:amd64
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:i386
    cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:i386
  • cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:powerpc
    cpe:2.3:o:ubuntu:ubuntu_linux:5.10:-:powerpc
CVSS
Base: 5.0 (as of 05-06-2006 - 13:03)
Impact:
Exploitability:
CWE CWE-399
CAPEC
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
nessus via4
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2005-028.NASL
    description Several flaws were discovered in the way teTeX processes PDF files. An attacker could construct a carefully crafted PDF file that could cause poppler to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. This package also updates bindings in texdoc and causes the local texmf tree to be searched first.
    last seen 2017-10-29
    modified 2012-10-01
    plugin id 62250
    published 2012-09-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=62250
    title Fedora Core 4 : tetex-3.0-9.FC4 (2005-028)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2006-029.NASL
    description Several flaws were discovered in the way teTeX processes PDF files. An attacker could construct a carefully crafted PDF file that could cause poppler to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20410
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20410
    title Fedora Core 3 : tetex-2.0.2-21.7.FC3 (2006-029)
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-236-1.NASL
    description Chris Evans discovered several integer overflows in the XPDF code, which is present in xpdf, the Poppler library, and tetex-bin. By tricking an user into opening a specially crafted PDF file, an attacker could exploit this to execute arbitrary code with the privileges of the application that processes the document. The CUPS printing system also uses XPDF code to convert PDF files to PostScript. By attempting to print such a crafted PDF file, a remote attacker could execute arbitrary code with the privileges of the printer server (user 'cupsys'). Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-05-26
    plugin id 20781
    published 2006-01-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20781
    title Ubuntu 4.10 / 5.04 / 5.10 : xpdf, poppler, cupsys, tetex-bin vulnerabilities (USN-236-1)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2005-025.NASL
    description - CVE-2005-0001 Paul Starzetz from isec.pl found an exploitable hole in the x86 SMP page fault handler which could lead to privilege escalation. http://www.isec.pl/vulnerabilities/isec-0022-pagefault.t xt This update additionally fixes a random memory corruption issue present in the previous update, and in addition updates to the latest -ac collection of patches. A full changelog of the update vs the previous -ac8 based release is available at http://lkml.org/lkml/2005/1/13/219 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 16166
    published 2005-01-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16166
    title Fedora Core 3 : kernel-2.6.10-1.741_FC3 (2005-025)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2006-0163.NASL
    description Updated CUPS packages that fix multiple security issues are now available for Red Hat Enterprise Linux. This update has been rated as having important security impact by the Red Hat Security Response Team. The Common UNIX Printing System (CUPS) provides a portable printing layer for UNIX(R) operating systems. Chris Evans discovered several flaws in the way CUPS processes PDF files. An attacker could construct a carefully crafted PDF file that could cause CUPS to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. All users of CUPS should upgrade to these updated packages, which contain backported patches to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-16
    plugin id 20481
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20481
    title RHEL 3 / 4 : cups (RHSA-2006:0163)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2005-029.NASL
    description Several flaws were discovered in the way teTeX processes PDF files. An attacker could construct a carefully crafted PDF file that could cause poppler to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues.
    last seen 2017-10-29
    modified 2012-10-01
    plugin id 62251
    published 2012-09-24
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=62251
    title Fedora Core 3 : tetex-2.0.2-21.7.FC3 (2005-029)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2006-028.NASL
    description Several flaws were discovered in the way teTeX processes PDF files. An attacker could construct a carefully crafted PDF file that could cause poppler to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. This package also updates bindings in texdoc and causes the local texmf tree to be searched first. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20409
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20409
    title Fedora Core 4 : tetex-3.0-9.FC4 (2006-028)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2006-0177.NASL
    description An updated gpdf package that fixes several security issues is now available for Red Hat Enterprise Linux 4. This update has been rated as having important security impact by the Red Hat Security Response Team. gpdf is a GNOME based viewer for Portable Document Format (PDF) files. Chris Evans discovered several flaws in the way gpdf processes PDF files. An attacker could construct a carefully crafted PDF file that could cause gpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. Users of gpdf should upgrade to this updated package, which contains a backported patch to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-16
    plugin id 20482
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20482
    title RHEL 4 : gpdf (RHSA-2006:0177)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-200601-17.NASL
    description The remote host is affected by the vulnerability described in GLSA-200601-17 (Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows) Chris Evans has reported some integer overflows in Xpdf when attempting to calculate buffer sizes for memory allocation, leading to a heap overflow and a potential infinite loop when handling malformed input files. Impact : By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 20829
    published 2006-02-01
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20829
    title GLSA-200601-17 : Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2005-026.NASL
    description - CVE-2005-0001 Paul Starzetz from isec.pl found an exploitable hole in the x86 SMP page fault handler which could lead to privilege escalation. http://www.isec.pl/vulnerabilities/isec-0022-pagefault.t xt This update additionally fixes a random memory corruption issue present in the previous update, and in addition updates to the latest -ac collection of patches. A full changelog of the update vs the previous -ac8 based release is available at http://lkml.org/lkml/2005/1/13/219 Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 16167
    published 2005-01-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16167
    title Fedora Core 2 : kernel-2.6.10-1.9_FC2 (2005-026)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2006-0177.NASL
    description An updated gpdf package that fixes several security issues is now available for Red Hat Enterprise Linux 4. This update has been rated as having important security impact by the Red Hat Security Response Team. gpdf is a GNOME based viewer for Portable Document Format (PDF) files. Chris Evans discovered several flaws in the way gpdf processes PDF files. An attacker could construct a carefully crafted PDF file that could cause gpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. Users of gpdf should upgrade to this updated package, which contains a backported patch to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 21980
    published 2006-07-05
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=21980
    title CentOS 4 : gpdf (CESA-2006:0177)
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-236-2.NASL
    description USN-236-1 fixed several vulnerabilities in xpdf. kpdf and kword contain copies of xpdf code and are thus vulnerable to the same issues. For reference, this is the original advisory : Chris Evans discovered several integer overflows in the XPDF code, which is present in xpdf, the Poppler library, and tetex-bin. By tricking an user into opening a specially crafted PDF file, an attacker could exploit this to execute arbitrary code with the privileges of the application that processes the document. Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-05-26
    plugin id 20782
    published 2006-01-21
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20782
    title Ubuntu 5.04 / 5.10 : kdegraphics, koffice vulnerabilities (USN-236-2)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2006-026.NASL
    description Chris Evans discovered several flaws in the way poppler processes PDF files. An attacker could construct a carefully crafted PDF file that could cause poppler to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20407
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20407
    title Fedora Core 4 : poppler-0.4.4-1.1 (2006-026)
  • NASL family Fedora Local Security Checks
    NASL id FEDORA_2006-025.NASL
    description Chris Evans discovered several flaws in the way CUPS processes PDF files. An attacker could construct a carefully crafted PDF file that could cause CUPS to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20406
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20406
    title Fedora Core 3 : gpdf-2.8.2-7.2 (2006-025)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2006-0163.NASL
    description Updated CUPS packages that fix multiple security issues are now available for Red Hat Enterprise Linux. This update has been rated as having important security impact by the Red Hat Security Response Team. The Common UNIX Printing System (CUPS) provides a portable printing layer for UNIX(R) operating systems. Chris Evans discovered several flaws in the way CUPS processes PDF files. An attacker could construct a carefully crafted PDF file that could cause CUPS to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, and CVE-2005-3627 to these issues. All users of CUPS should upgrade to these updated packages, which contain backported patches to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 21886
    published 2006-07-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=21886
    title CentOS 3 / 4 : cups (CESA-2006:0163)
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2006-011.NASL
    description Multiple heap-based buffer overflows in the DCTStream::readProgressiveSOF and DCTStream::readBaselineSOF functions in the DCT stream parsing code (Stream.cc) in xpdf 3.01 and earlier, allow user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with an out-of-range number of components (numComps), which is used as an array index. (CVE-2005-3191) Heap-based buffer overflow in the StreamPredictor function in Xpdf 3.01 allows remote attackers to execute arbitrary code via a PDF file with an out-of-range numComps (number of components) field. (CVE-2005-3192) Heap-based buffer overflow in the JPXStream::readCodestream function in the JPX stream parsing code (JPXStream.c) for xpdf 3.01 and earlier allows user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with large size values that cause insufficient memory to be allocated. (CVE-2005-3193) An additional patch re-addresses memory allocation routines in goo/gmem.c (Martin Pitt/Canonical, Dirk Mueller/KDE). In addition, Chris Evans discovered several other vulnerabilities in the xpdf code base : Out-of-bounds heap accesses with large or negative parameters to 'FlateDecode' stream. (CVE-2005-3192) Out-of-bounds heap accesses with large or negative parameters to 'CCITTFaxDecode' stream. (CVE-2005-3624) Infinite CPU spins in various places when stream ends unexpectedly. (CVE-2005-3625) NULL pointer crash in the 'FlateDecode' stream. (CVE-2005-3626) Overflows of compInfo array in 'DCTDecode' stream. (CVE-2005-3627) Possible to use index past end of array in 'DCTDecode' stream. (CVE-2005-3627) Possible out-of-bounds indexing trouble in 'DCTDecode' stream. (CVE-2005-3627) Tetex uses an embedded copy of the xpdf code, with the same vulnerabilities. The updated packages have been patched to correct these problems.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20477
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20477
    title Mandrake Linux Security Advisory : tetex (MDKSA-2006:011)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-961.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf which are also present in pdfkit.framework, the GNUstep framework for rendering PDF content, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22827
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22827
    title Debian DSA-961-1 : pdfkit.framework - buffer overflows
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2005-840.NASL
    description An updated xpdf package that fixes several security issues is now available. This update has been rated as having important security impact by the Red Hat Security Response Team. [Updated 20 Dec 2005] The initial fix for these issues was incomplete. The packages have been updated with a more complete fix. The xpdf package is an X Window System-based viewer for Portable Document Format (PDF) files. Several flaws were discovered in Xpdf. An attacker could construct a carefully crafted PDF file that could cause Xpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues. Users of Xpdf should upgrade to this updated package, which contains a backported patch to resolve these issues. Red Hat would like to thank Derek B. Noonburg for reporting this issue and providing a patch.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 21873
    published 2006-07-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=21873
    title CentOS 3 / 4 : xpdf (CESA-2005:840)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2006-0160.NASL
    description Updated tetex packages that fix several integer overflows are now available. This update has been rated as having moderate security impact by the Red Hat Security Response Team. TeTeX is an implementation of TeX. TeX takes a text file and a set of formatting commands as input and creates a typesetter-independent .dvi (DeVice Independent) file as output. Several flaws were discovered in the teTeX PDF parsing library. An attacker could construct a carefully crafted PDF file that could cause teTeX to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, CVE-2005-3193, CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, CVE-2005-3627 and CVE-2005-3628 to these issues. Users of teTeX should upgrade to these updated packages, which contain backported patches and are not vulnerable to these issues.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 21885
    published 2006-07-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=21885
    title CentOS 3 / 4 : tetex (CESA-2006:0160)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-931.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, that can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22797
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22797
    title Debian DSA-931-1 : xpdf - buffer overflows
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2006-010.NASL
    description Multiple heap-based buffer overflows in the DCTStream::readProgressiveSOF and DCTStream::readBaselineSOF functions in the DCT stream parsing code (Stream.cc) in xpdf 3.01 and earlier, allow user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with an out-of-range number of components (numComps), which is used as an array index. (CVE-2005-3191) Heap-based buffer overflow in the StreamPredictor function in Xpdf 3.01 allows remote attackers to execute arbitrary code via a PDF file with an out-of-range numComps (number of components) field. (CVE-2005-3192) Heap-based buffer overflow in the JPXStream::readCodestream function in the JPX stream parsing code (JPXStream.c) for xpdf 3.01 and earlier allows user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with large size values that cause insufficient memory to be allocated. (CVE-2005-3193) An additional patch re-addresses memory allocation routines in goo/gmem.c (Martin Pitt/Canonical, Dirk Mueller/KDE). In addition, Chris Evans discovered several other vulnerabilities in the xpdf code base : Out-of-bounds heap accesses with large or negative parameters to 'FlateDecode' stream. (CVE-2005-3192) Out-of-bounds heap accesses with large or negative parameters to 'CCITTFaxDecode' stream. (CVE-2005-3624) Infinite CPU spins in various places when stream ends unexpectedly. (CVE-2005-3625) NULL pointer crash in the 'FlateDecode' stream. (CVE-2005-3626) Overflows of compInfo array in 'DCTDecode' stream. (CVE-2005-3627) Possible to use index past end of array in 'DCTDecode' stream. (CVE-2005-3627) Possible out-of-bounds indexing trouble in 'DCTDecode' stream. (CVE-2005-3627) CUPS uses an embedded copy of the xpdf code, with the same vulnerabilities. The updated packages have been patched to correct these problems.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20476
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20476
    title Mandrake Linux Security Advisory : cups (MDKSA-2006:010)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-936.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, which is also present in libextractor, a library to extract arbitrary meta-data from files, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22802
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22802
    title Debian DSA-936-1 : libextractor - buffer overflows
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-938.NASL
    description 'infamous41md' and chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, which is also present in koffice, the KDE Office Suite, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22804
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22804
    title Debian DSA-938-1 : koffice - buffer overflows
  • NASL family Slackware Local Security Checks
    NASL id SLACKWARE_SSA_2006-045-04.NASL
    description New kdegraphics packages are available for Slackware 10.0, 10.1, 10.2, and -current to fix security issues with kpdf.
    last seen 2019-02-21
    modified 2018-11-19
    plugin id 20915
    published 2006-02-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20915
    title Slackware 10.0 / 10.1 / 10.2 / current : kdegraphics (SSA:2006-045-04)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2005-868.NASL
    description Updated kdegraphics packages that resolve several security issues in kpdf are now available. This update has been rated as having important security impact by the Red Hat Security Response Team. The kdegraphics packages contain applications for the K Desktop Environment including kpdf, a pdf file viewer. Several flaws were discovered in kpdf. An attacker could construct a carefully crafted PDF file that could cause kpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues. Users of kpdf should upgrade to these updated packages, which contain a backported patch to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 20363
    published 2005-12-30
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20363
    title RHEL 4 : kdegraphics (RHSA-2005:868)
  • NASL family CentOS Local Security Checks
    NASL id CENTOS_RHSA-2005-868.NASL
    description Updated kdegraphics packages that resolve several security issues in kpdf are now available. This update has been rated as having important security impact by the Red Hat Security Response Team. The kdegraphics packages contain applications for the K Desktop Environment including kpdf, a pdf file viewer. Several flaws were discovered in kpdf. An attacker could construct a carefully crafted PDF file that could cause kpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues. Users of kpdf should upgrade to these updated packages, which contain a backported patch to resolve these issues.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 21972
    published 2006-07-05
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=21972
    title CentOS 4 : kdegraphics (CESA-2005:868)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-932.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, that can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code. The same code is present in kpdf which is part of the kdegraphics package.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22798
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22798
    title Debian DSA-932-1 : kdegraphics - buffer overflows
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2006-012.NASL
    description Multiple heap-based buffer overflows in the DCTStream::readProgressiveSOF and DCTStream::readBaselineSOF functions in the DCT stream parsing code (Stream.cc) in xpdf 3.01 and earlier, allow user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with an out-of-range number of components (numComps), which is used as an array index. (CVE-2005-3191) Heap-based buffer overflow in the StreamPredictor function in Xpdf 3.01 allows remote attackers to execute arbitrary code via a PDF file with an out-of-range numComps (number of components) field. (CVE-2005-3192) Heap-based buffer overflow in the JPXStream::readCodestream function in the JPX stream parsing code (JPXStream.c) for xpdf 3.01 and earlier allows user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with large size values that cause insufficient memory to be allocated. (CVE-2005-3193) An additional patch re-addresses memory allocation routines in goo/gmem.c (Martin Pitt/Canonical, Dirk Mueller/KDE). In addition, Chris Evans discovered several other vulnerabilities in the xpdf code base : Out-of-bounds heap accesses with large or negative parameters to 'FlateDecode' stream. (CVE-2005-3192) Out-of-bounds heap accesses with large or negative parameters to 'CCITTFaxDecode' stream. (CVE-2005-3624) Infinite CPU spins in various places when stream ends unexpectedly. (CVE-2005-3625) NULL pointer crash in the 'FlateDecode' stream. (CVE-2005-3626) Overflows of compInfo array in 'DCTDecode' stream. (CVE-2005-3627) Possible to use index past end of array in 'DCTDecode' stream. (CVE-2005-3627) Possible out-of-bounds indexing trouble in 'DCTDecode' stream. (CVE-2005-3627) Kdegraphics uses an embedded copy of the xpdf code, with the same vulnerabilities. The updated packages have been patched to correct these problems.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20478
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20478
    title Mandrake Linux Security Advisory : kdegraphics (MDKSA-2006:012)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-940.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, which is also present in gpdf, the GNOME version of the Portable Document Format viewer, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22806
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22806
    title Debian DSA-940-1 : gpdf - buffer overflows
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-950.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf which are also present in CUPS, the Common UNIX Printing System, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22816
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22816
    title Debian DSA-950-1 : cupsys - buffer overflows
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2005-840.NASL
    description An updated xpdf package that fixes several security issues is now available. This update has been rated as having important security impact by the Red Hat Security Response Team. [Updated 20 Dec 2005] The initial fix for these issues was incomplete. The packages have been updated with a more complete fix. The xpdf package is an X Window System-based viewer for Portable Document Format (PDF) files. Several flaws were discovered in Xpdf. An attacker could construct a carefully crafted PDF file that could cause Xpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues. Users of Xpdf should upgrade to this updated package, which contains a backported patch to resolve these issues. Red Hat would like to thank Derek B. Noonburg for reporting this issue and providing a patch.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 20268
    published 2005-12-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20268
    title RHEL 2.1 / 3 / 4 : xpdf (RHSA-2005:840)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-962.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf which are also present in pdftohtml, a utility that translates PDF documents into HTML format, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22828
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22828
    title Debian DSA-962-1 : pdftohtml - buffer overflows
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-200601-02.NASL
    description The remote host is affected by the vulnerability described in GLSA-200601-02 (KPdf, KWord: Multiple overflows in included Xpdf code) KPdf and KWord both include Xpdf code to handle PDF files. This Xpdf code is vulnerable to several heap overflows (GLSA 200512-08) as well as several buffer and integer overflows discovered by Chris Evans (CESA-2005-003). Impact : An attacker could entice a user to open a specially crafted PDF file with Kpdf or KWord, potentially resulting in the execution of arbitrary code with the rights of the user running the affected application. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-11-19
    plugin id 20412
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20412
    title GLSA-200601-02 : KPdf, KWord: Multiple overflows in included Xpdf code
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-937.NASL
    description 'infamous41md' and Chris Evans discovered several heap based buffer overflows in xpdf, the Portable Document Format (PDF) suite, which is also present in tetex-bin, the binary files of teTeX, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 22803
    published 2006-10-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=22803
    title Debian DSA-937-1 : tetex-bin - buffer overflows
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2006-008.NASL
    description Multiple heap-based buffer overflows in the DCTStream::readProgressiveSOF and DCTStream::readBaselineSOF functions in the DCT stream parsing code (Stream.cc) in xpdf 3.01 and earlier, allow user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with an out-of-range number of components (numComps), which is used as an array index. (CVE-2005-3191) Heap-based buffer overflow in the StreamPredictor function in Xpdf 3.01 allows remote attackers to execute arbitrary code via a PDF file with an out-of-range numComps (number of components) field. (CVE-2005-3192) Heap-based buffer overflow in the JPXStream::readCodestream function in the JPX stream parsing code (JPXStream.c) for xpdf 3.01 and earlier allows user-complicit attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with large size values that cause insufficient memory to be allocated. (CVE-2005-3193) An additional patch re-addresses memory allocation routines in goo/gmem.c (Martin Pitt/Canonical, Dirk Mueller/KDE). In addition, Chris Evans discovered several other vulnerabilities in the xpdf code base : Out-of-bounds heap accesses with large or negative parameters to 'FlateDecode' stream. (CVE-2005-3192) Out-of-bounds heap accesses with large or negative parameters to 'CCITTFaxDecode' stream. (CVE-2005-3624) Infinite CPU spins in various places when stream ends unexpectedly. (CVE-2005-3625) NULL pointer crash in the 'FlateDecode' stream. (CVE-2005-3626) Overflows of compInfo array in 'DCTDecode' stream. (CVE-2005-3627) Possible to use index past end of array in 'DCTDecode' stream. (CVE-2005-3627) Possible out-of-bounds indexing trouble in 'DCTDecode' stream. (CVE-2005-3627) Koffice uses an embedded copy of the xpdf code, with the same vulnerabilities. The updated packages have been patched to correct these problems.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 20474
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20474
    title Mandrake Linux Security Advisory : koffice (MDKSA-2006:008)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2006-0160.NASL
    description Updated tetex packages that fix several integer overflows are now available. This update has been rated as having moderate security impact by the Red Hat Security Response Team. TeTeX is an implementation of TeX. TeX takes a text file and a set of formatting commands as input and creates a typesetter-independent .dvi (DeVice Independent) file as output. Several flaws were discovered in the teTeX PDF parsing library. An attacker could construct a carefully crafted PDF file that could cause teTeX to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, CVE-2005-3193, CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, CVE-2005-3627 and CVE-2005-3628 to these issues. Users of teTeX should upgrade to these updated packages, which contain backported patches and are not vulnerable to these issues.
    last seen 2019-02-21
    modified 2018-11-16
    plugin id 20752
    published 2006-01-20
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20752
    title RHEL 2.1 / 3 / 4 : tetex (RHSA-2006:0160)
  • NASL family Slackware Local Security Checks
    NASL id SLACKWARE_SSA_2006-045-09.NASL
    description New xpdf packages are available for Slackware 9.0, 9.1, 10.0, 10.1, 10.2, and -current to fix security issues.
    last seen 2019-02-21
    modified 2018-06-27
    plugin id 20920
    published 2006-02-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20920
    title Slackware 10.0 / 10.1 / 10.2 / 9.0 / 9.1 / current : xpdf (SSA:2006-045-09)
oval via4
accepted 2013-04-29T04:23:58.162-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
  • comment The operating system installed on the system is Red Hat Enterprise Linux 4
    oval oval:org.mitre.oval:def:11831
  • comment CentOS Linux 4.x
    oval oval:org.mitre.oval:def:16636
  • comment Oracle Linux 4.x
    oval oval:org.mitre.oval:def:15990
description Xpdf, as used in products such as gpdf, kpdf, pdftohtml, poppler, teTeX, CUPS, libextractor, and others, allows attackers to cause a denial of service (crash) via a crafted FlateDecode stream that triggers a null dereference.
family unix
id oval:org.mitre.oval:def:9992
status accepted
submitted 2010-07-09T03:56:16-04:00
title Xpdf, as used in products such as gpdf, kpdf, pdftohtml, poppler, teTeX, CUPS, libextractor, and others, allows attackers to cause a denial of service (crash) via a crafted FlateDecode stream that triggers a null dereference.
version 23
redhat via4
advisories
  • rhsa
    id RHSA-2006:0160
  • rhsa
    id RHSA-2006:0163
  • rhsa
    id RHSA-2006:0177
refmap via4
bid 16143
confirm
debian
  • DSA-931
  • DSA-932
  • DSA-936
  • DSA-937
  • DSA-938
  • DSA-940
  • DSA-950
  • DSA-961
  • DSA-962
fedora
  • FEDORA-2005-025
  • FEDORA-2005-026
  • FLSA-2006:176751
  • FLSA:175404
gentoo
  • GLSA-200601-02
  • GLSA-200601-17
mandrake MDKSA-2006:010
mandriva
  • MDKSA-2006:003
  • MDKSA-2006:004
  • MDKSA-2006:005
  • MDKSA-2006:006
  • MDKSA-2006:008
  • MDKSA-2006:011
  • MDKSA-2006:012
misc http://scary.beasts.org/security/CESA-2005-003.txt
sco SCOSA-2006.15
secunia
  • 18147
  • 18303
  • 18312
  • 18313
  • 18329
  • 18332
  • 18334
  • 18335
  • 18338
  • 18349
  • 18373
  • 18375
  • 18380
  • 18385
  • 18387
  • 18389
  • 18398
  • 18407
  • 18414
  • 18416
  • 18423
  • 18425
  • 18428
  • 18436
  • 18448
  • 18463
  • 18517
  • 18534
  • 18554
  • 18582
  • 18642
  • 18644
  • 18674
  • 18675
  • 18679
  • 18908
  • 18913
  • 19230
  • 19377
  • 25729
sgi
  • 20051201-01-U
  • 20060101-01-U
  • 20060201-01-U
slackware
  • SSA:2006-045-04
  • SSA:2006-045-09
sunalert 102972
suse SUSE-SA:2006:001
trustix 2006-0002
ubuntu USN-236-1
vupen
  • ADV-2006-0047
  • ADV-2007-2280
xf xpdf-flatedecode-dos(24026)
statements via4
contributor Mark J Cox
lastmodified 2007-03-14
organization Red Hat
statement Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Last major update 19-02-2017 - 00:09
Published 31-12-2005 - 00:00
Last modified 19-10-2018 - 11:37
Back to Top