ID CVE-2005-2944
Summary The perform_file_save function in GNOME Workstation Command Center (gwcc) 0.9.6 and earlier allows local users to create and overwrite arbitrary files via a symlink attack on the gwcc_out.txt temporary file.
References
Vulnerable Configurations
  • cpe:2.3:a:brent_ely:gnome_workstation_command_center:*:*:*:*:*:*:*:*
    cpe:2.3:a:brent_ely:gnome_workstation_command_center:*:*:*:*:*:*:*:*
  • cpe:2.3:a:brent_ely:gnome_workstation_command_center:0.9.8:*:*:*:*:*:*:*
    cpe:2.3:a:brent_ely:gnome_workstation_command_center:0.9.8:*:*:*:*:*:*:*
CVSS
Base: 4.6 (as of 05-09-2008 - 20:53)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL LOW NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
cvss-vector via4 AV:L/AC:L/Au:N/C:P/I:P/A:P
refmap via4
confirm http://bugs.gentoo.org/show_bug.cgi?id=104566
misc http://www.zataz.net/adviso/gwcc-09052005.txt
secunia 16833
vulnwatch 20050916 gwcc insecure temporary file creation
Last major update 05-09-2008 - 20:53
Published 16-09-2005 - 20:03
Back to Top