ID CVE-2004-1183
Summary Integer overflow in the tiffdump utility for libtiff 3.7.1 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted TIFF file.
References
Vulnerable Configurations
  • LibTIFF 3.4
    cpe:2.3:a:libtiff:libtiff:3.4
  • LibTIFF 3.5.1
    cpe:2.3:a:libtiff:libtiff:3.5.1
  • LibTIFF 3.5.2
    cpe:2.3:a:libtiff:libtiff:3.5.2
  • LibTIFF 3.5.3
    cpe:2.3:a:libtiff:libtiff:3.5.3
  • LibTIFF 3.5.4
    cpe:2.3:a:libtiff:libtiff:3.5.4
  • LibTIFF 3.5.5
    cpe:2.3:a:libtiff:libtiff:3.5.5
  • LibTIFF 3.5.6
    cpe:2.3:a:libtiff:libtiff:3.5.6
  • LibTIFF 3.5.7
    cpe:2.3:a:libtiff:libtiff:3.5.7
  • LibTIFF 3.6.0
    cpe:2.3:a:libtiff:libtiff:3.6.0
  • LibTIFF 3.6.1
    cpe:2.3:a:libtiff:libtiff:3.6.1
  • LibTIFF 3.7.0
    cpe:2.3:a:libtiff:libtiff:3.7.0
  • LibTIFF 3.7.1
    cpe:2.3:a:libtiff:libtiff:3.7.1
CVSS
Base: 5.1 (as of 20-06-2005 - 10:09)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK HIGH NONE
Impact
ConfidentialityIntegrityAvailability
PARTIAL PARTIAL PARTIAL
nessus via4
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2005-002.NASL
    description Several vulnerabilities have been discovered in the libtiff package; wxGTK2 uses a libtiff code tree, so it may have the same vulnerabilities : iDefense reported the possibility of remote exploitation of an integer overflow in libtiff that may allow for the execution of arbitrary code. The overflow occurs in the parsing of TIFF files set with the STRIPOFFSETS flag. iDefense also reported a heap-based buffer overflow vulnerability within the LibTIFF package could allow attackers to execute arbitrary code. (CVE-2004-1308) The vulnerability specifically exists due to insufficient validation of user-supplied data when calculating the size of a directory entry. The updated packages are patched to protect against these vulnerabilities.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 16115
    published 2005-01-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16115
    title Mandrake Linux Security Advisory : wxGTK2 (MDKSA-2005:002)
  • NASL family FreeBSD Local Security Checks
    NASL id FREEBSD_PKG_8F86D8B5602511D9A9E70001020EED82.NASL
    description Dmitry V. Levin found a potential integer overflow in the tiffdump utility which could lead to execution of arbitrary code. This could be exploited by tricking an user into executing tiffdump on a specially crafted tiff image.
    last seen 2019-02-21
    modified 2018-11-10
    plugin id 19028
    published 2005-07-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=19028
    title FreeBSD : tiff -- tiffdump integer overflow vulnerability (8f86d8b5-6025-11d9-a9e7-0001020eed82)
  • NASL family SuSE Local Security Checks
    NASL id SUSE_SA_2005_001.NASL
    description The remote host is missing the patch for the advisory SUSE-SA:2005:001 (libtiff/tiff). Libtiff supports reading, writing, and manipulating of TIFF image files. iDEFENSE reported an integer overflow in libtiff that can be exploited by specific TIFF images to trigger a heap-based buffer overflow afterwards. This bug can be used by external attackers to execute arbitrary code over the network by placing special image files on web-pages and alike. Additionally a buffer overflow in tiffdump was fixed.
    last seen 2019-02-21
    modified 2016-12-27
    plugin id 16305
    published 2005-02-03
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16305
    title SUSE-SA:2005:001: libtiff/tiff
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2005-035.NASL
    description Updated libtiff packages that fix various integer overflows are now available for Red Hat Enterprise Linux 4. This update has been rated as having important security impact by the Red Hat Security Response Team The libtiff package contains a library of functions for manipulating TIFF (Tagged Image File Format) image format files. infamous41md discovered integer overflow flaws in libtiff. An attacker could create a carefully crafted TIFF file in such a way that it could cause an application linked with libtiff to overflow a heap buffer when the file was opened by a victim. Due to the nature of the overflow it is unlikely that it is possible to use this flaw to execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2004-1308 to this issue. Dmitry V. Levin discovered an integer overflow flaw in libtiff. An attacker could create a carefully crafted TIFF file in such a way that it could cause an application linked with libtiff to crash. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2004-1183 to this issue. All users are advised to upgrade to these updated packages, which contain backported fixes for these issues.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 17169
    published 2005-02-22
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=17169
    title RHEL 4 : libtiff (RHSA-2005:035)
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2005-019.NASL
    description Updated libtiff packages that fix various integer overflows are now available. The libtiff package contains a library of functions for manipulating TIFF (Tagged Image File Format) image format files. iDEFENSE has reported an integer overflow bug that affects libtiff. An attacker who has the ability to trick a user into opening a malicious TIFF file could cause the application linked to libtiff to crash or possibly execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2004-1308 to this issue. Dmitry V. Levin reported another integer overflow in the tiffdump utility. An attacker who has the ability to trick a user into opening a malicious TIFF file with tiffdump could possibly execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2004-1183 to this issue. All users are advised to upgrade to these updated packages, which contain backported fixes for these issues.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 16159
    published 2005-01-13
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16159
    title RHEL 2.1 / 3 : libtiff (RHSA-2005:019)
  • NASL family Gentoo Local Security Checks
    NASL id GENTOO_GLSA-200501-06.NASL
    description The remote host is affected by the vulnerability described in GLSA-200501-06 (tiff: New overflows in image decoding) infamous41md found a potential integer overflow in the directory entry count routines of the TIFF library (CAN-2004-1308). Dmitry V. Levin found another similar issue in the tiffdump utility (CAN-2004-1183). Impact : A remote attacker could entice a user to view a carefully crafted TIFF image file, which would potentially lead to execution of arbitrary code with the rights of the user viewing the image. This affects any program that makes use of the TIFF library, including many web browsers or mail readers. Workaround : There is no known workaround at this time.
    last seen 2019-02-21
    modified 2018-08-10
    plugin id 16397
    published 2005-02-14
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16397
    title GLSA-200501-06 : tiff: New overflows in image decoding
  • NASL family Ubuntu Local Security Checks
    NASL id UBUNTU_USN-54-1.NASL
    description Dmitry V. Levin discovered a buffer overflow in the 'tiffdump' utility. If an attacker tricked a user into processing a malicious TIFF image with tiffdump, they could cause a buffer overflow which at least causes the program to crash. However, it is not entirely clear whether this can be exploited to execute arbitrary code with the privileges of the user opening the image. Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.
    last seen 2019-02-21
    modified 2016-05-25
    plugin id 20672
    published 2006-01-15
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=20672
    title Ubuntu 4.10 : tiff vulnerability (USN-54-1)
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2005-001.NASL
    description Several vulnerabilities have been discovered in the libtiff package : iDefense reported the possibility of remote exploitation of an integer overflow in libtiff that may allow for the execution of arbitrary code. The overflow occurs in the parsing of TIFF files set with the STRIPOFFSETS flag. iDefense also reported a heap-based buffer overflow vulnerability within the LibTIFF package could allow attackers to execute arbitrary code. (CVE-2004-1308) The vulnerability specifically exists due to insufficient validation of user-supplied data when calculating the size of a directory entry. The updated packages are patched to protect against these vulnerabilities.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 16114
    published 2005-01-07
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16114
    title Mandrake Linux Security Advisory : libtiff (MDKSA-2005:001)
  • NASL family Debian Local Security Checks
    NASL id DEBIAN_DSA-626.NASL
    description Dmitry V. Levin discovered a buffer overflow in libtiff, the Tag Image File Format library for processing TIFF graphics files. Upon reading a TIFF file it is possible to crash the application, and maybe also to execute arbitrary code.
    last seen 2019-02-21
    modified 2018-08-09
    plugin id 16104
    published 2005-01-06
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=16104
    title Debian DSA-626-1 : tiff - unsanitised input
  • NASL family Mandriva Local Security Checks
    NASL id MANDRAKE_MDKSA-2005-052.NASL
    description Previous updates to correct integer overflow issues affecting xpdf overlooked certain conditions when built for a 64 bit platform. (formerly CVE-2004-0888). This also affects applications like kdegraphics, that use embedded versions of xpdf. (CVE-2005-0206) In addition, previous libtiff updates overlooked kdegraphics, which contains and embedded libtiff used for kfax. This update includes patches to address: CVE-2004-0803, CVE-2004-0804, CVE-2004-0886, CVE-2004-1183, CVE-2004-1308. The updated packages are patched to deal with these issues.
    last seen 2019-02-21
    modified 2018-07-19
    plugin id 17281
    published 2005-03-06
    reporter Tenable
    source https://www.tenable.com/plugins/index.php?view=single&id=17281
    title Mandrake Linux Security Advisory : kdegraphics (MDKSA-2005:052)
oval via4
accepted 2013-04-29T04:21:47.616-04:00
class vulnerability
contributors
  • name Aharon Chernin
    organization SCAP.com, LLC
  • name Dragos Prisaca
    organization G2, Inc.
definition_extensions
  • comment The operating system installed on the system is Red Hat Enterprise Linux 3
    oval oval:org.mitre.oval:def:11782
  • comment CentOS Linux 3.x
    oval oval:org.mitre.oval:def:16651
  • comment The operating system installed on the system is Red Hat Enterprise Linux 4
    oval oval:org.mitre.oval:def:11831
  • comment CentOS Linux 4.x
    oval oval:org.mitre.oval:def:16636
  • comment Oracle Linux 4.x
    oval oval:org.mitre.oval:def:15990
description Integer overflow in the tiffdump utility for libtiff 3.7.1 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted TIFF file.
family unix
id oval:org.mitre.oval:def:9743
status accepted
submitted 2010-07-09T03:56:16-04:00
title Integer overflow in the tiffdump utility for libtiff 3.7.1 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted TIFF file.
version 23
redhat via4
advisories
  • rhsa
    id RHSA-2005:019
  • rhsa
    id RHSA-2005:035
refmap via4
bid 12173
bugtraq 20050106 [USN-54-1] TIFF library tool vulnerability
conectiva CLA-2005:920
debian DSA-626
gentoo GLSA-200501-06
mandrake
  • MDKSA-2005:001
  • MDKSA-2005:002
  • MDKSA-2005:052
secunia
  • 13728
  • 13776
suse SUSE-SA:2005:001
xf libtiff-tiffdump-bo(18782)
Last major update 17-10-2016 - 22:52
Published 06-01-2005 - 00:00
Last modified 10-10-2017 - 21:29
Back to Top