ID CVE-2003-0430
Summary The SPNEGO dissector in Ethereal 0.9.12 and earlier allows remote attackers to cause a denial of service (crash) via an invalid ASN.1 value.
References
Vulnerable Configurations
  • cpe:2.3:a:ethereal_group:ethereal:0.9.12
    cpe:2.3:a:ethereal_group:ethereal:0.9.12
CVSS
Base: 5.0 (as of 01-01-2004 - 00:00)
Impact:
Exploitability:
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
nessus via4
NASL family Red Hat Local Security Checks
NASL id REDHAT-RHSA-2003-077.NASL
description Updated Ethereal packages fixing a number of remotely exploitable security issues are now available. Ethereal is a package designed for monitoring network traffic. A number of security issues affect Ethereal. By exploiting these issues it may be possible to make Ethereal crash or run arbitrary code by injecting a purposefully malformed packet onto the wire, or by convincing someone to read a malformed packet trace file. Ethereal 0.9.9 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via carefully crafted SOCKS packets. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2003-0081 to this issue. A heap-based buffer overflow exists in the NTLMSSP code for Ethereal 0.9.9 and earlier. (CVE-2003-0159) Multiple off-by-one vulnerabilities exist in Ethereal 0.9.11 and earlier in the AIM, GIOP Gryphon, OSPF, PPTP, Quake, Quake2, Quake3, Rsync, SMB, SMPP, and TSP dissectors, which do not properly use the tvb_get_nstringz and tvb_get_nstringz0 functions. (CVE-2003-0356) Multiple integer overflow vulnerabilities exist in Ethereal 0.9.11 and earlier in the Mount and PPP dissectors. (CVE-2003-0357) A vulnerability in the DCERPC dissector exists in Ethereal 0.9.12 and earlier, allowing remote attackers to cause a denial of service (memory consumption) via a certain NDR string. (CVE-2003-0428) A possible buffer overflow vulnerability exists in Ethereal 0.9.12 and earlier, caused by invalid IPv4 or IPv6 prefix lengths and possibly triggering a buffer overflow. (CVE-2003-0429) A vulnerability exists in Ethereal 0.9.12 and earlier, allowing remote attackers to cause a denial of service (crash) via an invalid ASN.1 value. (CVE-2003-0430) The tvb_get_nstringz0 function in Ethereal 0.9.12 and earlier does not properly handle a zero-length buffer size. (CVE-2003-0431) Ethereal 0.9.12 and earlier does not handle certain strings properly in the BGP, WTP, DNS, 802.11, ISAKMP, WSP, CLNP, ISIS, and RMI dissectors. (CVE-2003-0432) Users of Ethereal should update to these erratum packages containing Ethereal version 0.9.13, which are not vulnerable to these issues.
last seen 2019-02-21
modified 2018-11-15
plugin id 12373
published 2004-07-06
reporter Tenable
source https://www.tenable.com/plugins/index.php?view=single&id=12373
title RHEL 2.1 : ethereal (RHSA-2003:077)
oval via4
accepted 2014-06-09T04:01:50.295-04:00
class vulnerability
contributors
  • name Jay Beale
    organization Bastille Linux
  • name Jay Beale
    organization Bastille Linux
  • name Thomas R. Jones
    organization Maitreya Security
  • name Jerome Athias
    organization McAfee, Inc.
description The SPNEGO dissector in Ethereal 0.9.12 and earlier allows remote attackers to cause a denial of service (crash) via an invalid ASN.1 value.
family unix
id oval:org.mitre.oval:def:88
status accepted
submitted 2003-08-29T12:00:00.000-04:00
title Ethereal SPNEGO Dissector Denial of Service Vulnerability
version 36
redhat via4
advisories
rhsa
id RHSA-2003:077
refmap via4
conectiva CLA-2003:662
confirm http://www.ethereal.com/appnotes/enpa-sa-00010.html
sco CSSA-2003-030.0
secunia 9007
Last major update 10-09-2008 - 15:19
Published 24-07-2003 - 00:00
Last modified 10-10-2017 - 21:29
Back to Top