ID CVE-2003-0089
Summary Buffer overflow in the Software Distributor utilities for HP-UX B.11.00 and B.11.11 allows local users to execute arbitrary code via a long LANG environment variable to setuid programs such as (1) swinstall and (2) swmodify.
References
Vulnerable Configurations
  • cpe:2.3:o:hp:hp-ux:11.00:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:11.00:*:*:*:*:*:*:*
  • cpe:2.3:o:hp:hp-ux:11.11:*:*:*:*:*:*:*
    cpe:2.3:o:hp:hp-ux:11.11:*:*:*:*:*:*:*
CVSS
Base: 7.2 (as of 11-10-2017 - 01:29)
Impact:
Exploitability:
CWE NVD-CWE-Other
CAPEC
Access
VectorComplexityAuthentication
LOCAL LOW NONE
Impact
ConfidentialityIntegrityAvailability
COMPLETE COMPLETE COMPLETE
cvss-vector via4 AV:L/AC:L/Au:N/C:C/I:C/A:C
oval via4
accepted 2014-03-24T04:01:41.068-04:00
class vulnerability
contributors
  • name Michael Wood
    organization Hewlett-Packard
  • name Sushant Kumar Singh
    organization Hewlett-Packard
description Buffer overflow in the Software Distributor utilities for HP-UX B.11.00 and B.11.11 allows local users to execute arbitrary code via a long LANG environment variable to setuid programs such as (1) swinstall and (2) swmodify.
family unix
id oval:org.mitre.oval:def:5466
status accepted
submitted 2008-07-09T16:48:33.000-04:00
title HP-UX Running Software Distributor (SD), Local Increased Privileges.
version 36
refmap via4
bid 8986
bugtraq 20031113 NSFOCUS SA2003-07: HP-UX Software Distributor Buffer Overflow Vulnerability
hp HPSBUX0311-293
vulnwatch 20031113 NSFOCUS SA2003-07: HP-UX Software Distributor Buffer Overflow Vulnerability
xf hp-sd-utilities-bo(13623)
Last major update 11-10-2017 - 01:29
Published 15-12-2003 - 05:00
Back to Top