ID CVE-2002-1568
Summary OpenSSL 0.9.6e uses assertions when detecting buffer overflow attacks instead of less severe mechanisms, which allows remote attackers to cause a denial of service (crash) via certain messages that cause OpenSSL to abort from a failed assertion, as demonstrated using SSLv2 CLIENT_MASTER_KEY messages, which are not properly handled in s2_srvr.c.
Vulnerable Configurations
  • OpenSSL Project OpenSSL 0.9.6e
Base: 5.0 (as of 01-01-2004 - 00:00)
nessus via4
  • NASL family Web Servers
    description According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.6f. A remote attacker can trigger a denial of service by sending a specially crafted SSLv2 CLIENT_MASTER_KEY message.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 17747
    published 2012-01-04
    reporter Tenable
    title OpenSSL < 0.9.6f Denial of Service
  • NASL family Red Hat Local Security Checks
    NASL id REDHAT-RHSA-2002-157.NASL
    description Updated OpenSSL packages are available which fix several serious buffer overflow vulnerabilities. OpenSSL is a commercial-grade, full-featured, and Open Source toolkit which implements the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well as a full-strength general purpose cryptography library. A security audit of the OpenSSL code sponsored by DARPA found several buffer overflows in OpenSSL which affect versions 0.9.7 and 0.9.6d and earlier : 1. The master key supplied by a client to an SSL version 2 server could be oversized, causing a stack-based buffer overflow. This issue is remotely exploitable. Services that have SSLv2 disabled would not be vulnerable to this issue. (CVE-2002-0656) 2. The SSLv3 session ID supplied to a client from a malicious server could be oversized and overrun a buffer. This issue looks to be remotely exploitable. (CVE-2002-0656) 3. Various buffers used for storing ASCII representations of integers were too small on 64 bit platforms. This issue may be exploitable. (CVE-2002-0655) A further issue was found in OpenSSL 0.9.7 that does not affect versions of OpenSSL shipped with Red Hat Linux (CVE-2002-0657). A large number of applications within Red Hat Linux make use the OpenSSL library to provide SSL support. All users are therefore advised to upgrade to the errata OpenSSL packages, which contain patches to correct these vulnerabilities. NOTE : Please read the Solution section below as it contains instructions for making sure that all SSL-enabled processes are restarted after the update is applied. Thanks go to the OpenSSL team and Ben Laurie for providing patches for these issues.
    last seen 2019-02-21
    modified 2018-11-15
    plugin id 12315
    published 2004-07-06
    reporter Tenable
    title RHEL 2.1 : openssl (RHSA-2002:157)
refmap via4
bugtraq 20031002 New OpenSSL remote vulnerability (issue date 2003/10/02)
Last major update 17-10-2016 - 22:27
Published 17-11-2003 - 00:00
Back to Top